log_full.sh run as PRDADM
Posted in 2000
Topics: Backup & Restore, Installation, Setup & Upgrades, Logging & Checkpoints
I apologize for the long posting but I have to make sure that I get
everything put in this posting.
I have an SAP/Informix installation. PRDADM is the sidadm id. My
customer just this past weekend migrated from a K-class hp box to an
N-class box. After the move the problem started occurring. The problem
is that when a logical log fills up the log_full.sh script gets
executed. This scripts returns the following messages:
Contents of online message log:
Process exited with return code 130: /bin/sh /bin/sh -c
/informix/PRD/etc/log_full.sh 2 23 "Logical Log 74891 Complete."
"Logical
Log 74891 Complete."
Contents of /tmp/bar_act.log
2000-10-26 09:44:35 10644 10643 /informix/PRD/bin/onbar_d -l
2000-10-26 09:44:35 10644 10643 ERROR: Unable to open connection to
server: could not fork server connection.
Now, when I run the script from the command line as PRDADM I get the
following messages:
Contents of online message log:
12:16:38 Logical Log 74596 - Backup Started
12:17:25 Logical Log 74596 - Backup Aborted
Aborted by client.
Contents of /tmp/bar_act.log
2000-10-23 12:16:37 16070 16060 ERROR: You must be user root or
informix to run ON-Bar
2000-10-23 12:16:37 16070 16060 /informix/PRD/bin/onbar_d -l
2000-10-23 12:16:38 16070 16060 Begin backup logical log 74596.
2000-10-23 12:16:38 16070 16060 Successfully connected to Storage
Manager.
2000-10-23 12:17:25 16070 16060 SQL -275 No INSERT permission.
2000-10-23 12:17:30 16070 16060 SQL -275 No INSERT permission.
Contents of /var/opt/omni/log/informix.log
12:16:44 : (16070) IBK-bsa: [Normal] From: OB2BAR@smprd "smfloatprdshm"
Time: 10/23/00 12:16:44
Starting OB2BAR Backup: /smfloatprdshm/1/74596 (logical logs)
12:16:44 : (16070) IBK-bsa: [Normal] SessionID : 2000/10/23-0040
12:17:25 : (16070) IBK-bsa: [Normal] From: OB2BAR@smprd "smfloatprdshm"
Time: 10/23/00 12:17:25
Completed OB2BAR Backup: /smfloatprdshm/1/74596 (logical logs)
The script, log_full.sh, getting automatically run returns a different
message than running the same script from the command line. I should
also state that the command line execution shows that according to
omniback the log is backed up. However, Informix thinks it has aborted.
My sysadmin has looked at omniback and tells me that everything looks
okay in omniback. I have been going down the path of thinking that there
is something wrong with file permissions/modes. Also, I checked out test
and dev environments and the sysutils databases in both dev/test have
the same permissions on the tables as prod does. I have compared file
permissions on the onbar files in the bin directory and they are
-rwsr-sr-x 1 root informix 2103 Aug 16 1999 onbar
-rwsr-sr-x 1 root informix 1871907 Aug 16 1999 onbar_d
If there are any ideas, I would greatly appreciate any help.
TIA, Gary
Sent via Deja.com http://www.deja.com/
Before you buy.
When you run as PRDADM from the command line, it appears as though what is
failing is the update of OnBar tables in sysutils. That would make sense,
since prdadm probably does not have update rights to the sysutils database.
As for the error when the alarm program runs, I don't have a clue. I
notice, however, that (on my systems) the sticky bit is not turned on for
the onbar script. That may or may not cause problems, but not sure.
HTH,
Doug
<fitr0912@my-deja.com> wrote in message news:8t9otb$pqh$1@nnrp1.deja.com...
> I apologize for the long posting but I have to make sure that I get
> everything put in this posting.
>
> I have an SAP/Informix installation. PRDADM is the sidadm id. My
> customer just this past weekend migrated from a K-class hp box to an
> N-class box. After the move the problem started occurring. The problem
> is that when a logical log fills up the log_full.sh script gets
> executed. This scripts returns the following messages:
>
> Contents of online message log:
> Process exited with return code 130: /bin/sh /bin/sh -c
> /informix/PRD/etc/log_full.sh 2 23 "Logical Log 74891 Complete."
> "Logical
> Log 74891 Complete."
>
> Contents of /tmp/bar_act.log
> 2000-10-26 09:44:35 10644 10643 /informix/PRD/bin/onbar_d -l
> 2000-10-26 09:44:35 10644 10643 ERROR: Unable to open connection to
> server: could not fork server connection.
>
> Now, when I run the script from the command line as PRDADM I get the
> following messages:
>
> Contents of online message log:
> 12:16:38 Logical Log 74596 - Backup Started
> 12:17:25 Logical Log 74596 - Backup Aborted
> Aborted by client.>
> Contents of /tmp/bar_act.log
> 2000-10-23 12:16:37 16070 16060 ERROR: You must be user root or
> informix to run ON-Bar
> 2000-10-23 12:16:37 16070 16060 /informix/PRD/bin/onbar_d -l
> 2000-10-23 12:16:38 16070 16060 Begin backup logical log 74596.
> 2000-10-23 12:16:38 16070 16060 Successfully connected to Storage
> Manager.
> 2000-10-23 12:17:25 16070 16060 SQL -275 No INSERT permission.
> 2000-10-23 12:17:30 16070 16060 SQL -275 No INSERT permission.
>
> Contents of /var/opt/omni/log/informix.log
> 12:16:44 : (16070) IBK-bsa: [Normal] From: OB2BAR@smprd "smfloatprdshm"
> Time: 10/23/00 12:16:44
> Starting OB2BAR Backup: /smfloatprdshm/1/74596 (logical logs)
>
> 12:16:44 : (16070) IBK-bsa: [Normal] SessionID : 2000/10/23-0040
> 12:17:25 : (16070) IBK-bsa: [Normal] From: OB2BAR@smprd "smfloatprdshm"
> Time: 10/23/00 12:17:25
> Completed OB2BAR Backup: /smfloatprdshm/1/74596 (logical logs)
>
>
> The script, log_full.sh, getting automatically run returns a different
> message than running the same script from the command line. I should
> also state that the command line execution shows that according to
> omniback the log is backed up. However, Informix thinks it has aborted.
> My sysadmin has looked at omniback and tells me that everything looks
> okay in omniback. I have been going down the path of thinking that there
> is something wrong with file permissions/modes. Also, I checked out test
> and dev environments and the sysutils databases in both dev/test have
> the same permissions on the tables as prod does. I have compared file
> permissions on the onbar files in the bin directory and they are
> -rwsr-sr-x 1 root informix 2103 Aug 16 1999 onbar
> -rwsr-sr-x 1 root informix 1871907 Aug 16 1999 onbar_d
>
>
> If there are any ideas, I would greatly appreciate any help.
>
> TIA, Gary
>
>
> Sent via Deja.com http://www.deja.com/
> Before you buy.