RE: Problems with Data Replication (WGS)
Posted in 2000
Helmut,
Do you have a shutdown script in place on the primary, to properly shutdown
the db server? Is it working properly at reboot time? I would suggest the
following to shutdown the primary instance:
-- onmode -uy \\
-- onmode -l \\ these should help ensure logs on primary are
-- onmode -c / flushed to secondary prior to instance down.
-- sleep 30 /
-- onmode -ky
If this doesn't help, you might try bouncing the secondary at 02:59 - 03:10.
You might also see if there's any outstanding bugs regarding HDR and that
"Receive Btree error" on the secondary... I know there was a bug out there
for a long time (can't recall the #) regarding HDR and inconsistent indices.
-- rarely happened, and just on one application that has now been long
retired.
HTH,
Paul Mosser
-----Original Message-----
From: Helmut Leininger [mailto:h.leininger@bull.at]
Sent: Tuesday, October 03, 2000 4:42 AM
To: informix-list@iiug.org
Subject: Problems with Data Replication (WGS)
Hi,
We are using Data Replication of Workgroup Server on AIX systems.
For some other reasons the primary server is rebooted every day at 3:00
in the morning. After the reboot sometimes (about once a week) we have
replication problems and the primary server (ESCKV2) seems to be blocked
(does not accept sessions).
Up to now, we have not found a good way to 1) avoid this situation and
2) reactivate DR.
Any ideas?
used protocol between the servers is onsoctcp, Informix versions are
equal, no apparent sqlhosts problems.
DR Settings:
DRAUTO 0
DRTIMEOUT 30
DRINTERVAL 10
Logs:
server ESCKV2
Thu Sep 21 03:08:24 2000
03:08:24 Event alarms enabled. ALARMPROG = '/informix/etc/log_full.sh'
03:08:30 DR: DRAUTO is 0 (Off)
03:08:30 AIX MP latch code enabled
03:08:30 Requested shared memory segment size rounded from 796KB to800KB
03:08:30 Informix Dynamic Server Version 7.31.UC5 Software SerialNumber AAC#J915528
03:08:31
03:08:31
03:08:32
03:08:34 Informix Dynamic Server Initialized -- Shared MemoryInitialized.
03:08:34 DR: Trying to connect to secondary server ...
03:08:38 DR: Primary server connected
03:08:38 DR: Receive error
03:08:38 DR: Failure recovery error (2)
03:08:39 Physical Recovery Started.
03:08:39
03:08:40 Physical Recovery Complete: 0 Pages Restored.
03:08:40 Logical Recovery Started.
03:08:40 DR: Turned off on primary server
server ESCKVBO
Thu Sep 21 03:00:32 2000
03:00:32 DR: Receive error
03:00:32 DR: Receive Btree error
03:00:32 DR: Turned off on secondary server
03:08:38 DR: Server state incompatible
07:32:22 DR: Server state incompatible
TIA
Helmut Leininger
Bull AG / Vienna
Open Systems Support
Email: h.leininger@bull.at
helmut.leininger@bull.net
This opinion is mine and not necessarily that of my employer.
No guarantees whatsoever.