Re: turning on KAIO
Posted in 2000
Topics: Installation, Setup & Upgrades, Platform-Specific Issues
From: Steven <steven_lee@jjsea.com> > >Just managed to upgrade my IDS from 7.24UC4X1 to 7.30UC7XB on HP-UX 11. > >Was trying to turn on KAIO by doing the following > >added >setenv KAIOON 1 >setenv IFMX_HPKAIO_NUM_REQ 2300 > >but was unable to start up my IDS. > >From the documentation, I seems to need HP KAIO driver "asyncdsk" but was >not able to find any patch resembling this anywhere on HP website. >Anyone got any idea on how I may proceed? Isn't it a mknod? >Btw, once, if, KAIO is started, I can reduce the number of aio vps to 2 or >something like that? Yep. ______________________________________________________ Get Your Private, Free Email at http://www.hotmail.com
in article 898qqe$n2b$1@news.xmission.com, Obnoxio The Clown at
obnoxio@hotmail.com wrote on 26/02/2000 10:41 PM:
>
> From: Steven <steven_lee@jjsea.com>
>>
>> Just managed to upgrade my IDS from 7.24UC4X1 to 7.30UC7XB on HP-UX 11.
>>
>> Was trying to turn on KAIO by doing the following
>>
>> added
>> setenv KAIOON 1
>> setenv IFMX_HPKAIO_NUM_REQ 2300
>>
>> but was unable to start up my IDS.
>>
>> From the documentation, I seems to need HP KAIO driver "asyncdsk" but was
>> not able to find any patch resembling this anywhere on HP website.
>> Anyone got any idea on how I may proceed?
>
> Isn't it a mknod?
>
>> Btw, once, if, KAIO is started, I can reduce the number of aio vps to 2 or
>> something like that?
>
> Yep.
> ______________________________________________________
> Get Your Private, Free Email at http://www.hotmail.com
>
Tried the following based on the release notes.
1. su root
2. /usr/sbin/mknod /dev/async c 101 4
3. chmod 0666 /dev/async
do a "ls -al", I get the following
crw-rw-rw- 1 root sys 101 0x000004 Feb 27 03:15 async
When I tried to "oninit", the online.log file shows the following
03:17:39 Event alarms enabled. ALARMPROG = '/informix/D01/etc/no_log.sh'
03:17:45 DR: DRAUTO is 0 (Off)
03:17:45 Requested shared memory segment size rounded from 588KB to 592KB
03:17:45 Requested shared memory segment size rounded from 588KB to 592KB
03:17:45 Requested shared memory segment size rounded from 588KB to 592KB
03:17:45 Informix Dynamic Server Version 7.30.UC7XB Software Serial Number
03:17:45 Can't open /dev/async. KAIO disabled
03:17:45 Can't open /dev/async. KAIO disabled
03:17:45 Can't open /dev/async. KAIO disabled
03:17:45 Can't open /dev/async. KAIO disabled
03:17:45 Assert Failed: kaiothread() ERROR
03:17:45 Informix Dynamic Server Version 7.30.UC7XB
03:17:45 Who: Session(0, @, 0, 0)
Thread(30, kaio, 0, 7)
File: kaio.c Line: 2048
03:17:45 stack trace for pid 920 written to /tmp/af.1e26d8
And then IDS will not be started at all.
Is it the way that I use mknod is wrong? or that the permission on
/dev/async is wrong?
Thanks again for all the help.
Steven
>Tried the following based on the release notes.
>1. su root
>2. /usr/sbin/mknod /dev/async c 101 4
>3. chmod 0666 /dev/async
>
>
>do a "ls -al", I get the following
>crw-rw-rw- 1 root sys 101 0x000004 Feb 27 03:15 async
>
>
>When I tried to "oninit", the online.log file shows the following
>03:17:39 Event alarms enabled. ALARMPROG = '/informix/D01/etc/no_log.sh'
>03:17:45 DR: DRAUTO is 0 (Off)
>03:17:45 Requested shared memory segment size rounded from 588KB to 592KB
>03:17:45 Requested shared memory segment size rounded from 588KB to 592KB
>03:17:45 Requested shared memory segment size rounded from 588KB to 592KB
>03:17:45 Informix Dynamic Server Version 7.30.UC7XB Software Serial Number
>03:17:45 Can't open /dev/async. KAIO disabled
>03:17:45 Can't open /dev/async. KAIO disabled
>03:17:45 Can't open /dev/async. KAIO disabled
>03:17:45 Can't open /dev/async. KAIO disabled
You need to build a new kernel which has the async driver linked in. By
default, it isn't on HP-UX. the easiest way to do this is via SAM. It's
pretty trivial.
And yes, you can then reduce the number of aiovps to 1.
Neil