System Commands across a Network
Posted in 2000
Hi
I have a multiple servers each running the same application
and the using the same database ( structurally ). I have set
up the .rhosts file on each machine and can connect to any
of the machines using dbaccess. The username and password is
identical on all the machines. Each machine is running
7.30UC3 and AIX4.2
I have a stored procedure do_command() which basically
executes a Unix command.
If I login to machine a connect to a database and execute
the SP everything works fine.
If I go to a different machine and through dbaccess
execute the following
DATABASE someDB@machineB;
EXECUTE PROCEDURE do_command();
I get Connected to the new database successful and the SP
fails with 668. I know 668 is often just thrown up for reasons
other than those specified in finderr 668 but I have also started
debug file and traces on the SP. I am not sure if I have missed
anything in the network configuration but everything else seems
to work fine.
I can connect to any machine and run any SP provided the SP doesn't
have a SYSTEM statement.
Any ideas???
Jo
___________________________________________________________________________
This email is confidential and intended solely for the use of the
individual to whom it is addressed. Any views or opinions presented are
solely those of the author and do not necessarily represent those of
Sema Group.
If you are not the intended recipient, be advised that you have received this
email in error and that any use, dissemination, forwarding, printing, or
copying of this email is strictly prohibited.
If you have received this email in error please notify the Sema Group
Helpdesk by telephone on +44 (0) 121 627 5600.
___________________________________________________________________________