semaphore tuning
Posted in 2005
Topics: Performance & Tuning, Platform-Specific Issues
--0-422229996-1106261911=:2197 Content-Type: text/plain; charset=us-ascii We are running Informix9.4-UC4 on Solaris 9. We are getting intermittent semctl: errno = 22 errors that are causing assert failures. Our current kernel settings for semaphores are: set semsys:seminfo_semmap=64 set semsys:seminfo_semmni=4096 set semsys:seminfo_semmns=4096 set semsys:seminfo_semmnu=4096 set semsys:seminfo_semume=64 set semsys:seminfo_semmsl=500 set shmsys:shminfo_shmmax=4294967296 set shmsys:shminfo_shmmin=100 set shmsys:shminfo_shmmni=500 set shmsys:shminfo_shmseg=100 Is there any recommendation to determine what to up the semaphore values to ? Which value is it, is it the semmns value ? Thanks, Floyd ======================== -<<Floyd Wellershaus>>- Database Administrator Unix Administrator email: fwellers@yahoo.com Work: 703-733-4126 Pager: 703-705-9241 Email Pager: 7037059241@my2way.com Home: 703-430-0805 Cell: 703-477-6045 ======================== --0-422229996-1106261911=:2197 Content-Type: text/html; charset=us-ascii <DIV>We are running Informix9.4-UC4 on Solaris 9.</DIV> <DIV>We are getting intermittent semctl: errno = 22 errors that are causing assert failures.</DIV> <DIV> </DIV> <DIV>Our current kernel settings for semaphores are:</DIV> <DIV>set semsys:seminfo_semmap=64<BR>set semsys:seminfo_semmni=4096<BR>set semsys:seminfo_semmns=4096<BR>set semsys:seminfo_semmnu=4096<BR>set semsys:seminfo_semume=64<BR>set semsys:seminfo_semmsl=500<BR>set shmsys:shminfo_shmmax=4294967296<BR>set shmsys:shminfo_shmmin=100<BR>set shmsys:shminfo_shmmni=500<BR>set shmsys:shminfo_shmseg=100<BR></DIV> <DIV>Is there any recommendation to determine what to up the semaphore values to ? Which value is it, is it the semmns value ?</DIV> <DIV> </DIV> <DIV>Thanks,</DIV> <DIV>Floyd</DIV> <DIV> </DIV><BR><BR><DIV> <DIV>========================<BR>-<<Floyd Wellershaus>>-<BR>Database Administrator<BR>Unix Administrator</DIV> <DIV><BR>email: <A href="mailto:fwellers@yahoo.com">fwellers@yahoo.com</A><BR>Work: 703-733-4126</DIV> <DIV>Pager: 703-705-9241 </DIV> <DIV>Email Pager: <A href="mailto:7037059241@my2way.com">7037059241@my2way.com</A></DIV> <DIV>Home: 703-430-0805</DIV> <DIV>Cell: 703-477-6045<BR>========================</DIV></DIV> --0-422229996-1106261911=:2197-- sending to informix-list
I think your AF is the cause of the semctl errors in the log file, not the semctl erro being the causeo fthe AF. What is probably happening is the enine coz down but some client is still trying to access the serever causing the semctl error. As others have suggested, contact your support vendor.