RE: DR problems after breakdown
Posted in 1999
Dunno if HDR has changed in 7.31, but in the three server pairs that I
administer (which are all on 7.24 right now), we have DRAUTO=0, and whenever
the secondary goes down (or I have to TAKE it down, for some reason or
other), as soon as I bring it back up with JUST an "oninit" (no onmode
command), it pings, reconnects, and re-synchronizes with the primary.
Evidently, the DR type is saved and "remembered" when the server comes back
up. Maybe, Frederik, it's your "onmode" command after the oninit that is
"confusing" the secondary??????
BTW, make sure that all of your DRxxx onconfig parameters are set
identically on primary and secondary (see p. 26-9 of the Admin. Guide, ver.
7.3).
HTH
paul Mosser
-----Original Message-----
From: Woodall Con [mailto:cwoodall@vth.colostate.edu]
Sent: Thursday, October 21, 1999 1:09 PM
To: Frederik Ramm
Cc: informix-list@iiug.org
Subject: Re: DR problems after breakdown
You might try splashing around in the manual for the onconfig Data
Replication Variables expecially the DRAUTO option. At various
times we have been in the same state you describe running AIX. And
I believe we were using DRAUTO = 0 for manual. We now use DRAUTO = 1 Now
we almost always get a reconnection after simply
from the oninit. On occasion we will get a failure to reconnect with
errors related to inconsistencies between the primary and the secondary.
I believe we only require the onmode command after we have started
replication from a level zero archive with the ontape -p.
Also, you might take a careful look at the entries in your online.log
file before you tried the DR restart. They might provide a clue to
your porblem.
Be careful to read all the implications of the DRAUTO setting!
Good luck
Con Woodall
Colorado State University Veterinary Teaching Hospital
Computer Services
cwoodall@vth.colostate.edu
970-491-1244
On 21 Oct 1999, Frederik Ramm wrote:
> Hi,
>
> I have a problem with data replication (HDR). Setting it up works,
> and everything runs as expeced; but when the secondary crashes and
> I try to restart it (oninit, after that onmode -d secondary...), I
> only get:
>
> 11:00:33 DR: new type = secondary, primary server name = prim_tcp
> 11:00:33 DR: Trying to connect to primary server ...
> 11:00:36 DR: Secondary server connected
> 11:00:37 DR: Failure recovery from disk in progress ...
> 11:00:37 DR: Failure during start of logical restore (1)
> 11:00:37 DR: Failure recovery error (6)
> 11:00:38 DR: Turned off on secondary server
> 11:00:38 DR: Failure during start of logical restore (1)
> 11:00:38 DR: new type = standard>
> I.e. it fails to start up the replication and acts as a standalone
> server. I have to do a complete backup of the primary and re-initialize
> the secondary with it every time.
>
> I am using IDS 7.31U on Solaris/x86.
>
> Thanks for any enlightenment,
> Frederik
>
> --
> Frederik Ramm (frederik@remote.org)
>