Ken,
This sounds strange, but I have had to logout and re-login as Informix to
re-start the DB engine sometimes!
I had a similar problem with -25580 when I was installing OWS. But, since
your DB was running before, I assume that you just have a leftover
memory/process problem.
Of course, restarting the Server (the Unix one) is the "cleanest" way to
reset everything...
Steve
--
Steven L Cooper
Manager, Systems Engineering
---------------------------------------
The views expressed here are mine and
you can't have them...unless you agree!
Ken Rothman <krothman@cs.brandeis.edu> wrote in article
<64f7l0$bbc$1@new-news.cc.brandeis.edu>...
>
> Informix Novice Question:
>
> I had to shut down my server (7.21 on Solaris) yesterday,
> which I did with onmode -k. It seemed to shut down cleanly.
>
> However, when I now attempt to restart it using oninit, I'm getting
> the following error:
>
> oninit: Fatal error in initializing ASF with 'ASF_INIT_DATA' flags;
> asfcode = '-25580'.
>
> and the log shows the following:
>
> Thu Nov 13 10:24:49 1997
>
> 10:24:49 Event alarms enabled. ALARMPROG =
'/home1/informix/log_full.sh'
> 10:24:52 DR: DRAUTO is 0 (Off)
> 10:24:52 shmget: [EEXIST][17]: key 52574805: shared memory alreadyexists
> 10:24:52 (2) shm creation of shmem segment failed>
>
> What can I do???
>
> --Ken
> krothman@exapps.com
> krothman@cs.brandeis.edu
>