Re: ISAM -172 (Unexpected Internal Error)
Posted in 1999
Topics: Error Codes & Troubleshooting
>From: "mmmm" <mmmmm@iiug.org>
>
>We are currently running some cleanup sql scripts and keep having this
>error.
>
>
>-240 and the ISAM -172 ISAM error occurs also.
>
>We perform all the oncheck's identified in the online.log and this
fixes the
>indexes it says are bad.
>
>Re-run the scripts and they fall over again after 20 deletes of a
>
>(DELETE FROM titles WHERE 1=1)
>
>This is extremely urgent and I have taken the database offline until I
can
>resolve this so if anyone can point me in a direction I would be
>most gratefule
Mmmmm... (no pun intended! :)
It sounds fairly severe. Is this in a transaction? Can we get more
specifics on your platform (version/OS/OS version, etc).
As an interim, drop the table and recreate it -- that will be much
faster than DELETEing every record in the table.
--
"I'll Be Back"
Obnoxio
************************************************
Sane? Hell, if I was sane, why would I be here?
Get Your Private, Free Email at http://www.hotmail.com
Yep - Thanks
Solaris 2.7
Informix SE 7.2
SUN Enterprise 3000 server
I have subsequently tried something
I did a dbexport of the whole database
loaded it up onto my SUN Ultra 10, 2.7, 7.2SE and everything works fine.??
The SQL DELETE example is something I tried in dbaccess to see if dbaccess
gave me the error. I am in fact running one of my ESQLC programs to tidy
up the database and get rid of data that is not required anymore.
The online.log and af files are not very helpful, to me as it's all HEX to
me....
Your help is very much appeciated.......
mmmm (not sure why my system did that )
Ta
Mike
>Obnoxio The Clown wrote in message <7dnqug$hh6$1@news.xmission.com>...
>
>>From: "mmmm" <mmmmm@iiug.org>
>>
>>We are currently running some cleanup sql scripts and keep having this
>>error.
>>
>>
>>-240 and the ISAM -172 ISAM error occurs also.
>>
>>We perform all the oncheck's identified in the online.log and this
>fixes the
>>indexes it says are bad.
>>
>>Re-run the scripts and they fall over again after 20 deletes of a
>>
>>(DELETE FROM titles WHERE 1=1)
>>
>>This is extremely urgent and I have taken the database offline until I
>can
>>resolve this so if anyone can point me in a direction I would be
>>most gratefule
>
>Mmmmm... (no pun intended! :)
>
>It sounds fairly severe. Is this in a transaction? Can we get more
>specifics on your platform (version/OS/OS version, etc).
>
>As an interim, drop the table and recreate it -- that will be much
>faster than DELETEing every record in the table.
>
>--
>"I'll Be Back"
>Obnoxio
>
>************************************************
>Sane? Hell, if I was sane, why would I be here?
>
>
>Get Your Private, Free Email at http://www.hotmail.com
Related threads
- Re(2): Write cache hits slipping !
- same View fails to run under IDS 10
- number of extents
- ONCONFIG file only for server or for informix client