RE: [ifxmaillist] ISAM Error 100 on dbexport
Posted in 2000
Topics: Error Codes & Troubleshooting, Migration, Import/Export & Data Conversion
It is a bug in both dbschema and dbexport.
It occurs when a table has constraints and/or indexes not owned by the owner
of the table. There may be other circumstances that cause this since some
tables with mixed owners do not give this error.
Last time I spoke to Tech Support it was unlikely to be fixed. It did not
have a bug number since it could not be reliably produced.
The resolution is to drop and re-create the table! (Get rid of the mixed
owners).
MW
-----Original Message-----
From: owner-ifxmaillist@quanta.co.nz
[mailto:owner-ifxmaillist@quanta.co.nz]On Behalf Of
azteczenith@my-deja.com
Sent: Thursday, May 04, 2000 1:07 PM
To: informix-list@iiug.org
Subject: [ifxmaillist] ISAM Error 100 on dbexport
I am getting an error 100 (Duplicate records with unique index) during
dbexport.
I am getting this even though there are no records in the table. I also
get this message on tables with no unique indexes or serial type fields.
The only way I could bypass this message was to drop and recreate the
table. But when I do that the problem occurs for the next table...
I am on SE 7.2X on Linux. Database does have logging turned on.
Sent via Deja.com http://www.deja.com/
Before you buy.
Thanks for your reply. I have recreated the database since then and
done a dbexport. This time everything seemed to work fine.
I have used only one user consistently so there is no question of ever
having two owners. But you are right I did recently add some
constraints. So it could be bug related to constraints and the way they
are set up. I used dbaccess to set up constraints, mainly primary and
unique, though I do have some referential also.
JB
In article <8eqv8u$ncm$1@news.xmission.com>,
<murray@quanta.co.nz> wrote:
>
> It is a bug in both dbschema and dbexport.
> It occurs when a table has constraints and/or indexes not owned by
the owner
> of the table. There may be other circumstances that cause this since
some
> tables with mixed owners do not give this error.
>
> Last time I spoke to Tech Support it was unlikely to be fixed. It
did not
> have a bug number since it could not be reliably produced.
>
> The resolution is to drop and re-create the table! (Get rid of the
mixed
> owners).
>
> MW
>
> -----Original Message-----
> From: owner-ifxmaillist@quanta.co.nz
> [mailto:owner-ifxmaillist@quanta.co.nz]On Behalf Of
> azteczenith@my-deja.com
> Sent: Thursday, May 04, 2000 1:07 PM
> To: informix-list@iiug.org
> Subject: [ifxmaillist] ISAM Error 100 on dbexport
>
> I am getting an error 100 (Duplicate records with unique index) during
> dbexport.
> I am getting this even though there are no records in the table. I
also
> get this message on tables with no unique indexes or serial type
fields.
> The only way I could bypass this message was to drop and recreate the
> table. But when I do that the problem occurs for the next table...
>
> I am on SE 7.2X on Linux. Database does have logging turned on.
>
> Sent via Deja.com http://www.deja.com/
> Before you buy.
>
>
Sent via Deja.com http://www.deja.com/
Before you buy.
You can use my dbschema replacement utility, myschema, to get a schema from
such a database and it will optionally remove all the owner names so that
when you recreate the database all objects will be owned by one user. In
addition if you get my package, utils4_ak, it contains awk scripts that will
post process a dbschema/myschema schema file and create unload and load
scripts. For larger tables it would not be hard to use these as templates
to create a load script that uses Jonathan Leffler's sqlreload which can
do partial commits to avoid long transaction problems. (Hmm sounds like
a new package! ;-) Myschema is contained in the package utils2_ak and a
new version was installed yesterday and sqlreload is part of the sqlcmd
package.
Art S. Kagel
Murray Wood wrote:
>
> It is a bug in both dbschema and dbexport.
> It occurs when a table has constraints and/or indexes not owned by the owner
> of the table. There may be other circumstances that cause this since some
> tables with mixed owners do not give this error.
>
> Last time I spoke to Tech Support it was unlikely to be fixed. It did not
> have a bug number since it could not be reliably produced.
>
> The resolution is to drop and re-create the table! (Get rid of the mixed
> owners).
>
> MW
>
> -----Original Message-----
> From: owner-ifxmaillist@quanta.co.nz
> [mailto:owner-ifxmaillist@quanta.co.nz]On Behalf Of
> azteczenith@my-deja.com
> Sent: Thursday, May 04, 2000 1:07 PM
> To: informix-list@iiug.org
> Subject: [ifxmaillist] ISAM Error 100 on dbexport
>
> I am getting an error 100 (Duplicate records with unique index) during
> dbexport.
> I am getting this even though there are no records in the table. I also
> get this message on tables with no unique indexes or serial type fields.
> The only way I could bypass this message was to drop and recreate the
> table. But when I do that the problem occurs for the next table...
>
> I am on SE 7.2X on Linux. Database does have logging turned on.
>
> Sent via Deja.com http://www.deja.com/
> Before you buy.