HELP!!! I need to restore a "level 0" backup.
Posted in 2000
Topics: Backup & Restore, Storage & Space Management, Server Administration
Hello,
I've got a system crash. (Sco OpenServer 5.0.5), I need to restore a level 0
backup of my database (Informix On-line WorkgroupServer 7.20). I have only
one tape with level 0 backup (ontape -s -L0), and I have lost the
configuration file (onconfig.ows).
I've restored the backup (ontape -r), but I've tried to check the database
(oncheck -cc) and the system shows the message:
Primary chunk and Mirror are bad.
I've tried to go on-line mode:
$ onmode -k
...
$ oninit
show the message:
Fatal error in shared memory initialization.
Can anybody help me ?
How can I to restore the bakup ?
Thanks in advance.
Hello,
I've got a system crash. (Sco OpenServer 5.0.5), I need to restore a level
0
backup of my database (Informix On-line WorkgroupServer 7.20). I have only
one tape with level 0 backup (ontape -s -L0), and I have lost the
configuration file (onconfig.ows).
I've restored the backup (ontape -r), but I've tried to check the database
(oncheck -cc) and the system shows the message:
Primary chunk and Mirror are bad.
I've tried to go on-line mode:
$ onmode -k
...
$ oninit
show the message:
Fatal error in shared memory initialization.
Can anybody help me ?
How can I to restore the bakup ?
Thanks in advance.
Francisco J. Cerdan.
Alianza Inform'tica
03600 ELDA
Alicante (Spain)
x-fjcerdan-x@alianzai.com
>
>
ppp wrote:
> Hello,
>
> I've got a system crash. (Sco OpenServer 5.0.5), I need to restore a level
> 0
> backup of my database (Informix On-line WorkgroupServer 7.20). I have only
> one tape with level 0 backup (ontape -s -L0), and I have lost the
> configuration file (onconfig.ows).
>
> I've restored the backup (ontape -r), but I've tried to check the database
> (oncheck -cc) and the system shows the message:
> Primary chunk and Mirror are bad.
>
> I've tried to go on-line mode:
>
> $ onmode -k
> ...
> $ oninit>
> show the message:
> Fatal error in shared memory initialization.>
> Can anybody help me ?
>
> How can I to restore the bakup ?
>
> Thanks in advance.
>
> Francisco J. Cerdan.
> Alianza Informática
>
> 03600 ELDA
> Alicante (Spain)
> x-fjcerdan-x@alianzai.com
>
> >
>
Hi,
Kill every process connected to the DB. Your engine is down.
Use "ipcs -a" and "ipcrm" . Must be clean 100% .
The crash of your engine is the source. "onmode -k" has no effect.
Then restart your engine.
Check the state of your DB before everything. Be carefully with restore ...
Do you have programs (esqlc c, c++ or ...) using shared memory and connecting
to DB ? Tell me.
We had bad problems with that.
Hi,
>
> Hello,
>
> I've got a system crash. (Sco OpenServer 5.0.5), I need to restore a level 0
> backup of my database (Informix On-line WorkgroupServer 7.20). I have only
> one tape with level 0 backup (ontape -s -L0), and I have lost the
> configuration file (onconfig.ows).
I hope you got it back already ?!?
Anyway, the configuration file is always backed up to tape.
It's stored on the second tape block, second page. The only
thing you should now is the tape block size. If you can't
remember your tape block size, you can try to find the
config page inside the first 128KB-256KB.
1st) dd if=/yourtapedevice of=/tmp/step1 bs=tapeblocksize count=2
2nd) strings /tmp/step1 > /tmp/step2
Edit the file /tmp/step2 , find the configuration
parameters and restore the parameters to the config file.
3rd) Ensure that you shut down your system and try to restore
the system via "ontape -r". Before you enter "y" to continue,
ensure that you've created the chunk pathnames ( raw devices )
and set up the permissions correctly.
4th) If the restore process will fail again, run "oncheck -pr"
and send the output - if any - to the NG. Additionally the
output of your message log file will conatin some important
information - send the last 100 messages to the NG, too.
Best regards,
Stefan
> I've restored the backup (ontape -r), but I've tried to check the database
> (oncheck -cc) and the system shows the message:
> Primary chunk and Mirror are bad.
>
> I've tried to go on-line mode:
>
> $ onmode -k
> ...
> $ oninit>
> show the message:
> Fatal error in shared memory initialization.>
> Can anybody help me ?
>
> How can I to restore the bakup ?
>
> Thanks in advance.
Hello, Thanks, Thanks, Thanks, .... My database is ok again. Best regards Francisco J. Cerdan.