Is a physical only whole backup possible?
Posted in 2000
Topics: Backup & Restore, Logging & Checkpoints, Versions, Editions & End-of-Life
I'm using IDS 7.31TC5 on Windows NT4. As an XBSA storage manager for
ONBar, I'm using the included ISM 2.20.
The Backup and Restore Guide states,
The advantage of using a whole-system backup is that you can restore
the storage spaces with or without the logical logs. Because the data
in all storage spaces is consistent in a whole-system backup, you do
not need to restore the logical logs to make the data consistent.
Given that I can restore a system to a previous physical state
using "onbar -r -p -w," is there a corresponding option to perform a
physical only whole backup?
I have tried "onbar -b -p -w," but ONBar only returns a command
synopsis. A physical only whole backup is possible by running
"onbar -b -w" while LTAPEDEV is set to NUL. However, the onbar process
returns error 131. According to the Backup and Restore Guide this
means "a failure occurred in the interface between ON-Bar and the
database server."
Is there a recommended way of performing a physical only whole backup
using ONBar? When error 131 is returned from "onbar -b -w," is there a
reliable method for determining if the physical portion of the backup
was performed successfully? If possible, I would like a method that
can be used within a Windows NT batch file.
Sent via Deja.com http://www.deja.com/
Before you buy.
A point-in-time restore, onbar -r -p -w..., requires that logical logs be
rolled
forward to the predetermined point. For this you need a whole system
backup
since the entire engine is to be restored and rolled forward to the logged
point in
time. There is no special backup for this, just a whole system backup.
Art S. Kagel
aaronluz@my-deja.com wrote:
> I'm using IDS 7.31TC5 on Windows NT4. As an XBSA storage manager for
> ONBar, I'm using the included ISM 2.20.
>
> The Backup and Restore Guide states,
>
> The advantage of using a whole-system backup is that you can restore
> the storage spaces with or without the logical logs. Because the data
> in all storage spaces is consistent in a whole-system backup, you do
> not need to restore the logical logs to make the data consistent.
>
> Given that I can restore a system to a previous physical state
> using "onbar -r -p -w," is there a corresponding option to perform a
> physical only whole backup?
>
> I have tried "onbar -b -p -w," but ONBar only returns a command
> synopsis. A physical only whole backup is possible by running
> "onbar -b -w" while LTAPEDEV is set to NUL. However, the onbar process
> returns error 131. According to the Backup and Restore Guide this
> means "a failure occurred in the interface between ON-Bar and the
> database server."
>
> Is there a recommended way of performing a physical only whole backup
> using ONBar? When error 131 is returned from "onbar -b -w," is there a
> reliable method for determining if the physical portion of the backup
> was performed successfully? If possible, I would like a method that
> can be used within a Windows NT batch file.
>
> Sent via Deja.com http://www.deja.com/
> Before you buy.
In article <38FB3EEA.FAF520E0@bloomberg.net>,
"Art S. Kagel" <kagel@bloomberg.net> wrote:
> A point-in-time restore, onbar -r -p -w..., requires that logical
logs be
> rolled
> forward to the predetermined point. For this you need a whole system
> backup
> since the entire engine is to be restored and rolled forward to the
logged
> point in
> time. There is no special backup for this, just a whole system
backup.
>
> Art S. Kagel
Thanks, Art. However, what I really want to know is why there is no
option to ON-Bar to perform a physical only whole backup. My client
would like to keep LTAPEDEV set to NUL, but doing so causes "onbar -b -
w" to exit with error 131 as soon as it attempts to backup the logical
logs. This error gets picked up by a script, which then reports the
entire backup as a failure.
I suppose I could change to script to ignore error code 131, but this
code could indicate any failure between ON-Bar and the database
server. I suppose I could parse the instance's error log for "Archive
on rootdbs, ... Completed," but I am hoping for a more direct method.
Aaron Luz
Sent via Deja.com http://www.deja.com/
Before you buy.
Aaron Luz wrote:
>
> In article <38FB3EEA.FAF520E0@bloomberg.net>,
> "Art S. Kagel" <kagel@bloomberg.net> wrote:
> > A point-in-time restore, onbar -r -p -w..., requires that logical
> logs be
> > rolled
> > forward to the predetermined point. For this you need a whole system
> > backup
> > since the entire engine is to be restored and rolled forward to the
> logged
> > point in
> > time. There is no special backup for this, just a whole system
> backup.
> >
> > Art S. Kagel
>
> Thanks, Art. However, what I really want to know is why there is no
> option to ON-Bar to perform a physical only whole backup. My client
> would like to keep LTAPEDEV set to NUL, but doing so causes "onbar -b -
> w" to exit with error 131 as soon as it attempts to backup the logical
> logs. This error gets picked up by a script, which then reports the
> entire backup as a failure.
Remember that if you do not back up your logical logs you CANNOT
restore the engine to the point of the crash with minimal loss.
The purpose of onbar/ontape/onarchive is for such restores and
extentions like point-in-time restore and physical restore are extra
features. Informix has always maintained these tools for this purpose
not for recovering from fumbling fingers. That is what tools like
dbexport/dbimport are for. This is why onbar requires you to back up
the logical logs and have LTAPEDEV directed to a real device/file.
If you really MUST fake it out just create a symbolic link to /dev/null
and set LTAPEDEV to that. Informix will not track the link to find out
if your clients are dumb enough (yes I think it is dumb to throw away
the logical logs and that's an opinion garnered from three years of
getting up at 3AM and working 60 hours straight with no further sleep
every few weeks to recover from some other fool's decision to toss the
logs not any high minded ideal) to toss the logs away.
> I suppose I could change to script to ignore error code 131, but this
> code could indicate any failure between ON-Bar and the database
> server. I suppose I could parse the instance's error log for "Archive
> on rootdbs, ... Completed," but I am hoping for a more direct method.
>
> Aaron Luz
>
> Sent via Deja.com http://www.deja.com/
> Before you buy.
--
Art S. Kagel & Family
kagel@erols.com