connecting to Informix 7.3 on Linux problem
Posted in 2012
Topics: Server Administration, Security, Permissions & Auditing, Networking & sqlhosts Configuration, Platform-Specific Issues
I need to connect some client software (SDK based) to an Informix 7.3 server
running on a Linux box. when I've started tweaking the server was rejecting
connections on the service port. now I narrowed down the problem to a -952
error "User's password is not correct for the database server.".
here I've noticed a strange behaviour of dbaccess, which I use locally (on
Linux). I go to the "Connection" option, select a database server and just
press ENTER for the user name to get a valid connection. but when I enter a
user name, I am asked for the password, I am entering the password and get the
same 952 error.
sqlhosts looks like:
fsrDBserver onipcshm fsr shmIDSservice
netDBserver onsoctcp 192.1.1.200 netDBservice
the behaviour is the same for both fsr and net servers.
thank you.
dbaccess will use a trusted or implicit connection when used locally if you
don't give it a username/password.
As the process is local, the authentication is already done....
If you're getting a 952 error I'd expect you're using the wrong password...
But I assume you checked that....
In any case:
- make sure you can authenticate the same user at the OS level (remotely
run a telnet/ssh against the machine and make sure you can connect
- give us the result of:
ls -liad $INFORMIXDIR
ls -lia $INFORMIXDIR/bin/oninit
- make sure you test it with SE-Linux turned off
- check/try that your password has no special (accented) characters
- check that your password has no more than 8 characters (these two options
are for debug purposes... if they solve your issue we'd need to better
understand the problem before applying a solution
This is all I'm recalling at the moment....
Regads
On Sat, Aug 18, 2012 at 9:03 AM, COSTIN OPROIU <costin.oproiu@gmail.com>wrote:
> I need to connect some client software (SDK based) to an Informix 7.3
> server
> running on a Linux box. when I've started tweaking the server was rejecting
> connections on the service port. now I narrowed down the problem to a -952
> error "User's password is not correct for the database server.".
>
> here I've noticed a strange behaviour of dbaccess, which I use locally (on
> Linux). I go to the "Connection" option, select a database server and just
> press ENTER for the user name to get a valid connection. but when I enter a
> user name, I am asked for the password, I am entering the password and get
> the
> same 952 error.
>
> sqlhosts looks like:
>
> fsrDBserver onipcshm fsr shmIDSservice
> netDBserver onsoctcp 192.1.1.200 netDBservice>
> the behaviour is the same for both fsr and net servers.
>
> thank you.
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--
Fernando Nunes
Portugal
http://informix-technology.blogspot.com
My email works... but I don't check it frequently...
--00248c768d867c5d9704c78a26e4
> make sure you can authenticate the same user at the OS level (remotely
run a telnet/ssh against the machine and make sure you can connect
that's the usual way I am accessing the server: connect with a PuTTY/ssh as a
standard Linux user then run dbaccess. I've already tested with fresh accounts
and very simple passwords.
> make sure you test it with SE-Linux turned off
afaik there is no SELinux on the machine.
> give us the result of:
[root@fsr /root]# ls -liad $INFORMIXDIR
541822 drwxr-x--- 19 root root 4096 Aug 17 19:22 .
[root@fsr /root]# ls -lia $INFORMIXDIR/bin/oninit
ls: /bin/oninit: No such file or directory
missing oninit could be the problem??? the fact is that on occasions dbaccess
says 'No such file or directory' after the 952 error, but not always it's not
reproducible.
thank you again and fingers crossed!
I am very sorry, I've sent you the test from the wrong window: [informix@fsr informix]$ ls -lia $INFORMIXDIR/bin/oninit 332177 -rwsr-sr-- 1 root informix 5210941 Oct 27 2001 /opt/informix/bin/oninit [informix@fsr informix]$ ls -liad $INFORMIXDIR/bin 331944 drwxrwxr-x 2 informix informix 4096 Jan 20 2003 /opt/informix/bin
after several epic attempts to solve the problem, including strace-ing both
server and dbaccess, I've remembered that the main goal was to quickly
establish a client server connection so I went for a trusted one (security is
not an important issue). so I can declare the problem solved.
one useful note: I am using IBM client SDK 3.70.TC5DE. I got a Setnet32 "Could
not open Registry" error. the solution was from datadirect's knowledgebase
site, article 3008:
"Check the INFORMIXSQLHOSTS variable in the Enviroment section of Setnet32 and
confirm the value is correct. If the value is correct, clear the value and
then try to set the Server and Host information."
thank you