Dbaccess Error : 25572: Network driver cannot bind a name to the port.
Posted in 2004
Topics: Server Administration, Networking & sqlhosts Configuration, Platform-Specific Issues, Versions, Editions & End-of-Life
Hi All
I am using IDS 9.2 on a solaris box
I get this error when i use dbaccess
25572: Network driver cannot bind a name to the port.
anybody know why i am getting this error
the entries in my sqlhosts file seem ok
sqlhosts file
#####################################
test_3 ontlitcp test_3 on_test_3
services file
######################################
on_test_3 1545/tcp
hosts file
######################################
ip_address hostname test_3 loghost
is there any other utility other than dbaccess
where we cud run queries
Thanks
Sudhir
sending to informix-list
Sudhir Sambrani wrote:
> Hi All
>
> I am using IDS 9.2 on a solaris box
>
> I get this error when i use dbaccess
>
> 25572: Network driver cannot bind a name to the port.>
> anybody know why i am getting this error
>
> the entries in my sqlhosts file seem ok
>
> sqlhosts file
> #####################################
> test_3 ontlitcp test_3 on_test_3>
>
> services file
> ######################################
> on_test_3 1545/tcp
>
>
> hosts file
> ######################################
> ip_address hostname test_3 loghost
>
>
> is there any other utility other than dbaccess
> where we cud run queries
>
>
>
> Thanks
> Sudhir
> sending to informix-list
Is it a new system?
Are you on Solaris 2.8?
If you migrated the OS to 2.8 please contact IBM technical support.
There was an issue with some versions of IBM Informix products on
Solaris 2.8 due to some changes in the TCP stack.
I don't recall the exact details, but I think it gave an error similar
to this. If possible try other connections like shared memory.
Regards.
Fernando Nunes wrote:
> Sudhir Sambrani wrote:
>
>> Hi All
>>
>> I am using IDS 9.2 on a solaris box
>>
>> I get this error when i use dbaccess
>>
>> 25572: Network driver cannot bind a name to the port.>>
>> anybody know why i am getting this error
>> the entries in my sqlhosts file seem ok
>> sqlhosts file
>> #####################################
>> test_3 ontlitcp test_3 on_test_3>>
>>
>> services file
>> ######################################
>> on_test_3 1545/tcp
>>
>>
>> hosts file
>> ######################################
>> ip_address hostname test_3 loghost
>>
>>
>> is there any other utility other than dbaccess
>> where we cud run queries
>>
>>
>>
>> Thanks
>> Sudhir
>> sending to informix-list
>
>
>
> Is it a new system?
> Are you on Solaris 2.8?
>
> If you migrated the OS to 2.8 please contact IBM technical support.
> There was an issue with some versions of IBM Informix products on
> Solaris 2.8 due to some changes in the TCP stack.
>
> I don't recall the exact details, but I think it gave an error similar
> to this. If possible try other connections like shared memory.
>
> Regards.
I would check your /etc/hosts file format, it usually looks something like :
127.0.0.1 localhost
192.168.0.5 ahost ahostalias