Upgrading to Infx 11.5
Posted in 2009
Topics: Storage & Space Management, Server Administration, Networking & sqlhosts Configuration, Versions, Editions & End-of-Life
Hi,
We are upgrading informix IDS from 7.3 to 11.5.
We have started this in development server.
We tried to bring IDS 11.5 up using the same 7.3 onconfig and sqlhosts file
and we could successfully bring up IDS 11.5.
But we are now not able to bring up IDS 7.3.
We tried to initialize using 'oninit -ivy' which fails with the following
message..
:
Starting tracing...succeeded
Initializing 8 flushers...succeeded
oninit: Not enough room in ROOT DBspace.
Requested 630638K, ONCONFIG value 'ROOTSIZE' 150000K.
oninit: Fatal error in shared memory initialization
//new_sigdev01/usr/att/informix/etc Mon Jun 8 04:51:06 CST 2009:
Please help.
-ivy recretes the instance !!
Although I supposed this is what you want to do...
Anyway I think that starting IDS 11.5 changed your original 7.3 onconfig...
check rootdbspace parameters there...
Do you have a backup of the 7.3 onconfig?
Or maybe growing ROOTSIZE inside onconfig fix your problem, it doesn´t
matter 'cause you are recreating the instance unless you don't space.
J.
2009/6/10 SASIKUMAR SUNDARAM <su_sasi@yahoo.com>
> Hi,
>
> We are upgrading informix IDS from 7.3 to 11.5.
>
> We have started this in development server.
>
> We tried to bring IDS 11.5 up using the same 7.3 onconfig and sqlhosts file
> and we could successfully bring up IDS 11.5.
>
> But we are now not able to bring up IDS 7.3.
>
> We tried to initialize using 'oninit -ivy' which fails with the following
> message..
>
> :
> Starting tracing...succeeded
> Initializing 8 flushers...succeeded
> oninit: Not enough room in ROOT DBspace.
>
> Requested 630638K, ONCONFIG value 'ROOTSIZE' 150000K.
> oninit: Fatal error in shared memory initialization
> //new_sigdev01/usr/att/informix/etc Mon Jun 8 04:51:06 CST 2009:
>
> Please help.
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--000e0cd2536cbfe9b2046bfdf7b3
Once you start 11.50 on an existing ROOTDB space (ie an existing instance)
IDS will modify several disk structures to those needed by the newer IDS
release and the disk contents will no longer be compatible with the earlier
release in general and certainly not after so large a version jump as 7.3x
to 11.50. What you have to do if you need to go back to the earlier release
is to start the instance with the new release (ie 11.50) and tell the engine
to revert the disk structures to the earlier format. This is the command to
go back to 7.31 (executed with the 11.50 engine online):
onmode -b 7.31
That will reverse the changes to the on-disk structures, preparing the
engine to restart using the 7.31 software, and will shutdown the instance.
After that you will be able to start the 7.31 software against this
instance.
NOTE: There are several gotcha's you have to consider when trying to revert
to an earlier version:
- You cannot have taken advantage of ANY features of the new version that
affect the format of the data on disk. So:
- No data types not supported by 7.31
- No large pages
- No chunks bigger than 2GB
- You cannot revert if any tables have any outstanding in-place alters.
If you did not check for these before you upgraded to 11.50, you MUST do so
before trying to revert. The reversion will fail if there are outstanding
alters and the instance may become unusable.
Art
Art S. Kagel
Oninit (www.oninit.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
On Wed, Jun 10, 2009 at 6:30 AM, SASIKUMAR SUNDARAM <su_sasi@yahoo.com>wrote:
> Hi,
>
> We are upgrading informix IDS from 7.3 to 11.5.
>
> We have started this in development server.
>
> We tried to bring IDS 11.5 up using the same 7.3 onconfig and sqlhosts file
> and we could successfully bring up IDS 11.5.
>
> But we are now not able to bring up IDS 7.3.
>
> We tried to initialize using 'oninit -ivy' which fails with the following
> message..
>
> :
> Starting tracing...succeeded
> Initializing 8 flushers...succeeded
> oninit: Not enough room in ROOT DBspace.
>
> Requested 630638K, ONCONFIG value 'ROOTSIZE' 150000K.
> oninit: Fatal error in shared memory initialization
> //new_sigdev01/usr/att/informix/etc Mon Jun 8 04:51:06 CST 2009:
>
> Please help.
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--001636c5c2f1e95956046bfe4236