Bug 104328 ? Bug 121447 ?
Posted in 1999
Topics: Storage & Space Management, Server Administration, Transactions, Locking & Isolation, Logging & Checkpoints, Networking & sqlhosts Configuration, Platform-Specific Issues
Hi list,
Here I go again.
My question is: Has anyone encountered Bugs 104328 and/or 121447
and if so what is the fix ?
Is there some place (URL) I should be looking at to keep up
with bugs instead of dumping my problems on the list ?
TIA,
Michael
michael_martin@komatsu.co.jp
--------------------------------------------------------------------
A rough outline of my latest adventure follows.
Database=INFORMIX-OnLine Version 7.23.UC4
OS= HP-UX 10.20
No. of cpus = 4
I got hit with a:
13:43:02 rsmirror.c, line 1662, thread 7, proc id 27425, INFORMIX-OnLine MustABORT Critical media failure.
Looking at the log before that there was an assertion failed:
13:33:07 Assertion failed:read_record:Deleted row ID= 20a, partnum =1e0002a
Followed by a whole bunch of KAIO errors eg:
13:33:10 KAIO: kaio_read error.KAIOCBP = ca9b76d0$B!"(BError number = 9
13:33:10 fildes = 13 (gfd 14), buf = ca4ce000, nbytes = 2048, offset = 6080
13:43:00 KAIO: kaio_write error. KAIOCBP = ca7fc140$B!"(BError number = 32
13:43:00 fildes = 4 (gfd 4), buf = c8a3d800, nbytes = 2048, offset = 413224960
Informix are telling me that the assertion faileds were probably caused by bugs.
QUOTE (Translated from Japanese by me... I may not know anything useful but
I can make stupid mistakes in English AND Japanese)
Bug: 104318 NUMCPUVP > 1 CAUSES DELETE STATEMENT WITH 3000+ CHARACTERS TO
ASSERT FAIL WITH -243/-172 READ_RECORD
Bug: 121447 READ_RECORD : DELETED ROWID = XXX PARTNUM = YYY, WHEN USER1
COMMITS A DELETE THAT IS IN USER2 REPEATABLE READ SET
Bug104318 occurs when NUMCPUVP > 1 and PDQ priority is set.
But although from onstat -a we can confirm NUMCPUVP > 1, at the time onstat -a
was run there were no sessions with PDQ set. Please confirm that there were
no sessions with PDQ set at the time the assertion failed occurred.
Bug104318 has been fixed in versions 7.30.UC9 and up.
Bug121447 occurs under the following conditions:
user1 user2
begin work
delete rowid
set isolation mode torepeatable read
set lock mode to wai
declare cursor
fetch
fetch
fetch
commit work
fetch
fetch
fetch
....
If there is a row lock on table partnum 0x1e0002a and you attempt the above
it is likely that you will get the problem.
We have no product which has the bug fixed in it but if you change your
tables from row locked to page locked it should fix it.
UNQUOTE
=========================================================================
$ onstat -c
INFORMIX-OnLine Version 7.23.UC4 -- On-Line -- Up 05:35:04 -- 117968 Kbytes
$B9=@.%U%!%$%k(B: /informix/etc/onconfig.baan300
#**************************************************************************
#
# INFORMIX SOFTWARE, INC.
#
# Title: onconfig.baan300
# Description: INFORMIX-OnLine Configuration Parameters
#
#**************************************************************************
# Root Dbspace Configuration
ROOTNAME rootdbs # Root dbspace name
ROOTPATH /dev/vg08/rlvol1 # Path for device containing root dbspace
ROOTOFFSET 0 # Offset of root dbspace into device (Kbytes)
ROOTSIZE 400000 # Size of root dbspace (Kbytes)
# Disk Mirroring Configuration Parameters
MIRROR 0 # Mirroring flag (Yes = 1, No = 0)
MIRRORPATH # Path for device containing mirrored root
MIRROROFFSET 0 # Offset into mirrored device (Kbytes)
# Physical Log Configuration
PHYSDBS rootdbs # Location (dbspace) of physical log
PHYSFILE 100000 # Physical log file size (Kbytes)
# Logical Log Configuration
LOGFILES 20 # Number of logical log files
LOGSIZE 49994 # Logical log size (Kbytes)
# Diagnostics
MSGPATH /informix/baan300.log # System message log file path
CONSOLE /dev/console # System console message pathALARMPROGRAM /informix/log_full.sh # Alarm program path
# System Archive Tape Device
TAPEDEV /dev/null # Tape device path
TAPEBLK 16 # Tape block size (Kbytes)
TAPESIZE 10240 # Maximum amount of data to put on tape (Kbytes)
# Log Archive Tape Device
LTAPEDEV /dev/null # Log tape device path
LTAPEBLK 16 # Log tape block size (Kbytes)
LTAPESIZE 10240 # Max amount of data to put on log tape (Kbytes)
# Optical
STAGEBLOB ,1 # INFORMIX-OnLine/Optical staging area
# System Configuration
SERVERNUM 2 # Unique id corresponding to a OnLine instance
DBSERVERNAME baan300 # Name of default database server
DBSERVERALIASES baan300tcp # List of alternate dbservernames
NETTYPE ipcstr,4,50,NET
NETTYPE soctcp,4,50,CPU
DEADLOCK_TIMEOUT 60 # Max time to wait of lock in distributed env.
RESIDENT 1 # Forced residency flag (Yes = 1, No = 0)
MULTIPROCESSOR 1 # 0 for single-processor, 1 for multi-processor
NUMCPUVPS 4 # Number of user (cpu) vps
SINGLE_CPU_VP 0 # If non-zero, limit number of cpu vps to one
NOAGE 0 # Process aging
AFF_SPROC 0 # Affinity start processor
AFF_NPROCS 0 # Affinity number of processors
# Shared Memory Parameters
LOCKS 100000 # Maximum number of locks
BUFFERS 15000 # Maximum number of shared buffers
NUMAIOVPS 2 # Number of IO vps
PHYSBUFF 32 # Physical log buffer size (Kbytes)
LOGBUFF 32 # Logical log buffer size (Kbytes)LOGSMAX 20 # Maximum number of logical log files
CLEANERS 5 # Number of buffer cleaner processes
SHMBASE 0x0 # Shared memory base address
SHMVIRTSIZE 20000 # initial virtual shared memory segment size
SHMADD 8192 # Size of new shared memory segments (Kbytes)
SHMTOTAL 0 # Total shared memory (Kbytes). 0=>unlimited
CKPTINTVL 300 # Check point interval (in sec)
LRUS 4 # Number of LRU queues
LRU_MAX_DIRTY 25 # LRU percent dirty begin cleaning limit
LRU_MIN_DIRTY 15 # LRU percent dirty end cleaning limit
LTXHWM 50 # Long transaction high water mar
In article <81j41o$ch7$1@news.xmission.com>, michael martin
<michael_martin@komatsu.co.jp> writes
>
>Hi list,
>
>Here I go again.
>
>My question is: Has anyone encountered Bugs 104328 and/or 121447
>and if so what is the fix ?
>
Not encountered but I belive they are fixed in 7.31.UC4-1.
I would move to it.
>Is there some place (URL) I should be looking at to keep up
>with bugs instead of dumping my problems on the list ?
>
www.informix.com Techinfo Centre. When you ask for access
provide a product serial number if you are not sure of the
contract number..
>TIA,
>
>Michael
>michael_martin@komatsu.co.jp
>
>--------------------------------------------------------------------
>
>$ onstat -c>
># System Configuration
>
>SERVERNUM 2 # Unique id corresponding to a OnLine instance
>DBSERVERNAME baan300 # Name of default database server
>DBSERVERALIASES baan300tcp # List of alternate dbservernames
>NETTYPE ipcstr,4,50,NET
>NETTYPE soctcp,4,50,CPU NetTYPE soctcp should be on a NET VP.
Rule is
soctcp on NET VP
ipcshm required on CPU VP (for onstat etc in case network fails).
ipcstr (Art ??, one for the FAQ!) I know ipcstr is new-ish..
>NOAGE 0 # Process aging Set to 1, else Informix slows down as it uses up more CPU time.
>AFF_SPROC 0 # Affinity start processor
>AFF_NPROCS 0 # Affinity number of processors>
Set these as well, 0/4 or if that fails 1/4.
># Read Ahead Variables
>RA_PAGES 400 # Number of pages to attempt to read ahead
>RA_THRESHOLD # Number of pages left before next group>
400!!!!! Big system,slow disk...
>DBSPACETEMP tempdbs # Default temp dbspaces
... and one temp dbspace for a big system???...
>OPTCOMPIND 0 # To hint the optimizer>
...and optcompind = 0, use indexes implying not a DSS system!!
--
David Williams
In article <JkAs2IABucP4EwjD@smooth1.demon.co.uk>,
David Williams <djw@smooth1.demon.co.uk> wrote:
> In article <81j41o$ch7$1@news.xmission.com>, michael martin
> <michael_martin@komatsu.co.jp> writes
[SNIP]
> >NETTYPE ipcstr,4,50,NET
> >NETTYPE soctcp,4,50,CPU> NetTYPE soctcp should be on a NET VP.
>
> Rule is
>
> soctcp on NET VP
> ipcshm required on CPU VP (for onstat etc in case network fails).
>
> ipcstr (Art ??, one for the FAQ!) I know ipcstr is new-ish..
I have not used ipcstr much, however, I suspect that like soc/tlitcp
you will do better with NET VPs as are configured here since the pipe
can be select()'ed.
[SNIP]
Art S. Kagel
Sent via Deja.com http://www.deja.com/
Before you buy.