ontape problem
Posted in 2000
Topics: Backup & Restore, Migration, Import/Export & Data Conversion, Platform-Specific Issues
Hallo Gurus, every day a do an automatique multi-ontape using a unix shel script. this morning, my first tape was full(with 50% of data) so as usualy my robot unload the tape num 1 and load the tape num 2. but after doing the 60 % of data it give me (in the log file) the error number 46. could some one tel me please what is the cause of this problem. I am using informix 7.30UC5 under AIX 4.3 thanks _________________________________________________________________________ Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com. Share information about yourself, create your own public profile at http://profiles.msn.com.
http://www.informix.com/answers/english/ierrors.htm -46 Protocol family not supported. An operating-system error code with the meaning shown was unexpectedly returned to the database server. If the error recurs, please note all circumstances and contact Informix Technical Support. I believe error messages under 100 are from the operating system? "samir BADAOUI" <samir_badaoui@hotmail.com> wrote in message news:8sk9gu$h80$1@news.xmission.com... > > Hallo Gurus, > every day a do an automatique multi-ontape using a unix shel script. > this morning, my first tape was full(with 50% of data) so as usualy my robot > unload the tape num 1 and load the tape num 2. but after doing the 60 % of > data it give me (in the log file) the error number 46. > could some one tel me please what is the cause of this problem. > I am using informix 7.30UC5 under AIX 4.3 > thanks > > > _________________________________________________________________________ > Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com. > > Share information about yourself, create your own public profile at > http://profiles.msn.com. >
Impy wrote: > http://www.informix.com/answers/english/ierrors.htm > -46 Protocol family not supported. > An operating-system error code with the meaning shown was unexpectedly > returned to the database server. If the error recurs, please note all > circumstances and contact Informix Technical Support. That's the BSD error message; the SVR4 error message is more likely to be the trouble: #define ENOLCK 46 /* No record locks available. */ > I believe error messages under 100 are from the operating system? Yes, but the texts given by Informix are fixed and are wrong for SVR4 systems when the error number is greater than about 30. When BSD broke off from SVR4's predecessor versions, there were about 30 error numbers. > "samir BADAOUI" <samir_badaoui@hotmail.com> wrote: > > every day a do an automatique multi-ontape using a unix shel script. > > this morning, my first tape was full(with 50% of data) so as usualy my > robot > > unload the tape num 1 and load the tape num 2. but after doing the 60 % of > > data it give me (in the log file) the error number 46. > > could some one tel me please what is the cause of this problem. > > I am using informix 7.30UC5 under AIX 4.3 I'd look to see how many locks are configured in your kernel. However, it is a little surprising to be running out of kernel locks with OnLine; it is more typically an error you see with C-ISAM or SE. -- Yours, Jonathan Leffler (Jonathan.Leffler@Informix.com) #include <disclaimer.h> Guardian of DBD::Informix v1.00.PC1 -- http://www.perl.com/CPAN "I don't suffer from insanity; I enjoy every minute of it!"