Problems with DBSERVERALIASES
Posted in 1999
Topics: Storage & Space Management, Error Codes & Troubleshooting, Server Administration, Logging & Checkpoints, Networking & sqlhosts Configuration, Platform-Specific Issues
Hello
Have a problem with definition of a DBSERVERALIAS, the informix server
(oninit) will not start.
Have the following configuration:
-----------------------------------------------------------------------------------------
onconfig:
...
DBSERVERNAME iserver # Name of default database server
DBSERVERALIASES cserver # List of alternatedbservernames
sqlhosts:
iserver onipcshm Linux sqlexec
cserver onsoctcp Linux sqlconnect
services:
...
sqlexec 1536/tcp informix
sqlconnect 1537/tcp informix_connect
-----------------------------------------------------------------------------------------
Running oninit with this configuration results in error message:
------------------------------------------------------------------------------------------
13:36:21 Event alarms enabled. ALARMPROG =
'/usr/informix/etc/log_full.sh'
13:36:27 DR: DRAUTO is 0 (Off)
13:36:28 Requested shared memory segment size rounded from 588KB to592KB
13:36:28 bsd_nsf_sendfd: sendmsg error - spipe 0, fd 4, error 22
********* bsd_nsf_flush: pid = 504 spipe = 0 errno = 22 ******Informix Dynamic Server Version 7.30.U Software Serial Number
AAC#A518469
13:36:28 Assert Failed: nsfpipe.c, line 2096, thread 9, errno=22, spipe
error.
13:36:28 Informix Dynamic Server Version 7.30.U
13:36:28 Who: Session(3, informix@, 0, 0)
Thread(9, soctcppoll, 0, 8)
File: called by ASF mt_affail Line: 0
13:36:30 Informix Dynamic Server Initialized -- Shared MemoryInitialized.
bash-2.02$ 13:36:30 Physical Recovery Started.
13:36:30 Physical Recovery Complete: 122 Pages Restored.
13:36:30 Logical Recovery Started.
tail: /usr/informix/online.log: No such file or directory
13:36:35 Logical Recovery Complete. 206 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
13:36:35 Dataskip is now OFF for all dbspaces
13:36:35 Logical Log Files are Full -- Backup is Needed
13:36:35 Process exited with return code 127: /bin/sh /bin/sh -c
/usr/informix/etc/log_full.sh 3 20 "Logical Logs are Full -- Backup isNeeded." "Logical Log Files are
13:36:40 See Also: /tmp/af.9f3bb, shmem.9f3bb.0
13:36:41 nsfpipe.c, line 2096, thread 9, errno=22, spipe error.
sh: /usr/informix/etc/log_full.sh: No such file or directory
13:36:41 invoke_alarm(): /bin/sh -c '/usr/informix/etc/log_full.sh 5 6"Internal Subsystem failure: 'MT'" "nsfpipe.c, line 2096, thread 9,
errno=22, spipe error." '
13:36:41 invoke_alarm(): mt_exec failed, status 32512, errno 0
13:36:41 PANIC: Attempting to bring system down
----------------------------------------------------------------------------------------------------------
Running oninit without the entry for DBSERVERALIASES
DBSERVERALIASES # List of alternate dbservernamesbrings up the server with oninit without problems.
Can anyone suggest why ?
Rüdiger Breit wrote:
> Hello
>
> Have a problem with definition of a DBSERVERALIAS, the informix server
> (oninit) will not start.
>
> Have the following configuration:
> -----------------------------------------------------------------------------------------
>
> onconfig:
> ...
> DBSERVERNAME iserver # Name of default database server
> DBSERVERALIASES cserver # List of alternate> dbservernames
>
> sqlhosts:
> iserver onipcshm Linux sqlexec
> cserver onsoctcp Linux sqlconnect>
> services:
> ...
> sqlexec 1536/tcp informix
> sqlconnect 1537/tcp informix_connect
> -----------------------------------------------------------------------------------------
>
> Running oninit with this configuration results in error message:
> ------------------------------------------------------------------------------------------
>
> 13:36:21 Event alarms enabled. ALARMPROG =
> '/usr/informix/etc/log_full.sh'
> 13:36:27 DR: DRAUTO is 0 (Off)
> 13:36:28 Requested shared memory segment size rounded from 588KB to> 592KB
> 13:36:28 bsd_nsf_sendfd: sendmsg error - spipe 0, fd 4, error 22
> ********* bsd_nsf_flush: pid = 504 spipe = 0 errno = 22 ******> Informix Dynamic Server Version 7.30.U Software Serial Number
> AAC#A518469
> 13:36:28 Assert Failed: nsfpipe.c, line 2096, thread 9, errno=22, spipe
> error.
> 13:36:28 Informix Dynamic Server Version 7.30.U
> 13:36:28 Who: Session(3, informix@, 0, 0)
> Thread(9, soctcppoll, 0, 8)
> File: called by ASF mt_affail Line: 0
> 13:36:30 Informix Dynamic Server Initialized -- Shared Memory> Initialized.
> bash-2.02$ 13:36:30 Physical Recovery Started.
> 13:36:30 Physical Recovery Complete: 122 Pages Restored.
> 13:36:30 Logical Recovery Started.
> tail: /usr/informix/online.log: No such file or directory
> 13:36:35 Logical Recovery Complete.> 206 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
>
> 13:36:35 Dataskip is now OFF for all dbspaces
> 13:36:35 Logical Log Files are Full -- Backup is Needed
>
> 13:36:35 Process exited with return code 127: /bin/sh /bin/sh -c
> /usr/informix/etc/log_full.sh 3 20 "Logical Logs are Full -- Backup is> Needed." "Logical Log Files are
> 13:36:40 See Also: /tmp/af.9f3bb, shmem.9f3bb.0
> 13:36:41 nsfpipe.c, line 2096, thread 9, errno=22, spipe error.
> sh: /usr/informix/etc/log_full.sh: No such file or directory
> 13:36:41 invoke_alarm(): /bin/sh -c '/usr/informix/etc/log_full.sh 5 6> "Internal Subsystem failure: 'MT'" "nsfpipe.c, line 2096, thread 9,
> errno=22, spipe error." '
> 13:36:41 invoke_alarm(): mt_exec failed, status 32512, errno 0
> 13:36:41 PANIC: Attempting to bring system down
> ---------------------------------------------------------------------------------------------------------->
> Running oninit without the entry for DBSERVERALIASES
> DBSERVERALIASES # List of alternate dbservernames> brings up the server with oninit without problems.
>
> Can anyone suggest why ?
Hi,
I don't know if it helps, but I would try to put "informix" or "informix_connect" as a comment (insert a #
before) in /etc/services.
Remark:
You may delete the sqlexec entry from /etc/services. The service sqlexec connects via shared memory, so
/etc/services is not used.
Additional remark:
In old times (Informix V4) the service name "sqlexec" was something like"reserved" for connections coming from
other systems. Maybe you should change this service name too.
Regards
--
Helmut Leininger
Bull AG / Vienna
Unix Support
Email: h.leininger@bull.at
helmut.leininger@bull.net
This opinion is mine and not necessarily that of my employer.
No guarantees whatsoever.
Rüdiger Breit wrote:
> Have a problem with definition of a DBSERVERALIAS, the informix server
> (oninit) will not start.
We have a problem helping you - you don't say which platform you are
working on. Actually, I think I can guess, but it would be of very
considerable relevance to know. When you ask for help, please,
please give us summary version and platform info, such as:
7.30.UC5 IDS on RedHat 5.2 Linux (2.0.36 kernel, 2.0.7 glibc).
That's what you're using, isn't it?
> Have the following configuration:
>
>
> onconfig:
> ...
> DBSERVERNAME iserver # Name of default database server
> DBSERVERALIASES cserver # List of alternate> dbservernames
>
> sqlhosts:
> iserver onipcshm Linux sqlexec
> cserver onsoctcp Linux sqlconnect>
> services:
> ...
> sqlexec 1536/tcp informix
> sqlconnect 1537/tcp informix_connect
> -----------------------------------------------------------------------------------------
>
> Running oninit with this configuration results in error message:
> ------------------------------------------------------------------------------------------
>
> 13:36:21 Event alarms enabled. ALARMPROG =
> '/usr/informix/etc/log_full.sh'
> 13:36:27 DR: DRAUTO is 0 (Off)
> 13:36:28 Requested shared memory segment size rounded from 588KB to> 592KB
> 13:36:28 bsd_nsf_sendfd: sendmsg error - spipe 0, fd 4, error 22
> ********* bsd_nsf_flush: pid = 504 spipe = 0 errno = 22 ******> Informix Dynamic Server Version 7.30.U Software Serial Number
> AAC#A518469
> 13:36:28 Assert Failed: nsfpipe.c, line 2096, thread 9, errno=22, spipe
> error.
> 13:36:28 Informix Dynamic Server Version 7.30.U
> 13:36:28 Who: Session(3, informix@, 0, 0)
> Thread(9, soctcppoll, 0, 8)
> File: called by ASF mt_affail Line: 0
> 13:36:30 Informix Dynamic Server Initialized -- Shared Memory> Initialized.
> bash-2.02$ 13:36:30 Physical Recovery Started.
> 13:36:30 Physical Recovery Complete: 122 Pages Restored.
> 13:36:30 Logical Recovery Started.
> tail: /usr/informix/online.log: No such file or directory
> 13:36:35 Logical Recovery Complete.> 206 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
>
> 13:36:35 Dataskip is now OFF for all dbspaces
> 13:36:35 Logical Log Files are Full -- Backup is Needed
>
> 13:36:35 Process exited with return code 127: /bin/sh /bin/sh -c
> /usr/informix/etc/log_full.sh 3 20 "Logical Logs are Full -- Backup is> Needed." "Logical Log Files are
> 13:36:40 See Also: /tmp/af.9f3bb, shmem.9f3bb.0
> 13:36:41 nsfpipe.c, line 2096, thread 9, errno=22, spipe error.
> sh: /usr/informix/etc/log_full.sh: No such file or directory
> 13:36:41 invoke_alarm(): /bin/sh -c '/usr/informix/etc/log_full.sh 5 6> "Internal Subsystem failure: 'MT'" "nsfpipe.c, line 2096, thread 9,
> errno=22, spipe error." '
> 13:36:41 invoke_alarm(): mt_exec failed, status 32512, errno 0
> 13:36:41 PANIC: Attempting to bring system down>
>
> Running oninit without the entry for DBSERVERALIASES
> DBSERVERALIASES # List of alternate dbservernames> brings up the server with oninit without problems.
>
> Can anyone suggest why ?
Only if I guessed the platform correctly - give or take the last
digit in the version number of IDS.
Yes, it's called a bug. There might be a fixed version available
from Intraware, or it may still be a current bug. I'm not clear
about the ins and outs of the problem, but having a NET VP is (a)
necessary and (b) triggers the bug. So choose whether you want
shared memory (local only) or network (local or remote) access and
use just the one connectivity method.
--
Jonathan Leffler (jleffler@informix.com, jleffler@earthlink.net)
Guardian of DBD::Informix v0.60 -- see http://www.perl.com/CPAN
#include <disclaimer.h>
Which platform are you running Informix on? I have experienced the same problem on Linux kernel 2.0.35 and kernel 2.2.5. The only way I was able to circumvent the problem was to download and install a patched 2.0.36 kernel from Informix (rpm format); rumors has it that the problem stems from some kernel compilation parameter regarding the number of file descriptors.. anyway I was unable to change these parameters by myself, so I sticked with the precompiled kernel. With this configuration the Dynamic Server gets online, and I can see the listener active with netstat -a --listening. I still have problems connecting from Win9x clients, but this is another story.....