Network driver cannot bind a name to the port.
Posted in 2000
Topics: Storage & Space Management, Networking & sqlhosts Configuration
When I try to run connect to a server, it said:
25572: Network driver cannot bind a name to the port.
When I want to create some dbspace, it said:
error writing network
I have edit the sqlhosts and /etc/services, what else should I also
config?
Ki.
i always thought this message (network driver cannot bind...) always
seemed to mean
someone else had established a connection across this port number, some
other program,
some previous incarnation of the instance which was held by that
instance, but was
not removed when it came down ( probably unceremoniously?)
someone will probably correct me on that..
if you do a netstat -an | grep <your port number >
you should see the process which holds the port as it is now, and you
should find
out what it is , and possibly then , if it is safe to, remove it.
but i really don't understand your question as it begins
'when i try to run connect...' i.e.; do you have the instance up
and you are connecting across a network using a network protocol
program?
or are you trying to use dbaccess from a client?
you might try your question with some basic information such as
relevant entries in your /etc/services, your $INFORMIXSQLHOSTS file,
and what it was you were doing when you got your network error...
i am not wure what error writing network means, but have you been able
to create any dbspaces and are these raw devices, and where are they
mounted - are they on an hp or sun or sco or whatever? are you root or
are you informix
or are you dbuser or nobody ?
cfbenson wrote:
> When I try to run connect to a server, it said:
> 25572: Network driver cannot bind a name to the port.>
> When I want to create some dbspace, it said:
> error writing network
>
> I have edit the sqlhosts and /etc/services, what else should I also
> config?
>
> Ki.
Edward Rosenthal wrote:
> if you do a netstat -an | grep <your port number >
Nothings is grepped
> 'when i try to run connect...' i.e.; do you have the instance up
> and you are connecting across a network using a network protocol
> program?
> or are you trying to use dbaccess from a client?
dbaccess -> connection -> connect
Then:
25572: Network driver cannot bind a name to the port.
Exec format error
Or when I enter onmonitor, it said network down and I create DBSPACE it
said network down.
> you might try your question with some basic information such as
> relevant entries in your /etc/services, your $INFORMIXSQLHOSTS file,
extract part of my /etc/inet/services:
ifmx_srvc 2055/tcp # service used by
OnLine/DSA
cert_db 2056/tcp # service used by Phone
List
mesg-admin 28258/tcp # mesg administration
sqlhosts:
demo_on onipcshm on_hostname on_servernamedemo_se seipcpip se_hostname sqlexec
cert ontlitcp cfbwb3-dev cert_db
> mounted - are they on an hp or sun or sco or whatever?
SunOS cfbwb3-dev 5.8 Generic sun4u sparc SUNW,Ultra-5_10
> are you root or
> are you informix
> or are you dbuser or nobody ?
informix
Hi,
Just having a quick look at your services file and sqlhosts...
cert_db is the service you are trying to connect to (in SQLHOSTS) but in
your services file "cert_db" is listed as being "service used by Phone List"
where as for "ifmx_srvc" the comment is "service used by OnLine/DSA", so
which are you trying to connect to? (post a copy of your $ONCONFIG as
well...).
ben.
"cfbenson" <cfbenson@netvigator.com> wrote in message
news:3948AF4E.440A6777@netvigator.com...
>
>
> Edward Rosenthal wrote:
>
> > if you do a netstat -an | grep <your port number >
>
> Nothings is grepped
>
> > 'when i try to run connect...' i.e.; do you have the instance up
> > and you are connecting across a network using a network protocol
> > program?
> > or are you trying to use dbaccess from a client?
>
> dbaccess -> connection -> connect
> Then:
> 25572: Network driver cannot bind a name to the port.
> Exec format error>
> Or when I enter onmonitor, it said network down and I create DBSPACE it
> said network down.
>
> > you might try your question with some basic information such as
> > relevant entries in your /etc/services, your $INFORMIXSQLHOSTS file,
>
> extract part of my /etc/inet/services:
> ifmx_srvc 2055/tcp # service used by
> OnLine/DSA
> cert_db 2056/tcp # service used by Phone
> List
> mesg-admin 28258/tcp # mesg administration
>
> sqlhosts:
> demo_on onipcshm on_hostname on_servername> demo_se seipcpip se_hostname sqlexec
> cert ontlitcp cfbwb3-dev cert_db>
>
>
>
>
> > mounted - are they on an hp or sun or sco or whatever?
>
> SunOS cfbwb3-dev 5.8 Generic sun4u sparc SUNW,Ultra-5_10
>
>
> > are you root or
> > are you informix
> > or are you dbuser or nobody ?
>
> informix
>
>
>
Ben Wilde wrote: > Hi, > > Just having a quick look at your services file and sqlhosts... > > cert_db is the service you are trying to connect to (in SQLHOSTS) but in > your services file "cert_db" is listed as being "service used by Phone List" > where as for "ifmx_srvc" the comment is "service used by OnLine/DSA", so > which are you trying to connect to? (post a copy of your $ONCONFIG as > well...). > As per attached.