Assert Failure files
Posted in 1999
Topics: Stored Procedures & SPL, Server Administration
Does anyone know off hand the ONCONFIG parameter to set to force af files to be created when the system crashes? The Informix support person could not find it in his notes. Some background on the problem: We are having a problem on an NT server. when a stored procedure is executed that does significant updates or inserts online dynamically allocates shared memory segments until it uses up all available resources on the box. It is a dual 500 PIII with 1 GB of memory. Any help is appreciated.
Dan_Weeks@agsea.com wrote: > We are having a problem on an NT server. when a stored procedure is > executed that does significant updates or inserts online dynamically > allocates shared memory segments until it uses up all available resources > on the box. It is a dual 500 PIII with 1 GB of memory. We had something similar. Our problem was NVL() function. After changing all lines in stored procedures having: RETURN NVL( var, 'NULL' ); to this: IF var IS NULL THEN RETURN 'NULL'; END IF RETURN var; problem was resolved. Leonid.