Arithmetic
Posted in 1999
Topics: Error Codes & Troubleshooting
We have been plagued with this problem several times in the past.
23:00:02 Assert Failed: Internal Error - Arithmetic Exception
23:00:02 Who: Session(3588, heisys@prodpdb, 20624, 1444847628)
Thread(3756, sqlexec, 56230e14, 10)
23:00:02 Results: OnLine must abort
23:00:02 Action: Reinitialize shared memory
23:00:02 PANIC: Attempting to bring system down
Informix has told me that this problem is addressed and fixed in later
releases of Informix but they have given me a workaround,
Here is the description:
The root cause is that the engine code is not expecting one of the
sysindexes entries for this table to have a value of "0" (zero) in the
nunique column.
Here is the workaround
To workaround, change the value to 1:
update sysindexes set nunique=1 where tabid=xxx and nunique=0;
Has anyone ever tried somthing like this? Has anyone ever seen this...
Carlos Bolden
Database Administrator
Harrah's Entertainment
cbolden@harrahs.com ( work )
cbolden1@midsouth.rr.com ( home )
Been there ;)
Stop running update-stats until you can upgrade the engine. We are running
7.24.uc5 on Solaris 2.6. We are currently upgrading to 7.24.uc7, which we
are told will fix this problem.
SC
> We have been plagued with this problem several times in the past.
>
> 23:00:02 Assert Failed: Internal Error - Arithmetic Exception
> 23:00:02 Who: Session(3588, heisys@prodpdb, 20624, 1444847628)
> Thread(3756, sqlexec, 56230e14, 10)
> 23:00:02 Results: OnLine must abort
> 23:00:02 Action: Reinitialize shared memory
> 23:00:02 PANIC: Attempting to bring system down>
> Informix has told me that this problem is addressed and fixed in later
> releases of Informix but they have given me a workaround,
>
> Here is the description:
>
> The root cause is that the engine code is not expecting one of the
> sysindexes entries for this table to have a value of "0" (zero) in the
> nunique column.
>
> Here is the workaround
>
> To workaround, change the value to 1:
> update sysindexes set nunique=1 where tabid=xxx and nunique=0;>
> Has anyone ever tried somthing like this? Has anyone ever seen this...
In article <370DFAE5.888638BD@interaccess.com>, Stephen F. Cawley
<sfcawley@interaccess.com> writes
>Been there ;)
>
>Stop running update-stats until you can upgrade the engine. We are running
>7.24.uc5 on Solaris 2.6. We are currently upgrading to 7.24.uc7, which we
>are told will fix this problem.
>
I work go to 7.30.UC7-1 which is out for Solaris 2.6!
>SC
>
>> We have been plagued with this problem several times in the past.
>>
>> 23:00:02 Assert Failed: Internal Error - Arithmetic Exception
>> 23:00:02 Who: Session(3588, heisys@prodpdb, 20624, 1444847628)
>> Thread(3756, sqlexec, 56230e14, 10)
>> 23:00:02 Results: OnLine must abort
>> 23:00:02 Action: Reinitialize shared memory
>> 23:00:02 PANIC: Attempting to bring system down>>
>> Informix has told me that this problem is addressed and fixed in later
>> releases of Informix but they have given me a workaround,
>>
>> Here is the description:
>>
>> The root cause is that the engine code is not expecting one of the
>> sysindexes entries for this table to have a value of "0" (zero) in the
>> nunique column.
>>
>> Here is the workaround
>>
>> To workaround, change the value to 1:
>> update sysindexes set nunique=1 where tabid=xxx and nunique=0;>>
>> Has anyone ever tried somthing like this? Has anyone ever seen this...
>
--
David Williams
It's not Neccesarily update statistics. I've recieved this error during
multiple threads doing kaio, also on many of the backend processes.
The question I ask now is have you or has anyone ever updated the nuniques
column of sysindexes in the perspective database and have they run into any
problems...
Carlos Bolden
Database Administrator
Harrahs Entertainment
home:cbolden1@midsouth.rr.com
work:cbolden@harrahs.com
Stephen F. Cawley <sfcawley@interaccess.com> wrote in message
news:370DFAE5.888638BD@interaccess.com...
> Been there ;)
>
> Stop running update-stats until you can upgrade the engine. We are
running
> 7.24.uc5 on Solaris 2.6. We are currently upgrading to 7.24.uc7, which we
> are told will fix this problem.
>
> SC
>
> > We have been plagued with this problem several times in the past.
> >
> > 23:00:02 Assert Failed: Internal Error - Arithmetic Exception
> > 23:00:02 Who: Session(3588, heisys@prodpdb, 20624, 1444847628)
> > Thread(3756, sqlexec, 56230e14, 10)
> > 23:00:02 Results: OnLine must abort
> > 23:00:02 Action: Reinitialize shared memory
> > 23:00:02 PANIC: Attempting to bring system down> >
> > Informix has told me that this problem is addressed and fixed in later
> > releases of Informix but they have given me a workaround,
> >
> > Here is the description:
> >
> > The root cause is that the engine code is not expecting one of the
> > sysindexes entries for this table to have a value of "0" (zero) in the
> > nunique column.
> >
> > Here is the workaround
> >
> > To workaround, change the value to 1:
> > update sysindexes set nunique=1 where tabid=xxx and nunique=0;> >
> > Has anyone ever tried somthing like this? Has anyone ever seen this...
>