Error -674 Routine (ifx_allow_newline) can not be
Posted in 2008
Topics: High Availability & Replication, Storage & Space Management, Error Codes & Troubleshooting, Server Administration, Security, Permissions & Auditing, Platform-Specific Issues, Internationalization & Character Sets, Versions, Editions & End-of-Life
HI, Folks,
Attached is the error in online log, any ideas?
(It also throws core dump some times).
Program Name: onstat
Build Version: 11.10.UC2
Build Number: N158
Build Host: vach
Build OS: AIX 5.3
Build Date: Thu Oct 25 22:56:40 CDT 2007
GLS Version: glslib-4.50.UC2
Thanks,
Frank
13:42:29 IBM Informix Dynamic Server Started.
13:42:29 Segment locked: addr=40000000, size=256049152
13:42:30 VP pid=450594 priority fixed at 60, former = 71
Mon Apr 7 13:42:30 2008
13:42:30 Warning: ONCONFIG dump directory (DUMPDIR) '/tmp' has
in secure permissions
13:42:30 Event alarms enabled. ALARMPROG =
'/usr/informix/etc/al armprogram.sh'
13:42:31 Booting Language <c> from module <>
13:42:31 Loading Module <CNULL>
13:42:31 Booting Language <builtin> from module <>
13:42:31 Loading Module <BUILTINNULL>
13:42:36 DR: DRAUTO is 0 (Off)
13:42:36 DR: ENCRYPT_HDR is 0 (HDR encryption Disabled)
13:42:36 AIX MP latch code enabled
13:42:36 Fast poll pollset enabled.
13:42:36 Requested shared memory segment size rounded from 532KB to 544KB
13:42:36 IBM Informix Dynamic Server Version 11.10.UC2 Software Serial
Number AAA#B000000
13:42:37 IBM Informix Dynamic Server Initialized -- Shared Memory
Initialized.
13:42:37 Physical Recovery Started at Page (2:2299).
13:42:37 Physical Recovery Complete: 0 Pages Examined, 0 Pages Restored.
13:42:37 Logical Recovery Started.
13:42:37 10 recovery worker threads will be started.
13:42:40 Logical Recovery has reached the transaction cleanup phase.
13:42:40 Logical Recovery Complete.
0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
13:42:41 Dataskip is now OFF for all dbspaces
13:42:41 On-Line Mode
13:42:43 SCHAPI: Started dbScheduler thread.
13:42:43 SCHAPI: Error -674 Routine (ifx_allow_newline) can not be
resolved.
13:42:43 SCHAPI: Type: , Name: NULL, Location: NULL.
13:42:43 SCHAPI: Error -101 ISAM error: file is not open.
13:42:43 SCHAPI: Type: , Name: NULL, Location: NULL.
13:42:43 SCHAPI: Error -311 Cannot open system catalog (syscasts).
13:42:43 SCHAPI: Type: , Name: NULL, Location: NULL.
13:42:43 SCHAPI: Error -135 ISAM error: TBLspace does not exist
13:42:43 SCHAPI: Type: , Name: NULL, Location: NULL.
13:42:43 SCHAPI: Failed to setup dbScheduler thread.
...................
Hi,
no, I've not seen this. But that may well be because
I don't use dbcron ...
If you can and want to live without the dbcron feature,
you can disable it. Then it will not start the SCHAPI
thing and probably you will not get this error and
successive core dump. To disable do the following
as user informix:
touch $INFORMIXDIR/etc/sysadmin/stop
If you want to enable it again at a later time, then
just remove the file. At next start of IDS it will then
again start dbcron as well.
Regards,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany
Information Management
IBM Deutschland Entwicklung GmbH
Chairman of the Supervisory Board: Martin Jetter
Board of Management: Herbert Kircher
Corporate Seat: Boeblingen, Germany
Reg.-Gericht: Amtsgericht Stuttgart, HRB 243294
ids-bounces@iiug.org wrote on 07.04.2008 16:06:56:
> HI, Folks,
>
> Attached is the error in online log, any ideas?
> (It also throws core dump some times).
>
> Program Name: onstat
> Build Version: 11.10.UC2
> Build Number: N158
> Build Host: vach
> Build OS: AIX 5.3
> Build Date: Thu Oct 25 22:56:40 CDT 2007
> GLS Version: glslib-4.50.UC2
>
> Thanks,
> Frank
>
> 13:42:29 IBM Informix Dynamic Server Started.
> 13:42:29 Segment locked: addr=40000000, size=256049152
> 13:42:30 VP pid=450594 priority fixed at 60, former = 71
>
> Mon Apr 7 13:42:30 2008
>
> 13:42:30 Warning: ONCONFIG dump directory (DUMPDIR) '/tmp' has
> in secure permissions
> 13:42:30 Event alarms enabled. ALARMPROG =
> '/usr/informix/etc/al armprogram.sh'
> 13:42:31 Booting Language <c> from module <>
> 13:42:31 Loading Module <CNULL>
> 13:42:31 Booting Language <builtin> from module <>
> 13:42:31 Loading Module <BUILTINNULL>
> 13:42:36 DR: DRAUTO is 0 (Off)
> 13:42:36 DR: ENCRYPT_HDR is 0 (HDR encryption Disabled)
> 13:42:36 AIX MP latch code enabled
> 13:42:36 Fast poll pollset enabled.
> 13:42:36 Requested shared memory segment size rounded from 532KB to
544KB
> 13:42:36 IBM Informix Dynamic Server Version 11.10.UC2 Software Serial
> Number AAA#B000000
> 13:42:37 IBM Informix Dynamic Server Initialized -- Shared Memory
> Initialized.
>
> 13:42:37 Physical Recovery Started at Page (2:2299).
> 13:42:37 Physical Recovery Complete: 0 Pages Examined, 0 Pages Restored.
> 13:42:37 Logical Recovery Started.
> 13:42:37 10 recovery worker threads will be started.
> 13:42:40 Logical Recovery has reached the transaction cleanup phase.
> 13:42:40 Logical Recovery Complete.
>
> 0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
>
> 13:42:41 Dataskip is now OFF for all dbspaces
> 13:42:41 On-Line Mode
> 13:42:43 SCHAPI: Started dbScheduler thread.
> 13:42:43 SCHAPI: Error -674 Routine (ifx_allow_newline) can not be
> resolved.
> 13:42:43 SCHAPI: Type: , Name: NULL, Location: NULL.
> 13:42:43 SCHAPI: Error -101 ISAM error: file is not open.
> 13:42:43 SCHAPI: Type: , Name: NULL, Location: NULL.
> 13:42:43 SCHAPI: Error -311 Cannot open system catalog (syscasts).
> 13:42:43 SCHAPI: Type: , Name: NULL, Location: NULL.
> 13:42:43 SCHAPI: Error -135 ISAM error: TBLspace does not exist
> 13:42:43 SCHAPI: Type: , Name: NULL, Location: NULL.
> 13:42:43 SCHAPI: Failed to setup dbScheduler thread.
> ....................
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
> See you at the IIUG Informix 2008 Conference
> The Power Conference for Informix Professionals
> April 27 - 30, 2008 Marriott Overland Park (Kansas City), Kansas
> http://www.iiug.org/conf
> Registration Now Open!!
Hi Frank,
Have you checked to see if the sysadmin database was properly created?
The function in question is a stock function, and should resolve without fail.
-Mark
----- Original Message ----
From: FRANK <yunyaoqu@gmail.com>
To: ids@iiug.org
Sent: Monday, April 7, 2008 9:06:56 AM
Subject: Error -674 Routine (ifx_allow_newline) can not.... [11791]
HI, Folks,
Attached is the error in online log, any ideas?
(It also throws core dump some times).
Program Name: onstat
Build Version: 11.10.UC2
Build Number: N158
Build Host: vach
Build OS: AIX 5.3
Build Date: Thu Oct 25 22:56:40 CDT 2007
GLS Version: glslib-4.50.UC2
Thanks,
Frank
13:42:29 IBM Informix Dynamic Server Started.
13:42:29 Segment locked: addr=40000000, size=256049152
13:42:30 VP pid=450594 priority fixed at 60, former = 71
Mon Apr 7 13:42:30 2008
13:42:30 Warning: ONCONFIG dump directory (DUMPDIR) '/tmp' has
in secure permissions
13:42:30 Event alarms enabled. ALARMPROG =
'/usr/informix/etc/al armprogram.sh'
13:42:31 Booting Language <c> from module <>
13:42:31 Loading Module <CNULL>
13:42:31 Booting Language <builtin> from module <>
13:42:31 Loading Module <BUILTINNULL>
13:42:36 DR: DRAUTO is 0 (Off)
13:42:36 DR: ENCRYPT_HDR is 0 (HDR encryption Disabled)
13:42:36 AIX MP latch code enabled
13:42:36 Fast poll pollset enabled.
13:42:36 Requested shared memory segment size rounded from 532KB to 544KB
13:42:36 IBM Informix Dynamic Server Version 11.10.UC2 Software Serial
Number AAA#B000000
13:42:37 IBM Informix Dynamic Server Initialized -- Shared Memory
Initialized.
13:42:37 Physical Recovery Started at Page (2:2299).
13:42:37 Physical Recovery Complete: 0 Pages Examined, 0 Pages Restored.
13:42:37 Logical Recovery Started.
13:42:37 10 recovery worker threads will be started.
13:42:40 Logical Recovery has reached the transaction cleanup phase.
13:42:40 Logical Recovery Complete.
0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
13:42:41 Dataskip is now OFF for all dbspaces
13:42:41 On-Line Mode
13:42:43 SCHAPI: Started dbScheduler thread.
13:42:43 SCHAPI: Error -674 Routine (ifx_allow_newline) can not be
resolved.
13:42:43 SCHAPI: Type: , Name: NULL, Location: NULL.
13:42:43 SCHAPI: Error -101 ISAM error: file is not open.
13:42:43 SCHAPI: Type: , Name: NULL, Location: NULL.
13:42:43 SCHAPI: Error -311 Cannot open system catalog (syscasts).
13:42:43 SCHAPI: Type: , Name: NULL, Location: NULL.
13:42:43 SCHAPI: Error -135 ISAM error: TBLspace does not exist
13:42:43 SCHAPI: Type: , Name: NULL, Location: NULL.
13:42:43 SCHAPI: Failed to setup dbScheduler thread.
....................
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
See you at the IIUG Informix 2008 Conference
The Power Conference for Informix Professionals
April 27 - 30, 2008 Marriott Overland Park (Kansas City), Kansas
http://www.iiug.org/conf
Registration Now Open!!