Re: Informix problems afters Y2K Solaris 2.5 patch
Posted in 1999
Looking at your onconfig file I saw the error stating there a no
shared memory available. May be this patch has modified
the shared memory or virtual memory process limit kernel parameters.
Check them and change them to be as stated in the Informix
Dynamic Server release notes.
Hope this helps,
Octav
On Tue, Dec 28, 1999 at 10:26:12AM +0100, Has van der Krieken wrote:
> Since I did the Y2K patch for Solaris 2.5 on a Ultra Sparc 1 system,
> Informix 7.22 refuses to startup properly.
> Anyone experienced a simular problem? Any suggestions?
> Attached some system information and the relevant part of the online.log
>
> Has van der Krieken.
>
> # uname -a
> SunOS sungemms 5.5 Generic_103093-25 sun4u sparc SUNW,Ultra-1
> # su - informix> Sun Microsystems Inc. SunOS 5.5 Generic November 1995
> $ onstat -V> INFORMIX-OnLine Version 7.22.UC2 Software Serial Number AAA#J917741
> $ cat online.log>
> Mon Dec 27 16:09:48 1999
>
> 16:09:48 Event alarms enabled. ALARMPROG = '/informix/etc/no_log.sh'
> 16:09:48 DR: DRAUTO is 0 (Off)
> 16:09:49 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
> 16:09:49 Physical Recovery Started.
> 16:09:49 Physical Recovery Complete: 0 Pages Restored.
> 16:09:49 Logical Recovery Started.
> 16:09:49 shmget: [ENOMEM][12]: key 52574804: out of shared memory, check> system
> SHMALL
> 16:09:49 out of virtual shared memory
>
> 16:09:49 Assert Failed: Internal Error - Segmentation Violation
> 16:09:49 Who: Session(6, informix@sungemms, 0, 218473640)
> Thread(13, bld_logrecs, d039530, 1)
> 16:09:49 Results: OnLine must abort
> 16:09:49 Action: Reinitialize shared memory
> 16:09:49 See Also: /var/tmp/af.d813d
> 16:09:49 rsinit.c, line 9932, thread 13, proc id 20737, Segmentation
> Violation.
> 16:09:49 PANIC: Attempting to bring system down>
--
Octav Chiriac Phone: (373) 2 22 99 67
NetInfo S.R.L. Fax: (373) 2 21 36 59
Chisinau (373) 2 22 84 88
Moldova, Republic of mailto:com@netinfo-moldova.com