Informix ADO DB Provider Error
Posted in 2000
Topics: Connectivity: ODBC / JDBC / .NET, Connectivity: ESQL/C, 4GL & Embedded SQL, Security, Permissions & Auditing, Platform-Specific Issues, Versions, Editions & End-of-Life
Hello, I'm using Informix OLE DB Provider of Informix-Connect 2.3 in a VB6.0 program. I set the connection string to:Provider=Ifxoledbc.2;User ID=informix;Password=xxxx;Data Source=bd@maq1_tli;Extended Properties=""; The database server is a Solaris 7 Server with IDS 7.3 UC7. When I try connect with de database server using ADO DB in my program I get: XIX000:-25540: The esqlauth.dll has refused your connection. If I try connect using ILogin it runs correctly. Can anybody help me? Thanks in advance. Sent via Deja.com http://www.deja.com/ Before you buy.
Check that INFORMIXDIR and INFORMIXSERVER are set correctly in setnet32. Check that INFORMIXDIR/bin is in the path. Check username and password that are set in setnet32 for the host where maq1_tli is running. If nothing helps, contact Informix support. Leopold <dgarcia0@my-deja.com> wrote in message news:881jvf$jm1$1@nnrp1.deja.com... > Hello, > I'm using Informix OLE DB Provider of Informix-Connect 2.3 in a VB6.0 > program. I set the connection string to:Provider=Ifxoledbc.2;User > ID=informix;Password=xxxx;Data Source=bd@maq1_tli;Extended > Properties=""; > The database server is a Solaris 7 Server with IDS 7.3 UC7. > When I try connect with de database server using ADO DB in my program I > get: XIX000:-25540: The esqlauth.dll has refused your connection. > > If I try connect using ILogin it runs correctly. > > Can anybody help me? > > Thanks in advance. > > > Sent via Deja.com http://www.deja.com/ > Before you buy.
You need to register Informix OLE DB Provider on your database server by running the %INFORMIXDIR% \\etc\\coledbp.sql script against the sysmaster. But this script does not come with IDS 7.31.UC2A (my engine). I'm also interested how to obtain this script. * Sent from AltaVista http://www.altavista.com Where you can also find related Web Pages, Images, Audios, Videos, News, and Shopping. Smart is Beautiful
Ok, it works! The problem was that $INFORMIXDIR/bin was not in path.
Now I can connect to my database server. All my queries work right but
I get results in OEM ASCII. I'm using CLIENT_LOCALE=es_es.1252 and
DB_LOCALE=es_es.8859-1
How can I get them in ANSI ASCII?
Thanks in advance.
"Leopold The Cat" <leopold_the_cat@yahoo.com> wrote:
> Check that INFORMIXDIR and INFORMIXSERVER are set correctly in
setnet32.
> Check that INFORMIXDIR/bin is in the path.
> Check username and password that are set in setnet32 for the host
where
> maq1_tli is running.
> If nothing helps, contact Informix support.
>
> Leopold
>
> <dgarcia0@my-deja.com> wrote in message news:881jvf$jm1
$1@nnrp1.deja.com...
> > Hello,
> > I'm using Informix OLE DB Provider of Informix-Connect 2.3 in a
VB6.0
> > program. I set the connection string to:Provider=Ifxoledbc.2;User
> > ID=informix;Password=xxxx;Data Source=bd@maq1_tli;Extended
> > Properties="";
> > The database server is a Solaris 7 Server with IDS 7.3 UC7.
> > When I try connect with de database server using ADO DB in my
program I
> > get: XIX000:-25540: The esqlauth.dll has refused your connection.
> >
> > If I try connect using ILogin it runs correctly.
> >
> > Can anybody help me?
> >
> > Thanks in advance.
> >
> >
> > Sent via Deja.com http://www.deja.com/
> > Before you buy.
>
>
Sent via Deja.com http://www.deja.com/
Before you buy.