Re: HELP: Informix baffled by Seg. Viol.
Posted in 1996
Robert Donat (rdonat@sigg.com) wrote: : I have experienced Powerbuilder connections via Inet/ODBC which give : the following information in online.log (I run Online 7.13.UC1 on : Solaris 2.4): : 09:46:35 Assert Failed: Internal Error - Segmentation Violation : 09:46:35 Who:Session(46, x@x.sigg.com, -1, 218418024) : Thread(1058, scan_1.0, d038d10, 1) : 09:46:35 Results: OnLine must abort : 09:46:35 Action: Reinitialize shared memory : 09:46:35 See Also: /tmp/af.42270ca The contents of /tmp/af.42270ca would be helpful here. But just a wild guess... Do your queries do character-to-integer conversion? eg. WHERE charcol = 5 There is a bug where this will result in a SEGV if your charcol contains a non-numeric value. BTW, this is very bad for performance reasons as well -- it forces a sequential scan on your table (regardless of whether charcol is indexed) PLUS a char-to-int conversion for every row, and will return an error if your column contains a non-numeric (that is, once the bug that causes the SEGV is fixed ;-) Either make your charcol numeric, or put quotes around the 5. June ---- June Tong Informix Software ---- ---- Senior Consultant (415) 926-6140 ---- ---- International Support junet@informix.com ---- ---- Location-du-jour: Menlo Park ---- * * Standard disclaimers apply * - Please do not send me requests/questions by mail. When I have the knowledge - and time permits, I try to answer questions on comp.databases.informix, but - travel schedule, time, and volume make responding to personal requests - difficult and often slow. Please call your local Informix Technical Support - organization for assistance with technical issues.