RE: Error: dbspace chunk
Posted in 2000
Jerry
finderr 2 will tell you that the file /chunk/rootdbs does not exist
All this information is on your server to help you. Read the admin guide,
release notes on setting up a new instance.
MW
-----Original Message-----
From: owner-informix-list@iiug.iiug.org
[mailto:owner-informix-list@iiug.iiug.org]On Behalf Of Jerry Chimutanda
Sent: Friday, June 09, 2000 6:30 AM
To: COOPER, Joseph; informix-list@iiug.org
Subject: Re: Error: dbspace chunk
I have created my dbspace according to Joseph's advice (see below).
Now on running oninit -i, here is the Error message that I get.
# A warning that all existing servers will be dropped appears
Assertion Failure Type:\\t\\c
Warning
Hostname:\\t\\tpluto # hostname=pluto
Database Server Name:\\tdemo_on
Time of failure:\\t\\c
Thu Jun 8 20:16:35 BST 2000
AF file:\\t\\t/tmp/af.7f113
Shared Memory file:\\tNone
System Blocking:\\t\\c
OFF
oninit: Cannot open chunk '/chunks/rootdbs'. errno=2
oninit: Fatal Error in Shared Memory ininitialisation
WHAT COULD BE CAUSING THIS???
----- Original Message -----
From: "COOPER, Joseph" <Joseph.COOPER@sema.co.uk>
To: "'Jerry Chimutanda'" <jerry@compcentre.uz.ac.zw>;
<informix-list@iiug.org>
Sent: Thursday, June 08, 2000 5:42 PM
Subject: RE: Error: dbspace chunk
> > Hi people,
> >
> > I'm in my 4th weeek trying to get Informix up and running!
>
> :-)). The value of manuals ?
>
> >
> > The following are extracts from some of my configuration
> > files that I think
> > will help you diagnose my situation:
> >
> > Extract from /opt/informix/etc/onconfig
> >
> > ROOTNAME rootdbs> > ROOTPATH /dev/online_root
> > ROOTOFFSET 0
> > ROOTSIZE 2000
> > ..
> > ..> > PHYSDBS rootdbs
> > PHYSFILE 1000
> > SERVERNUM 0
> > DBSERVERNAME demo_on> >
> >
> > Extract from /etc/profile
> >
> > INFORMIXSERVER=demo_on> > export INFORMIXSERVER
> >
> >
> > Now, here are my questions.
> >
> > 1. The variable DBSERVERNAME in onconfig is the one I took
> > and placed for
> > INFORMIXSERVER in /etc/profile. Is that the correct value for the
> > INFORMIXSERVER variable? If not, how do I determine the correct value?
>
> Yep. That's okish. You may want to change both /etc/profile and onconfig
> and set the variable INFORMIXSERVER to something less common that demo_on.
> It should however work fine with demo_on.
>
> >
> > 2. The Rootdbs! Can somebody explain this one for me. In the
> > onconfig file,
> > does the value(string) online_root refer to a directory or a
> > file? How can I
> > create a dbspace that conforms with the above onconfig file (names and
> > paths)?
> > [ so far I had created online_root as a file under /dev,
> > owner/group=informix/informix, but still the initialisation
> > was complaining
> > that both owner ID and grp ID must be informix
> > This is how I had done it:
> > $ touch online_root
> > $ chown informix online_root
> > $ chgrp informix online_root
> > $ chmod 660 online_root
> > ]> >
> > 3. What is the minimum size of a rootdbs?
> >
>
> Well the minimum is a little larger that the size created by touch :-)
> The exact size I would guess is in the manual. Basically just increase
> it until the server starts is the easiest way to find out. However
> the default value specified in onconfig.std will do for starting online.
>
> What works for me is.
> Login as root
> cd /
> mkdir chunks
> chown informix chunks
> chgrp informix chunks
> chmod 660 chunks
> cd chunks
> touch /chunks/rootdbs
> chown informix rootdbs
> chgrp informix rootdbs
> chmod 660 rootdbs
>
> eidt onconfig and set
>
> ROOTNAME rootdbs
> ROOTPATH /chunks/rootdbs
> ROOTOFFSET 0
> ROOTSIZE 20000>
>
>
> Login as informix
> oninit -i>
>
> HTH
> Jo
> >
> > Thank you all for your responses
> >
> > Jerry.
> >
>
>
___________________________________________________________________________
> This email is confidential and intended solely for the use of the
> individual to whom it is addressed. Any views or opinions presented are
> solely those of the author and do not necessarily represent those of
> Sema Group.
> If you are not the intended recipient, be advised that you have received
this
> email in error and that any use, dissemination, forwarding, printing, or
> copying of this email is strictly prohibited.
>
> If you have received this email in error please notify the Sema Group
> Helpdesk by telephone on +44 (0) 121 627 5600.
>
___________________________________________________________________________
>