RE: ODBC 3.30.0010139 Error
Posted in 2000
Informix Technical Support has just provided the following information on bug #118407: "That bug has been fixed in the 3.32 ODBC driver, which will be available with Client SDK 2.50. 2.50 will be out in March." -----Original Message----- From: Nigel Gall [mailto:nigelg@ppsl.com] Sent: Monday, January 24, 2000 12:10 PM To: 'Reinhard Habichtsberg'; informix-list@iiug.org Subject: RE: ODBC 3.30.0010139 Error I have Informix 3.31 32 Bit driver, version 3.31.00.10287, obtained in Client SDK 2.40.TC1-1. In the accompanying release notes I found, the following existing Known Bug (with no workaround): **START 7. Bug 118407 When using MSAccess97 or MSquery to link to a table through the Informix 3.30 ODBC drivers on NT4.0, certain table names such as those containing 18 characters which are made up of two or more underscores cause: Invalid string of buffer length. (#-11071) error to occur, and the table can not be accessed. **END So you may want to contact Informix to determine when a fix will be provided. Or perhaps someone like Clem could inform us directly via this list? Best regards, Edmund Nigel Gall Senior Information Systems Specialist Process Plant Services Limited Atlantic Avenue, Point Lisas Industrial Estate Point Lisas, Couva, Trinidad & Tobago, W.I. Tel: (868) 636 2906 x 274 Fax: (868) 679 3770 -----Original Message----- From: Reinhard Habichtsberg [mailto:Reinhard.Habichtsberg@unilux.de] Sent: 1999 November 15 1:57 AM To: informix-list@iiug.org Subject: Re: ODBC 3.30.0010139 Error <mars1972@my-deja.com> wrote: >Reinhard wrote: >> 2. Is it possible that this ODBC-driver has the bug that it cannot >> work with table names including underscores, for example: >> a_table_name. If I want to bind such tables to a query I get the >> error: [Informix][Informix ODBC Driver][Informix]An illegal >> character has been found in the statement.(#-202) > > I have tables with underscores and haven't had any problems. > I have still this problem. Has anybody an idea? Reinhard