Nightmare NT configuration problem
Posted in 1999
Topics: Installation, Setup & Upgrades, Stored Procedures & SPL, Server Administration
Hi there,
I have a dead-end problem that I don't understand... (involved with
system installation so I simply can't work around it
I install Informix dynamic server (universal data option) on my Windows
NT 4.00 Server machine,
set up the environment variables and try to run oninit and the process
just hangs...
If I run oninit -v to get a verbose response I get the following:
Checking group membership to determine server run modesucceeded
Reading configuration file 'D:/informix/etc/onconfig.std'...succeeded
Creating INFXTMP/.infxdirs ... FAILED
Creating infos file "D:/informix/etc/.infos.neuroscholar" ...
"D:/informix/etc/.
conf.neuroscholar" ... succeeded
Writing to infos file ... succeeded
Checking config parameters...succeeded
Allocating and attaching to shared memory...succeeded
Creating resident pool 372 kbytes...succeeded
Creating buffer pool 804 kbytes...succeeded
Initializing rhead structure...succeeded
Initializing ASF ...succeeded
Initializing Dictionary Cache and Stored Procedure Cache...succeeded
Bringing up ADM VP...succeeded
Creating VP classes...succeeded
Onlining 0 additional cpu vps...succeeded
Onlining 1 IO vps...succeeded
Forking main_loop thread...succeeded
Initialzing DR structures...succeeded
Forking 1 'soctcp' listener threads...succeeded
and then it just waits forever....
the "Creating INFXTMP/.infxdirs ... FAILED" line is the only
identifiable error here.. How can I address this problem...
ANY HELP WOULD BE HUGELY APPRECIATED!!!
Gully Burns
USC Brain Project.
> I install Informix dynamic server (universal data option) on my Windows
> NT 4.00 Server machine,
> set up the environment variables and try to run oninit and the process
> just hangs...
Our customer had similar problem on 7.22 on NT 4.0 with SP4 installed.
Without SP4 it worked fine.
Due Y2K (SP4 solve it) he upgraded to 7.30
Leos
In article <378663E7.3F568858@usc.edu>,
Gully Burns <gully@usc.edu> wrote:
> Hi there,
>
> I have a dead-end problem that I don't understand... (involved with
> system installation so I simply can't work around it
>
> I install Informix dynamic server (universal data option) on my
Windows
> NT 4.00 Server machine,
> set up the environment variables and try to run oninit and the process
> just hangs...
Sorry, have you initialised your Informix server ? I mean "oninit -iy".
>
> If I run oninit -v to get a verbose response I get the following:
>
> Checking group membership to determine server run modesucceeded
> Reading configuration file 'D:/informix/etc/onconfig.std'...succeeded
> Creating INFXTMP/.infxdirs ... FAILED
Right there. INFXTMP is environment variable. Check path it is pointing
to, and if this directory is already created - check permissions.
> Creating infos file "D:/informix/etc/.infos.neuroscholar" ...
> "D:/informix/etc/.
> conf.neuroscholar" ... succeeded
> Writing to infos file ... succeeded
> Checking config parameters...succeeded
> Allocating and attaching to shared memory...succeeded
> Creating resident pool 372 kbytes...succeeded
> Creating buffer pool 804 kbytes...succeeded
> Initializing rhead structure...succeeded
> Initializing ASF ...succeeded
> Initializing Dictionary Cache and Stored Procedure Cache...succeeded
> Bringing up ADM VP...succeeded
> Creating VP classes...succeeded
> Onlining 0 additional cpu vps...succeeded
> Onlining 1 IO vps...succeeded
> Forking main_loop thread...succeeded
> Initialzing DR structures...succeeded
> Forking 1 'soctcp' listener threads...succeeded
>
> and then it just waits forever....
>
> the "Creating INFXTMP/.infxdirs ... FAILED" line is the only
> identifiable error here.. How can I address this problem...
>
> ANY HELP WOULD BE HUGELY APPRECIATED!!!
>
> Gully Burns
>
> USC Brain Project.
>
>
Looks like your server is not initialised ...
--
With best regards, Yuri Dovgart,
SAP R/3, Informix consultant,
"Telecominvest" company.
E-mail y_dovgart@tci.ukrtel.net
Sent via Deja.com http://www.deja.com/
Share what you know. Learn what you don't.
Leos Urban <Leos.Urban@aitix.cz> wrote in message news:7m6rng$if5$1@adis.cesnet.cz...
> > I install Informix dynamic server (universal data option) on my Windows
> > NT 4.00 Server machine,
> > set up the environment variables and try to run oninit and the process
> > just hangs...
>
> Our customer had similar problem on 7.22 on NT 4.0 with SP4 installed.
> Without SP4 it worked fine.
> Due Y2K (SP4 solve it) he upgraded to 7.30
> Leos
>
>
It does not work with NT SP4. oninit will try to start msgsrvr service to write to
NT event log, but due to changes in security scheme introduced in SP4 msgsrvr
will not start so oninit will wait forever and your disks will never be initialised. 7.30.TC7
fixed this problem for IDS. I don't know which version of IDS-UD is compatible with SP4.
--
Slobodan Zorko
======================================
Alfatec Group
Technical Support
Kranjceviceva 36, 10000 Zagreb
Phone: +385(1) 3647 077
E-Mail: slobodan.zorko@zg.tel.hr