Interference among instances
Posted in 1997
AIX Release 3
OnLine 7.13.UC3
Hi family,
I'm having a nasty situation on a client machine.
I have an instance, known my INFORMIXSERVER=bcbgshm. I created a new
instance named bctestshm with an alias of bctestsoc. I have taken great
care to avoid any kind of conflict. I created separate devices with
different [symbolic] links, carefully avoiding the dreaded consistency
check errors.
Yet, when I start up my bctest OnLine server, the production server goes
bananas. I tested this by running both environments in separate windows.
In the bcbg production window I ran dbaccess and connected to the
database. Then I exited. In the bctest environment window, I started up
my bctestshm server, then switched back to the bcbg production window.
Now, when I started dbaccess <database> I got error:
-761 INFORMIXSERVER does not match either DBSERVERNAME or
DBSERVERALIASES.
This is a lie! If it had mismatched I could not have gotten in
previously.
OK, so the test system is somehow interfering with the production
system. Bad enough. But when I shut down the bctest instance and try
to get into the production side's dbaccess again, I now get error:
-25588 The appl process cannot connect to OnLine server server-name.
Why the *^%$%! NOT? What is interfering now?
What makes this worse that I am unable to completely shut down the
production instance to start it up again. One of the shared memory
segments won't quite go away. The ipcs -m shows a lingering line:
IPC status from /dev/mem as of Mon Nov 10 16:11:41 PST 1997
T ID KEY MODE OWNER GROUP
Shared Memory:
m 4100 00000000 D-rw-rw-rw- root informix
I got them back up by editing the $ONCONFIG file and changing the server
number from 2 to 3. The fact that they come back up on-line without a
hitch indicates that my disk parameters are perfectly in order.
Here is a checklist of what I have definitely avoided conflict:
+--------------------+--------------------+
| Production Server | Test Server |
+--------------------+--------------------+
INFORMIXDIR |/informix |/informix |
ONCONFIG |onconfig.bdbg |onconfig.bctest |
INFORMIXSERVER |bcbgshm |bctestshm |
DBSERVERNUM |2 |4 |
DBSERVERNAME |bcbgshm |bctestshm |DBSERVERALIAS |bcbgsoc |bctestsoc |
TCP Service Name |bsoc |bctest_svc |
TCP Service # |2500 |2501 |
+--------------------+--------------------+
Thanks for any ideas, solutions, known bugs, workarounds etc.
--
-- Jake (Never yelled "CROWDED THEATER!" during a fire)
+------------------------------------------------------------+
| The expedient performance of a task with excessive concern |
| regarding its duration-to-completion engenders a virtual |
| certainty of diminished benefit therefrom. |
| -- Benjamin Franklin (but he said it in 3 words) |
+------------------------------------------------------------+