Re: Help:informix database backup/restore with netbackup agent.
Posted in 2005
Hi,
the message "could not fork server connection,
SQLCODE -25596" means that the server (IDS's oninit
processes) could not be started, or they could be started but
it was not possible to connect to them.
The XBSA error then is the following error caused by the
resulting abort.
Check whether there are any "oninit" processes running
for this instance after a restore attempt ("ps -ef | grep oninit"
if you have only this one instance on this machine).
If there are any, remove them, remove possibly left-over
shared memory segments ("ipcrm ..."). Then check that your
protocol for server connections is configured properly
("onsoctcp", ontlitcp", onipcshm", ...).
Then try again.
For additional info you can switch on debug tracing in
ON-Bar. Set the parameters in your onconfig file,
respectively BAR_DEBUG_LOG to a filename and
BAR_DEBUG to a digit between 2 and 6. Then try again
and afterwards try to figure out from the debug log file
what the problem is, or open a case with IBM Informix
Tech Support and let them help you.
Regards,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany
Information Management
owner-informix-list@iiug.org wrote on 17.06.2005 17:02:01:
> Thanks for the help,
>
> I check activity log, it says:
> 2005-06-16 18:57:58 13215 13213 /opt/informix/bin/onbar_d -r -w
> 2005-06-16 18:57:59 13215 13213 Working with veritas-netbackup as
generic
> stor
> age manager.
> 2005-06-16 18:58:00 13215 13213 Successfully connected to Storage
Manager.
> 2005-06-16 19:01:00 13215 13213 Begin salvage for log 2.
> 2005-06-16 19:01:43 13215 13213 Completed salvage of logical log 2.
> 2005-06-16 19:01:48 13215 13213 Successfully connected to Storage
Manager.
> 2005-06-16 19:01:58 13215 13213 Begin cold level 0 restore rootdbs
> (Storage Ma
> nager copy ID: 1 1118961048).
> 2005-06-16 19:04:24 13215 13213 Unable to write storage space restore
data
> to
> the database server: could not fork server connection, SQLCODE -25596.
> 2005-06-16 19:04:24 13215 13213 Skipped backup/restore of space
'rootdbs'.
> d. Aborting XBSA session. 13213 XBSA Error: (BSAEndData) A system
error
> occurr
> l not be attempted.4 13215 13213 Due to the previous error, logical
restore
> wil
> 2005-06-16 19:04:54 13215 13213 /opt/informix/bin/onbar_d complete,
> returning
> 3 (0x03)
>
> Regards,
>
> Bin
> "Brice" <briceavila@hotmail.com> wrote in message
> news:1118765268.272948.256050@g47g2000cwa.googlegroups.com...
> > What is the BAR_ACT_LOG errors that you recieved? What are the
> > errors/warnings in the "/usr/openv/netbackup/logs/infxbsa/log.<date>"
> > file?
> >
> > 1. If you backup using "onbar -b -w", you should restore using either
> > "onbar -r -w" or "onbar -r -p -w".
> >
> > 2. LTAPEDEV should not bet set to /dev/null
> >
> > 3. You can cold-restore over a damaged database. One should not warm
> > restore over a damaged database.
> >
> > Hope this helps.
> >
> > Brice Avila
> >
> > Bin Zhu wrote:
> > > Hi,
> > >
> > > I am using Informix netbackup agent for backup and restore.
> > >
> > > The backup is done by using onbar -b -w
> > >
> > > However the restore failed by onbar -r -p or onbar -r -p -w.
> > >
> > > Is it LTAPDEV and TAPEDEV set to /dev/null causing the problem?
> > >
> > > Do I need to delete or "damage" the database before I do a restore?
> > >
> > > Any comment will be appreicated.
> > >
> > > Thanks
> > >
> > > Bin
> >
>
>
sending to informix-list