ESQL/C: -461 error
Posted in 2000
Topics: Error Codes & Troubleshooting, Connectivity: ESQL/C, 4GL & Embedded SQL
Hi, I always get this error when getting a blob from the db using esqlc. SQLCODE: -461 ISAM: 0 I checked the permissions, all look OK. Somebody help me with this... INFORMIX-SQL Version 6.05.UD1 AIX 4.3.3.0 Thanks, Sunil
The error -461 refers to reading a file into a BLOB column or writing a
BLOB column into a file using the LOC_FILE or LOC_FNAME method using
descriptors or the sqlda structure. If you are not doing this, and the fact
that the ISAM code is zero indicates that you are not, know that this error
is also some kind of default message that is output when a front-end cannot
read the current message files in the Informix installation directories.
This usually happens when you run an executable compiled with a later
version of ESQL/C or 4GL than the runtime installation on the system on
which it is being run. It can also happen when you link objects compiled
with different versions of ESQL/C or 4GL. Lastly it can happen if you
mistakenly install an earlier product over a later one, ie you installed
C4GL 7.20 AFTER installing ESQL/C 9.40 from the SDK 2.40 release.
Tell us what is the version of ESQL and of the engine and runtime
environment on the system. Run 'esql -V', oninit -V (OK with the engine
online), and the contents of the file $INFORMIXDIR/etc/Connect-cr or
$INFORMIXDIR/etc/ClientSDK-cr. Also if you have permissions, as root
type out the contents of $INFORMIXDIR/etc/.snfile and post the order of
the products listed.
Art S. Kagel
"Bhaskarla, Sunil" wrote:
>
> Hi,
> I always get this error when getting a blob from the db using esqlc.
>
> SQLCODE: -461
> ISAM: 0
>
> I checked the permissions, all look OK.
>
> Somebody help me with this...
>
> INFORMIX-SQL Version 6.05.UD1
> AIX 4.3.3.0
>
> Thanks,
> Sunil