Re: Fw: Informix Failing to Come Up
Posted in 2005
Topics: Installation, Setup & Upgrades, Error Codes & Troubleshooting
Hi,
no, you can not delete a log file while in recovery mode.
I advice you to open a case with IBM Technical Support.
They will determine the best way to fix your problem and
will help you do it (or do it for you).
They may also advice you on what the root cause might
be and if it is a problem in IDS whether this problem has
already been fixed, and to which version you should
upgrade in order to avoid this problem in future.
Regards,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany
Information Management
owner-informix-list@iiug.org wrote on 19.07.2005 14:23:41:
>
> My informix if failing to come up.
>
> The following is part of the log..............
>
> File: rsextlog.c Line: 1450
> 12:03:36 Results: Log record (OLDRSAM:HDELETE) in log 119471, offset0x1cf52fc was not rolled back
> 12:03:36 Action: Use 'onlog' to view the transaction and repair
manually.
> 12:03:45 See Also: /apps/tmp/af.40acfef
> 12:03:45 Assert Failed: Dynamic Server must abort
> 12:03:45 Informix Dynamic Server Version 7.31.UC5
> 12:03:45 Who: Session(7, informix@posbho, 0, 812111464)
> Thread(34, fast_rec, 30658ed8, 5)
> File: rslog.c Line: 3180
> 12:03:45 Results: Dynamic Server must abort
> 12:03:45 Action: Reinitialize shared memory
> 12:03:54 See Also: /apps/tmp/af.40acfef
> 12:03:54 rslog.c, line 3180, thread 34, proc id 14859, Dynamic Servermust abort.
> 12:03:54 PANIC: Attempting to bring system down>
> Tue Jul 19 12:19:02 2005
>
> 12:19:02 Event alarms enabled. ALARMPROG =
'/apps/informix/etc/log_full.sh'
> 12:19:07 DR: DRAUTO is 0 (Off)
> 12:19:07 Informix Dynamic Server Version 7.31.UC5 Software SerialNumber AAC#J869162
> 12:19:10 Informix Dynamic Server Initialized -- Shared MemoryInitialized.
> 12:19:10 Physical Recovery Started.
> 12:19:12 Physical Recovery Complete: 11008 Pages Restored.
> 12:19:12 Logical Recovery Started.
> 12:22:00 Assert Failed: Rollback error 126
> 12:22:00 Informix Dynamic Server Version 7.31.UC5
> 12:22:00 Who: Session(7, informix@posbho, 0, 812111464)
> Thread(34, fast_rec, 30658ed8, 3)
> File: rstrans.c Line: 2197
> 12:22:00 Results: Log record (OLDRSAM:HDELETE) in log 119471, offset0x1cf52fc was not rolled back
> 12:22:00 Action: Use 'onlog' to view the transaction and repair
manually.
> 12:22:08 See Also: /apps/tmp/af.40ad447
> 12:22:08 Assert Failed: Rollback error 126
> 12:22:08 Informix Dynamic Server Version 7.31.UC5
> 12:22:08 Who: Session(7, informix@posbho, 0, 812111464)
> Thread(34, fast_rec, 30658ed8, 3)
> File: rsextlog.c Line: 1450
> 12:22:08 Results: Log record (OLDRSAM:HDELETE) in log 119471, offset0x1cf52fc was not rolled back
> 12:22:08 Action: Use 'onlog' to view the transaction and repair
manually.
> 12:22:16 See Also: /apps/tmp/af.40ad447
> 12:22:16 Assert Failed: Dynamic Server must abort
> 12:22:16 Informix Dynamic Server Version 7.31.UC5
> 12:22:16 Who: Session(7, informix@posbho, 0, 812111464)
> Thread(34, fast_rec, 30658ed8, 3)
> File: rslog.c Line: 3180
> 12:22:16 Results: Dynamic Server must abort
> 12:22:16 Action: Reinitialize shared memory
> 12:22:25 See Also: /apps/tmp/af.40ad447
> 12:22:25 rslog.c, line 3180, thread 34, proc id 15817, Dynamic Servermust abort.
> 12:22:25 PANIC: Attempting to bring system down>
>
>
>
>
>
> The system crashes during recovery and does not go on-line or to
quiescent. I can't use the onparams utility while the server is in this
state.
>
> Can I drop/delete log '119471' the while the system is in 'Fast
Recorvery'?
>
> Erick M. Bvukurusi
>
> tel : +2634251756
>
sending to informix-list
Martin Fuerderer wrote:
> Hi,
>
> no, you can not delete a log file while in recovery mode.
>
> I advice you to open a case with IBM Technical Support.
> They will determine the best way to fix your problem and
> will help you do it (or do it for you).
>
> They may also advice you on what the root cause might
> be and if it is a problem in IDS whether this problem has
> already been fixed, and to which version you should
> upgrade in order to avoid this problem in future.
>
> Regards,
> Martin
> --
> Martin Fuerderer
> IBM Informix Development Munich, Germany
> Information Management
>
> owner-informix-list@iiug.org wrote on 19.07.2005 14:23:41:
> >
> > My informix if failing to come up.
> >
> > The following is part of the log..............
> >
> > File: rsextlog.c Line: 1450
> > 12:03:36 Results: Log record (OLDRSAM:HDELETE) in log 119471, offset> 0x1cf52fc was not rolled back
> > 12:03:36 Action: Use 'onlog' to view the transaction and repair
> manually.
> > 12:03:45 See Also: /apps/tmp/af.40acfef
> > 12:03:45 Assert Failed: Dynamic Server must abort
> > 12:03:45 Informix Dynamic Server Version 7.31.UC5
> > 12:03:45 Who: Session(7, informix@posbho, 0, 812111464)
> > Thread(34, fast_rec, 30658ed8, 5)
> > File: rslog.c Line: 3180
> > 12:03:45 Results: Dynamic Server must abort
> > 12:03:45 Action: Reinitialize shared memory
> > 12:03:54 See Also: /apps/tmp/af.40acfef
> > 12:03:54 rslog.c, line 3180, thread 34, proc id 14859, Dynamic Server> must abort.
> > 12:03:54 PANIC: Attempting to bring system down> >
> > Tue Jul 19 12:19:02 2005
> >
> > 12:19:02 Event alarms enabled. ALARMPROG =
> '/apps/informix/etc/log_full.sh'
> > 12:19:07 DR: DRAUTO is 0 (Off)
> > 12:19:07 Informix Dynamic Server Version 7.31.UC5 Software Serial> Number AAC#J869162
> > 12:19:10 Informix Dynamic Server Initialized -- Shared Memory> Initialized.
> > 12:19:10 Physical Recovery Started.
> > 12:19:12 Physical Recovery Complete: 11008 Pages Restored.
> > 12:19:12 Logical Recovery Started.
> > 12:22:00 Assert Failed: Rollback error 126
> > 12:22:00 Informix Dynamic Server Version 7.31.UC5
> > 12:22:00 Who: Session(7, informix@posbho, 0, 812111464)
> > Thread(34, fast_rec, 30658ed8, 3)
> > File: rstrans.c Line: 2197
> > 12:22:00 Results: Log record (OLDRSAM:HDELETE) in log 119471, offset> 0x1cf52fc was not rolled back
> > 12:22:00 Action: Use 'onlog' to view the transaction and repair
> manually.
> > 12:22:08 See Also: /apps/tmp/af.40ad447
> > 12:22:08 Assert Failed: Rollback error 126
> > 12:22:08 Informix Dynamic Server Version 7.31.UC5
> > 12:22:08 Who: Session(7, informix@posbho, 0, 812111464)
> > Thread(34, fast_rec, 30658ed8, 3)
> > File: rsextlog.c Line: 1450
> > 12:22:08 Results: Log record (OLDRSAM:HDELETE) in log 119471, offset> 0x1cf52fc was not rolled back
> > 12:22:08 Action: Use 'onlog' to view the transaction and repair
> manually.
> > 12:22:16 See Also: /apps/tmp/af.40ad447
> > 12:22:16 Assert Failed: Dynamic Server must abort
> > 12:22:16 Informix Dynamic Server Version 7.31.UC5
> > 12:22:16 Who: Session(7, informix@posbho, 0, 812111464)
> > Thread(34, fast_rec, 30658ed8, 3)
> > File: rslog.c Line: 3180
> > 12:22:16 Results: Dynamic Server must abort
> > 12:22:16 Action: Reinitialize shared memory
> > 12:22:25 See Also: /apps/tmp/af.40ad447
> > 12:22:25 rslog.c, line 3180, thread 34, proc id 15817, Dynamic Server> must abort.
> > 12:22:25 PANIC: Attempting to bring system down> >
> >
> >
> >
> >
> >
> > The system crashes during recovery and does not go on-line or to
> quiescent. I can't use the onparams utility while the server is in this
> state.
> >
> > Can I drop/delete log '119471' the while the system is in 'Fast
> Recorvery'?
> >
> > Erick M. Bvukurusi
> >
> > tel : +2634251756
> >
> sending to informix-list
Erick,
Might be time to dig out an archive and roll forward the logical logs
to a point just before the corrupted log!
As martin said, if you have a maintenance contract with IBM, you should
call them and see what other options you have.
You are still running 7.31.UC5. this has been superseded and IBM
Informix is now well into the UD number set. There are known logical
recovery problem in some of the UC and maybe even early UD products. So
I would recommed once you get online again you start to look at getting
to a more current version of the product.
Also the 7.31.UC products will stop being supported from April next
year (only 9 months away) IBM will only continue to support the IDS
7.31.UDx