onstat shared memory error
Posted in 2006
Topics: Storage & Space Management, Server Administration, Security, Permissions & Auditing
I am running INFORMIX IDS9.40 on Slackware 10.1 and everything works
fine except that informix cannot run onstat due to the shared memory:
permission denied error. The database chunks reside on a smart array
disk system, so I did a
raw /dev/raw/raw1 /dev/cciss/c0d0p3 so I would have a character
device. I then soft linked a file with informix.informix access just
for readability with the onconfig file.
I can run the command as root, and if I make informix part of the Disk
group, he can run it as well. Is there an issue with giving informix
access to Disk group, or is there another was to set up the chunk? I
have no problems with scrapping the chunks and reloading the database.
I do know this does not happen when I use cooked files. Is this the
better way to go?
Thanks for any assistance
malabapa wrote:
> I am running INFORMIX IDS9.40 on Slackware 10.1 and everything works
> fine except that informix cannot run onstat due to the shared memory:
> permission denied error. The database chunks reside on a smart array
> disk system, so I did a
>
> raw /dev/raw/raw1 /dev/cciss/c0d0p3 so I would have a character
> device. I then soft linked a file with informix.informix access just
> for readability with the onconfig file.
>
> I can run the command as root, and if I make informix part of the Disk
> group, he can run it as well. Is there an issue with giving informix
> access to Disk group, or is there another was to set up the chunk? I
> have no problems with scrapping the chunks and reloading the database.
>
> I do know this does not happen when I use cooked files. Is this the
> better way to go?
>
> Thanks for any assistance
>
You're likely having that problem because you started the engine instance as
root. IDS 9.xx & 10.xx want to run as 'informix'.
Art S. Kagel
Do you have the problem with any onstat command or only certain ones ?
IDS10 tightened up the onstat commands, and some of them can only be run as informix or root.
========================
-<<Floyd Wellershaus>>-
Database Administrator
Unix Administrator
email: fwellers@yahoo.com
Home: 703-430-0805
Cell: 703-477-6045
========================
http://www.one.org/
----- Original Message ----
From: malabapa <malabapa@ci.harrisonburg.va.us>
To: informix-list@iiug.org
Sent: Wednesday, August 2, 2006 4:25:24 PM
Subject: onstat shared memory error
I am running INFORMIX IDS9.40 on Slackware 10.1 and everything works
fine except that informix cannot run onstat due to the shared memory:
permission denied error. The database chunks reside on a smart array
disk system, so I did a
raw /dev/raw/raw1 /dev/cciss/c0d0p3 so I would have a character
device. I then soft linked a file with informix.informix access just
for readability with the onconfig file.
I can run the command as root, and if I make informix part of the Disk
group, he can run it as well. Is there an issue with giving informix
access to Disk group, or is there another was to set up the chunk? I
have no problems with scrapping the chunks and reloading the database.
I do know this does not happen when I use cooked files. Is this the
better way to go?
Thanks for any assistance
_______________________________________________
Informix-list mailing list
Informix-list@iiug.org
http://www.iiug.org/mailman/listinfo/informix-list
Also, check the permissions of the items in your INFORMIXDIR/bin
Here are my permissions from that directory:
-rwsr-sr-x root informix mkdbsdir
-rwsr-sr-x root informix sgidsh
-rwsr-sr-x root informix onedcu
-rwxr-sr-x informix informix onedpu
-rwxr-sr-x informix informix xtree
-rwsr-sr-x root informix ondblog
-rwsr-sr-x root informix onsnmp
-rwsr-sr-x root informix onsrvapd
-rwsr-sr-x root informix snmpdm
-rwsr-sr-x root informix snmpdp
-rwxr-sr-x informix informix oncheck
-rwxr-sr-x informix informix onload
-rwxr-sr-x informix informix onparams
-rwxr-sr-x informix informix onspaces
-rwxr-sr-x informix informix onstat
-rwxr-sr-x informix informix onarchive
-rwxr-sr-x informix informix onautovop
-rwsr-sr-x informix informix oncatlgr
-rwxr-sr-x informix informix ondatartr
-rwxr-sr-x informix informix onkeymgr
-rwxr-sr-x informix informix onlog
-rwxr-sr-x informix informix onunload
-rwxr-sr-x informix informix onpload
-rwsr-sr-- root informix oninit
-rwsr-sr-x root informix onmonitor
-rwsr-sr-x root informix ontape
-rwsr-sr-x root informix onaudit
-rwsr-sr-x root informix onbar_d
-rwsr-sr-x root informix onmode
-rwsr-sr-x root informix onshowaudit
-rwsr-sr-x root informix onsmsync
You might have forgotten to run that as root portion of the install. So
to compensate you are starting the engine as root, etc. Notice that the
bulk of the on* executables promote themselves to root while they are
running.
Also, I think you have to have a group informix and a user informix.
Check the installation guide again to make sure that you set up the
informix user correctly.
malabapa wrote:
> I am running INFORMIX IDS9.40 on Slackware 10.1 and everything works
> fine except that informix cannot run onstat due to the shared memory:
> permission denied error. The database chunks reside on a smart array
> disk system, so I did a
>
> raw /dev/raw/raw1 /dev/cciss/c0d0p3 so I would have a character
> device. I then soft linked a file with informix.informix access just
> for readability with the onconfig file.
>
> I can run the command as root, and if I make informix part of the Disk
> group, he can run it as well. Is there an issue with giving informix
> access to Disk group, or is there another was to set up the chunk? I
> have no problems with scrapping the chunks and reloading the database.
>
> I do know this does not happen when I use cooked files. Is this the
> better way to go?
>
> Thanks for any assistance
one billion and one thank yous.... The RUN_AS_ROOT.server command did
fail. I ran the script by hand and all is well. Thanks to everyone
who lent a suggestion.
Paul
bozon wrote:
> Also, check the permissions of the items in your INFORMIXDIR/bin
>
> Here are my permissions from that directory:
>
> -rwsr-sr-x root informix mkdbsdir
> -rwsr-sr-x root informix sgidsh
> -rwsr-sr-x root informix onedcu
> -rwxr-sr-x informix informix onedpu
> -rwxr-sr-x informix informix xtree
> -rwsr-sr-x root informix ondblog
> -rwsr-sr-x root informix onsnmp
> -rwsr-sr-x root informix onsrvapd
> -rwsr-sr-x root informix snmpdm
> -rwsr-sr-x root informix snmpdp
> -rwxr-sr-x informix informix oncheck
> -rwxr-sr-x informix informix onload
> -rwxr-sr-x informix informix onparams
> -rwxr-sr-x informix informix onspaces
> -rwxr-sr-x informix informix onstat
> -rwxr-sr-x informix informix onarchive
> -rwxr-sr-x informix informix onautovop
> -rwsr-sr-x informix informix oncatlgr
> -rwxr-sr-x informix informix ondatartr
> -rwxr-sr-x informix informix onkeymgr
> -rwxr-sr-x informix informix onlog
> -rwxr-sr-x informix informix onunload
> -rwxr-sr-x informix informix onpload
> -rwsr-sr-- root informix oninit
> -rwsr-sr-x root informix onmonitor
> -rwsr-sr-x root informix ontape
> -rwsr-sr-x root informix onaudit
> -rwsr-sr-x root informix onbar_d
> -rwsr-sr-x root informix onmode
> -rwsr-sr-x root informix onshowaudit
> -rwsr-sr-x root informix onsmsync
>
> You might have forgotten to run that as root portion of the install. So
> to compensate you are starting the engine as root, etc. Notice that the
> bulk of the on* executables promote themselves to root while they are
> running.
>
> Also, I think you have to have a group informix and a user informix.
> Check the installation guide again to make sure that you set up the
> informix user correctly.
>
> malabapa wrote:
> > I am running INFORMIX IDS9.40 on Slackware 10.1 and everything works
> > fine except that informix cannot run onstat due to the shared memory:
> > permission denied error. The database chunks reside on a smart array
> > disk system, so I did a
> >
> > raw /dev/raw/raw1 /dev/cciss/c0d0p3 so I would have a character
> > device. I then soft linked a file with informix.informix access just
> > for readability with the onconfig file.
> >
> > I can run the command as root, and if I make informix part of the Disk
> > group, he can run it as well. Is there an issue with giving informix
> > access to Disk group, or is there another was to set up the chunk? I
> > have no problems with scrapping the chunks and reloading the database.
> >
> > I do know this does not happen when I use cooked files. Is this the
> > better way to go?
> >
> > Thanks for any assistance