RE: DBspace temp1 down after restore
Posted in 2009
Topics: Backup & Restore, Storage & Space Management, Server Administration, Logging & Checkpoints, Platform-Specific Issues
Hi Jacques
Check the ONCONFIG file, regard about:
ONDBSPACEDOWNONDBSPACEDOWN
onconfig.std value
0
range of values
0, 1, 2
refer to
Monitoring the database server for disabling I/O errors, in the chapter on
consistency checking in the IBM Informix Administrator's Guide
ONDBSPACEDOWN defines the action that the database server will take when any
disabling event occurs on a noncritical dbspace. The following values are valid
for this parameter.
Value
Description
0
Continue. Causes the database server to mark a noncritical dbspace down and
continue whenever a disabling I/O error occurs on it.
1
Abort. Causes the database server to fail
without allowing a checkpoint to occur whenever a disabling I/O error occurs on
any dbspace. Critical dbspaces run only in this mode.
2
Wait. Causes the database server to hang all updating threads as soon as the
next checkpoint request occurs after a disabling I/O occurs on a noncritical
dbspace. If now not 0 , change it to 0 and restart the instance. Check if the
dbspace is listed in DBSPACETEMP parameter in the same ONCONFIG file.
If you lost a TEMP dbspace (I can say the chunk of the dbspace temp), not a
problem, because you can rebuilt it using onspaces. Drop the dbspace temp and
create a new.
Best regards.
R Ferronato
> To: ids@iiug.org
> From: art.kagel@gmail.com
> Subject: Re: DBspace temp1 down after restore [14996]
> Date: Tue, 24 Feb 2009 10:31:03 -0500
>
> If the physical and logical disks are actually OK, your restore should bring
> all chunks back to online mode. If they are not, then the restore will
> fail. If only the tempdb space is physically bad, you may not know until
> you try to write to it.
>
> Art
>
> On Tue, Feb 24, 2009 at 7:52 AM, JACQUES LAPEIRE <
> jacques.lapeire@fujitsu-siemens.com> wrote:
>
> > Hi Guys,
> >
> > had some troubles with power and lost some disks last night.
> > Running 9.40 FC7 on Solaris.
> >
> > There were some I/O errors and 3 chunks were down.
> > For the moment a restore (onbar -r) is still running (could salvage the
> > current logical log), but I wonder what will happen when the restore is
> > finished.
> >
> > The dbspace temp1 was down, and there is no backup for this temporary
> > dbspace.
> > What's the best way to get rid of this ?
> >
> > Patch it online with onspaces -s temp1 -p /xxxxxx -o 0 -O
> > or remove it from the config file, startup again and add a new temp1
> > dbspace
> > on the same location ?
> > Or will it come online again automatically ?
> >
> > Thx,
> > Best regards,
> > JAcques Lapeire
> >
> >
> >
> >
>
*******************************************************************************
> > Forum Note: Use "Reply" to post a response in the discussion forum.
> >
> >
>
> --
> Art S. Kagel
> Oninit (www.oninit.com)
> IIUG Board of Directors (art@iiug.org)
>
> Disclaimer: Please keep in mind that my own opinions are my own opinions and
> do not reflect on my employer, Oninit, the IIUG, nor any other organization
> with which I am associated either explicitly or implicitly. Neither do
> those opinions reflect those of other individuals affiliated with any entity
> with which I am affiliated nor those of the entities themselves.
>
> --00163631059d0ac3400463abce2a
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
_________________________________________________________________
Show them the way! Add maps and directions to your party invites.
http://www.microsoft.com/windows/windowslive/products/events.aspx
Thanks for the replies.
In the mean time, the restore has finished and all dbspaces and chunks
(including temp1) have become online.
I'm just wondering about 1 thing : during the logical restore, the log 2413 is
handled followed by the 2415
(the one that was salvaged) but 2414 seems to be skipped.
Thx
Jacques
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of R Fo
Sent: Tuesday, February 24, 2009 7:57 PM
To: ids@iiug.org
Subject: RE: DBspace temp1 down after restore [15004]
Hi Jacques
Check the ONCONFIG file, regard about:
ONDBSPACEDOWNONDBSPACEDOWN
onconfig.std value
0
range of values
0, 1, 2
refer to
Monitoring the database server for disabling I/O errors, in the chapter on
consistency checking in the IBM Informix Administrator's Guide
ONDBSPACEDOWN defines the action that the database server will take when any
disabling event occurs on a noncritical dbspace. The following values are
valid for this parameter.
Value
Description
0
Continue. Causes the database server to mark a noncritical dbspace down and
continue whenever a disabling I/O error occurs on it.
1
Abort. Causes the database server to fail without allowing a checkpoint to
occur whenever a disabling I/O error occurs on any dbspace. Critical dbspaces
run only in this mode.
2
Wait. Causes the database server to hang all updating threads as soon as the
next checkpoint request occurs after a disabling I/O occurs on a noncritical
dbspace. If now not 0 , change it to 0 and restart the instance. Check if the
dbspace is listed in DBSPACETEMP parameter in the same ONCONFIG file.
If you lost a TEMP dbspace (I can say the chunk of the dbspace temp), not a
problem, because you can rebuilt it using onspaces. Drop the dbspace temp and
create a new.
Best regards.
R Ferronato
> To: ids@iiug.org
> From: art.kagel@gmail.com
> Subject: Re: DBspace temp1 down after restore [14996]
> Date: Tue, 24 Feb 2009 10:31:03 -0500
>
> If the physical and logical disks are actually OK, your restore should
> bring all chunks back to online mode. If they are not, then the
> restore will fail. If only the tempdb space is physically bad, you may
> not know until you try to write to it.
>
> Art
>
> On Tue, Feb 24, 2009 at 7:52 AM, JACQUES LAPEIRE <
> jacques.lapeire@fujitsu-siemens.com> wrote:
>
> > Hi Guys,
> >
> > had some troubles with power and lost some disks last night.
> > Running 9.40 FC7 on Solaris.
> >
> > There were some I/O errors and 3 chunks were down.
> > For the moment a restore (onbar -r) is still running (could salvage
> > the current logical log), but I wonder what will happen when the
> > restore is finished.
> >
> > The dbspace temp1 was down, and there is no backup for this
> > temporary dbspace.
> > What's the best way to get rid of this ?
> >
> > Patch it online with onspaces -s temp1 -p /xxxxxx -o 0 -O or remove
> > it from the config file, startup again and add a new temp1 dbspace
> > on the same location ?
> > Or will it come online again automatically ?
> >
> > Thx,
> > Best regards,
> > JAcques Lapeire
> >
> >
> >
> >
>
*******************************************************************************
> > Forum Note: Use "Reply" to post a response in the discussion forum.
> >
> >
>
> --
> Art S. Kagel
> Oninit (www.oninit.com)
> IIUG Board of Directors (art@iiug.org)
>
> Disclaimer: Please keep in mind that my own opinions are my own
> opinions and do not reflect on my employer, Oninit, the IIUG, nor any
> other organization with which I am associated either explicitly or
> implicitly. Neither do those opinions reflect those of other
> individuals affiliated with any entity with which I am affiliated nor those
of the entities themselves.
>
> --00163631059d0ac3400463abce2a
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
_________________________________________________________________
Show them the way! Add maps and directions to your party invites.
http://www.microsoft.com/windows/windowslive/products/events.aspx
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
Unlikely, unless it was empty. More likely it was archived along with 2415
and restored with it as well.
Art
On Tue, Feb 24, 2009 at 2:50 PM, Lapeire, Jacques <
Jacques.Lapeire@fujitsu-siemens.com> wrote:
> Thanks for the replies.
>
> In the mean time, the restore has finished and all dbspaces and chunks
> (including temp1) have become online.
>
> I'm just wondering about 1 thing : during the logical restore, the log 2413
> is
> handled followed by the 2415
> (the one that was salvaged) but 2414 seems to be skipped.
>
> Thx
> Jacques
>
> -----Original Message-----
> From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of R Fo
> Sent: Tuesday, February 24, 2009 7:57 PM
> To: ids@iiug.org
> Subject: RE: DBspace temp1 down after restore [15004]
>
> Hi Jacques
>
> Check the ONCONFIG file, regard about:
> ONDBSPACEDOWNONDBSPACEDOWN
> onconfig.std value
> 0
> range of values
> 0, 1, 2
> refer to
> Monitoring the database server for disabling I/O errors, in the chapter on
> consistency checking in the IBM Informix Administrator's Guide
>
> ONDBSPACEDOWN defines the action that the database server will take when
> any
> disabling event occurs on a noncritical dbspace. The following values are
> valid for this parameter.
>
> Value
> Description
> 0
> Continue. Causes the database server to mark a noncritical dbspace down and
> continue whenever a disabling I/O error occurs on it.
> 1
> Abort. Causes the database server to fail without allowing a checkpoint to
> occur whenever a disabling I/O error occurs on any dbspace. Critical
> dbspaces
> run only in this mode.
> 2
> Wait. Causes the database server to hang all updating threads as soon as
> the
> next checkpoint request occurs after a disabling I/O occurs on a
> noncritical
> dbspace. If now not 0 , change it to 0 and restart the instance. Check if
> the
> dbspace is listed in DBSPACETEMP parameter in the same ONCONFIG file.
>
> If you lost a TEMP dbspace (I can say the chunk of the dbspace temp), not a
> problem, because you can rebuilt it using onspaces. Drop the dbspace temp
> and
> create a new.
>
> Best regards.
>
> R Ferronato
>
> > To: ids@iiug.org
> > From: art.kagel@gmail.com
> > Subject: Re: DBspace temp1 down after restore [14996]
> > Date: Tue, 24 Feb 2009 10:31:03 -0500
> >
> > If the physical and logical disks are actually OK, your restore should
> > bring all chunks back to online mode. If they are not, then the
> > restore will fail. If only the tempdb space is physically bad, you may
> > not know until you try to write to it.
> >
> > Art
> >
> > On Tue, Feb 24, 2009 at 7:52 AM, JACQUES LAPEIRE <
> > jacques.lapeire@fujitsu-siemens.com> wrote:
> >
> > > Hi Guys,
> > >
> > > had some troubles with power and lost some disks last night.
> > > Running 9.40 FC7 on Solaris.
> > >
> > > There were some I/O errors and 3 chunks were down.
> > > For the moment a restore (onbar -r) is still running (could salvage
> > > the current logical log), but I wonder what will happen when the
> > > restore is finished.
> > >
> > > The dbspace temp1 was down, and there is no backup for this
> > > temporary dbspace.
> > > What's the best way to get rid of this ?
> > >
> > > Patch it online with onspaces -s temp1 -p /xxxxxx -o 0 -O or remove
> > > it from the config file, startup again and add a new temp1 dbspace
> > > on the same location ?
> > > Or will it come online again automatically ?
> > >
> > > Thx,
> > > Best regards,
> > > JAcques Lapeire
> > >
> > >
> > >
> > >
> >
>
>
>
*******************************************************************************
> > > Forum Note: Use "Reply" to post a response in the discussion forum.
> > >
> > >
> >
> > --
> > Art S. Kagel
> > Oninit (www.oninit.com)
> > IIUG Board of Directors (art@iiug.org)
> >
> > Disclaimer: Please keep in mind that my own opinions are my own
> > opinions and do not reflect on my employer, Oninit, the IIUG, nor any
> > other organization with which I am associated either explicitly or
> > implicitly. Neither do those opinions reflect those of other
> > individuals affiliated with any entity with which I am affiliated nor
> those
> of the entities themselves.
> >
> > --00163631059d0ac3400463abce2a
> >
> >
> >
>
>
>
*******************************************************************************
> > Forum Note: Use "Reply" to post a response in the discussion forum.
> >
>
> _________________________________________________________________
> Show them the way! Add maps and directions to your party invites.
> http://www.microsoft.com/windows/windowslive/products/events.aspx
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--
Art S. Kagel
Oninit (www.oninit.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
--0016364edc12104ace0463b0a1ee