RE: Apache Child Seg Fault using Web Datablade
Posted in 2000
Topics: Stored Procedures & SPL, Platform-Specific Issues
What if anything are your seeing in the webdriver log file? Are 100% sure you have altered the Apache source (Two files) and the configuration files ( the tmpl file not the one the manual says). If you fail to alter these Apache will start and run perfectly, until you try to access the db then it will core. Paul Watson # WF Software Ltd # All answers are Tel: +44 1436 674729 # pure fantasy Fax: +44 1436 678693 # www.wfsoftware.com # > -----Original Message----- > From: Brian Fink [mailto:brian_fink@my-deja.com] > Sent: Monday, November 27, 2000 9:31 PM > To: informix-list@iiug.org > Subject: Apache Child Seg Fault using Web Datablade > > > Hi. > > We have been trying (with the help of Informix support)to get the web > datablade working with Apache 1.3.12 on Linux 6.1. Apache is running > correctly and I can access the default site however when I try to > access the admin or apb2 pages from the database the browser > comes back > with 'The page cannot be displayed' error and the Apache log contains > the following: > > [Mon Nov 27 16:23:55 2000] [notice] child pid 14306 exit signal > Segmentation fault (11) > > After some research in the newsgroups I found that the error usually > occurs when using SSL but we have only compiled in the basic > functionality. Before I wipe everything and start from scratch I was > wondering if anyone else has run into this problem or > anything similar. > > Any thoughts/comments are appreciated. > > Brian > > Informix Foundation.2000 > Linux RH 6.1 > Apache 1.3.12 > Web datablade 4.00 > > > Sent via Deja.com http://www.deja.com/ > Before you buy. > ********************************************************************** The contents of this e-mail are confidential to the ordinary user(S) of the mail address(es) to which it was sent and may be legally privileged. If you are not the intended recipient, any disclosure, copying, distribution or use of it, or any part of it, in any form whatsoever, and any actions taken or omitted to be taken in reliance on it, is prohibited and may be unlawful. **********************************************************************
Paul, thanks for the response. I commented out the Informix directories in Configuration.tmpl while trying to debug a loadModule error and never put them back :-0. After editing the file again along with the mod_include.c, http_request.c, and the httpd.conf I get the following error when executing the configure command: Creating Configuration.apaci in src cd ..; gcc -DLINUX=2 -DUSE_HSREGEX -DUSE_EXPAT -I./lib/expat-lite `./apaci` -L/opt/informix2000/lib -L/opt/informix2000/lib/esql - L/opt/informix2000/extend/ web.4.00.UC1/apache -o helpers/dummy helpers/dummy.c -lifxw -lifsql - lifasf -li fgen -lifos -lifgls /opt/informix2000/lib/esql/checkapi.o -lifglx - lifsql -lifas f -lifgen -lifos -lifgls -lm -lm /opt/informix2000/lib/libifasf.so: undefined reference to `dlclose' /opt/informix2000/lib/libifasf.so: undefined reference to `dlopen' /opt/informix2000/lib/esql/libifos.so: undefined reference to `crypt' /opt/informix2000/lib/libifasf.so: undefined reference to `dlsym' collect2: ld returned 1 exit status make: *** [dummy] Error 1 Creating Makefile in src + configured for Linux platform + setting C compiler to gcc + setting C pre-processor to gcc -E + checking for system header files + adding selected modules + checking sizeof various data types + doing sanity check on compiler and options ** A test compilation with your Makefile configuration ** failed. The below error output from the compilation ... Support suggested reinstalling Apache but this seems like an error in the informix libraries. The driver.log file states that the initialization completed ok and the INFORMIXDIR is set correctly. TIA Brian In article <900uip$can$1@news.xmission.com>, Watson Paul <Paul.Watson@fefc.ac.uk> wrote: > > What if anything are your seeing in the webdriver log file? > > Are 100% sure you have altered the Apache source (Two files) and > the configuration files ( the tmpl file not the one the manual > says). If you fail to alter these Apache will start and run > perfectly, until you try to access the db then it will core. > > Paul Watson # > WF Software Ltd # All answers are > Tel: +44 1436 674729 # pure fantasy > Fax: +44 1436 678693 # > www.wfsoftware.com # > > > -----Original Message----- > > From: Brian Fink [mailto:brian_fink@my-deja.com] > > Sent: Monday, November 27, 2000 9:31 PM > > To: informix-list@iiug.org > > Subject: Apache Child Seg Fault using Web Datablade > > > > > > Hi. > > > > We have been trying (with the help of Informix support)to get the web > > datablade working with Apache 1.3.12 on Linux 6.1. Apache is running > > correctly and I can access the default site however when I try to > > access the admin or apb2 pages from the database the browser > > comes back > > with 'The page cannot be displayed' error and the Apache log contains > > the following: > > > > [Mon Nov 27 16:23:55 2000] [notice] child pid 14306 exit signal > > Segmentation fault (11) > > > > After some research in the newsgroups I found that the error usually > > occurs when using SSL but we have only compiled in the basic > > functionality. Before I wipe everything and start from scratch I was > > wondering if anyone else has run into this problem or > > anything similar. > > > > Any thoughts/comments are appreciated. > > > > Brian > > > > Informix Foundation.2000 > > Linux RH 6.1 > > Apache 1.3.12 > > Web datablade 4.00 > > > > > > Sent via Deja.com http://www.deja.com/ > > Before you buy. > > > > ********************************************************************** > The contents of this e-mail are confidential to the ordinary user(S) of the > mail address(es) to which it was sent and may be legally privileged. > If you are not the intended recipient, any disclosure, copying, distribution > or use of it, or any part of it, in any form whatsoever, and any actions > taken or omitted to be taken in reliance on it, is prohibited and may be unlawful. > ********************************************************************** > Sent via Deja.com http://www.deja.com/ Before you buy.