onprobe will not start
Posted in 2000
Hi,
When I try to start onprobe I get the following error;-
17:08:34 SYSTEM STARTUP-FATAL LS_server_init: errno=226: Address already in
use, -55252: bind( ) using service 'cockpit' failed.
17:08:34 COCKPIT STARTUP-FATAL main_loop: -55412: Could not initialize
client-
server layer of OnProbe using service 'cockpit'.
The first time I ran this it worked fine, I could run oncockpit Ok. The
next time I tried to run oncockpit it failed with failure to connect to
onprobe messages so I killed onprobe and now I can't restart it.
Hp-Ux 10.20
Informix Versions;-
INFORMIX-4GL Interactive Debugger Version 7.20.UD8
INFORMIX-4GL Version 7.20.UD8
INFORMIX-4GL Rapid Development System Version 7.20.UD8
Informix Dynamic Server Version 7.30.UC7
INFORMIX-SQL Version 7.20.UD8
/etc/services
ol_live_tcp 10000/tcp # OnLine Live Server
ol_dev_tcp 10002/tcp # OnLine Dev Server
cockpit 10001/tcp # OnLine Dev DBCockpit
ol_iecc 10004/tcp # OnLine Dev Informix ECC
sqlhosts file
dev1 onipcshm hpe25 online1
dev2 onsoctcp hpe25 ol_dev_tcp
dev3 onsoctcp hpe25 cockpit
dev4 onsoctcp hpe25 ol_iecc
live2 onsoctcp hpk200 ol_live_tcp
netstat output
Active Internet connections
Proto Recv-Q Send-Q Local Address Foreign Address (state)
tcp 0 0 hpe25.telnet tonyf.1360
ESTABLISHED
tcp 0 0 hpe25.ol_iecc *.* LISTEN
tcp 0 0 hpe25.cockpit *.* LISTEN
tcp 0 0 hpe25.ol_dev_t *.* LISTEN
tcp 0 0 hpe25.1076 tonyf.6000
ESTABLISHED
tcp 0 0 hpe25.1069 tonyf.6000
ESTABLISHED
tcp 0 0 hpe25.1068 tonyf.6000
ESTABLISHED
tcp 0 0 hpe25.telnet tonyf.1161
ESTABLISHED
Active UNIX domain sockets
Address Type Recv-Q Send-Q Inode Conn Refs Nextref Addr
c1de00 stream 0 0 6520ec 0 0 0
/tmp/.AgentSockets/A
c17d00 dgram 0 0 65094c 0 0 0
/opt/dcelocal/var/rpc/local/00341/reaper
c83b00 dgram 0 0 652a1c 0 0 0
/opt/dcelocal/var/rpc/local/00868/reaper
a6c400 stream 0 0 64d37c 0 0 0
/opt/dcelocal/var/rpc/local/s-0/2121
c1c600 dgram 0 0 64d4cc 0 0 0
/opt/dcelocal/var/rpc/local/s-3/2121
c50100 stream 0 0 652e0c 0 0 0
/opt/dcelocal/var/rpc/local/s-0/135
c4b300 dgram 0 0 6530ac 0 adba00 0
/opt/dcelocal/var/rpc/local/s-3/135
bad700 dgram 0 0 652b6c adb9c0 0 0
/opt/dcelocal/var/rpc/local/00868/c-3/7000
c3be00 dgram 0 0 65349c 0 adba80 0
/opt/dcelocal/var/rpc/local/00868/c-3/shared
c50b00 dgram 0 0 6535ec adba40 0 0
/opt/dcelocal/var/rpc/local/00868/c-3/7002
cf3c00 dgram 0 0 65016c 0 0 0
/var/tmp/psb_front_socket
cf3d00 dgram 0 0 65430c 0 0 0
/var/tmp/psb_back_socket
e5f500 stream 0 0 0 adbb00 0 0
e3bf00 stream 0 0 0 adbbc0 0 0
/INFORMIXTMP/VP.dev2.0101s
Should the hpe25.cockpit connection be listening or should it not be there
at all?
Also, what is the /INFORMIXTMP/VP.dev2.0101s entry telling me?
TIA.
--
---------------------------------------
Tony Flaherty aef@mfs.misys.co.uk
Analyst Programmer
Misys Financial Systems
All statements and opinions are my own,
Misys don't pay me enough to have opinions
on their behalf
.