Re: Problem connecting under Windows 95
Posted in 2003
I tested this on my system (Win2000) and it worked with service number instead of the name. I tried it on the problem Win95 system at the customer site and it kind of worked. In the ODBC config window for the Informix data source, when I click the "Apply & Test Connection" button, it connects successfully. But none of our software that connects to the database through ODBC will connect. It gets a "Cannot connect to the database server <servername>" error (where <servername> is correct). Additionally, DBPing's ODBC tab cannot connect either - it bombs out with an exception - not even a real error message. The only other thing I can think of to try (sort of telling them to scrap Win95) is to download the latest MDAC - even though we don't use MDAC, but it may replace the ODBC subsystem. "Fernando Ortiz" <fortiz@lacorona.com.mx> wrote in message news:bdfep1$v5s$1@terabinaries.xmission.com... > > Hi: > > Have you tried using service NUMBER in place of the service name? > > As each new Windows version (and possible Winsock version) change the path > of the services file I always use the port number in the setnet32. > > HTH > > ----- Original Message ----- > From: <joe@colsys.com> > To: <informix-list@iiug.org> > Sent: Thursday, June 26, 2003 10:12 AM > Subject: Problem connecting under Windows 95 > > > > Has anyone encountered the following? I've had it happen at two > > customer sites so far. > > > > The PC is running the original version of Windows 95 and has the > > Informix CLI for Windows installed (it doesn't matter which version - > > I've tried them all). It's working fine. > > > > Then the customer downloads and installs the Microsoft Winsock 2 > > Update for Windows 95 because another software package needs it. > > > > That installs and seems to work (can ping, can telnet, Samba works, > > etc.) > > > > But now any attempt to connect to the Informix database through CLI > > results in an error -931, saying it cannot locate the sqlexec/tcp > > service. > > > > The answer is not the obvious - the "sqlexec" service *IS* specified > > (correctly) in c:\\windows\\services. On the off chance it would work, > > I copied services to c:\\windows\\system32\\drivers\\etc\\hosts (the > > location of the file for NT/2000/XP). It didn't help. > > > > I can't figure out why CLI now cannot find the service entry in the > > services file. It's definitely not just a fluke because it has now > > happened at two separate sites. The first time we encountered it, we > > just gave up and told them to upgrade their Windows 95 to XP and that > > worked. That was OK because it was just one PC. The second site > > where we just encountered it has more PC's and now they are all > > broken. > > sending to informix-list