Re: Moving SE Database and logfile
Posted in 1998
Axel Sander wrote:
>
> Hi,
> I successfully moved my SE 5.x to a new partition by just copying all
> database files. I discovered one problem:
> After moving the files the old logfile *must* still exist in the old
> directory (could be length of 0) given by the systables. When I try
> "dbaccess - -" and "start database xxx with log in "newpartition...";"
> there is a database error if the old file is not accessible.
> Is there any way to avoid this? Is there a command to stop the logging
> (like "start database xxx with nolog") ?
>
> Axel
>
Yes. START DATABASE xxx WITH NO LOG.
You need to stop the logging before moving the database and restart it
after the move. The reason is that the database contains a reference to
the location of the logfile. It is in the systables table, I think.
--
Peter Lancashire
Information Systems Specialist, Bayer plc
Eastern Way, Bury St Edmunds, Suffolk, IP32 7AH, UK
Tel: +44-1635-562258, Fax: +44-1635-562281
---
If all else fails, read the instructions AND the release notes.
All opinions are my own and not those of Bayer plc.
My Internet plumbing does not allow me to mail and post news together.
Sorry.
---
Join Infuse, the UK Informix User Group at http://www.infuse.org.uk/