Start and Stop rc* scripts - GLS error
Posted in 2000
Topics: Installation, Setup & Upgrades, Server Administration, Networking & sqlhosts Configuration, Internationalization & Character Sets
HI,
I finally edit my script to start and stop the IDS engine, with your help,
but now I'm having problems with the GLS Initialization.
Here's my stop script:
#!/sbin/sh
PATH=/usr/bin:/usr/ucb:/etc:.export PATH
TERM=vt100
export TERM
EDITOR=/bin/vi
export EDITOR
INFORMIXDIR=/opt/informixexport INFORMIXDIR
PATH=$INFORMIXDIR/bin:$PATHexport PATH
DBDATE=dmy4/export DBDATE
INFORMIXSERVER=ol_prueba_shmexport INFORMIXSERVER
INFORMIXSQLHOSTS=/opt/informix/etc/sqlhostsexport INFORMIXSQLHOSTS
ONCONFIG=onconfig.203export ONCONFIG
CLIENT_LOCALE=en_us.819 #I get this value from the collate column ofsysmaster:systabnames table
DB_LOCALE=en_us.819 #I get this value from the collate column ofsysmaster:systabnames table
export CLIENT_LOCALE DB_LOCALEsu - informix -c "$INFORMIXDIR/bin/onmode -ky"
exit
But after executing it, I get the sign: "GLS initialization failed,
error -23101. Aftre that I execute "finderr -23101" and I get the following
result:
-------------------------------
-23101 Unable to load locale categories.
An invalid locale name was supplied for the locale initialization.
The environment variable to specify the locale category has a wrong
value. Check the value of the corresponding environment variable,
CLIENT_LOCALE or DB_LOCALE. Also check if INFORMIXDIR points to a valid
directory where Informix products are installed.
If a client application receives this error when it requests a database
server connection, check that the client and database locales are
compatible. They are compatible if a valid locale exists on the server
computer with the name lg_tr.codeset@mod, where lg_tr (language and
territory) and mod (locale modifier) are from the CLIENT_LOCALE and
codeset is from the database locale (from the DB_LOCALE, if it is set,
or as stored in the database).
----------------------------------
I ask you: ....what can I do now ??? I don't know what to do.
Thanks for all your valuable help.
Regards,
Alejandro Cabrera Obed
Responsable Area Informatica
Sistema Unico de Prestaciones para Personas con Discapacidad
Tel. 54 11 4331-7344 int 5527
http://www.sisdis.gov.ar
E-mail: sisdis@tournet.com.ar
Bs. As. - Argentina
Just eliminate the _LOCALE vars. If you locale is en_us that is the default
anyway.
Art S. Kagel
"Sistema Unico (CNA)" wrote:
>
> HI,
>
> I finally edit my script to start and stop the IDS engine, with your help,
> but now I'm having problems with the GLS Initialization.
> Here's my stop script:
>
> #!/sbin/sh
> PATH=/usr/bin:/usr/ucb:/etc:.> export PATH
> TERM=vt100
> export TERM
> EDITOR=/bin/vi
> export EDITOR
> INFORMIXDIR=/opt/informix> export INFORMIXDIR
> PATH=$INFORMIXDIR/bin:$PATH> export PATH
> DBDATE=dmy4/> export DBDATE
> INFORMIXSERVER=ol_prueba_shm> export INFORMIXSERVER
> INFORMIXSQLHOSTS=/opt/informix/etc/sqlhosts> export INFORMIXSQLHOSTS
> ONCONFIG=onconfig.203> export ONCONFIG
> CLIENT_LOCALE=en_us.819 #I get this value from the collate column of> sysmaster:systabnames table
> DB_LOCALE=en_us.819 #I get this value from the collate column of> sysmaster:systabnames table
> export CLIENT_LOCALE DB_LOCALE> su - informix -c "$INFORMIXDIR/bin/onmode -ky"
> exit
>
> But after executing it, I get the sign: "GLS initialization failed,
> error -23101. Aftre that I execute "finderr -23101" and I get the following
> result:
>
> -------------------------------
> -23101 Unable to load locale categories.
>
> An invalid locale name was supplied for the locale initialization.
> The environment variable to specify the locale category has a wrong
> value. Check the value of the corresponding environment variable,
> CLIENT_LOCALE or DB_LOCALE. Also check if INFORMIXDIR points to a valid
> directory where Informix products are installed.
>
> If a client application receives this error when it requests a database
> server connection, check that the client and database locales are
> compatible. They are compatible if a valid locale exists on the server
> computer with the name lg_tr.codeset@mod, where lg_tr (language and
> territory) and mod (locale modifier) are from the CLIENT_LOCALE and
> codeset is from the database locale (from the DB_LOCALE, if it is set,
> or as stored in the database).
> ----------------------------------
>
> I ask you: ....what can I do now ??? I don't know what to do.
> Thanks for all your valuable help.
>
> Regards,
>
> Alejandro Cabrera Obed
> Responsable Area Informatica
> Sistema Unico de Prestaciones para Personas con Discapacidad
> Tel. 54 11 4331-7344 int 5527
> http://www.sisdis.gov.ar
> E-mail: sisdis@tournet.com.ar
> Bs. As. - Argentina