Logical Log
Posted in 1999
Topics: Backup & Restore, Transactions, Locking & Isolation, Logging & Checkpoints
This is a multi-part message in MIME format.
------=_NextPart_000_0084_01BE5CC0.3EFB85E0
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
Dear User,
I have been trying to get a large file loaded on a database with =
transaction logging and the loading keep bombing out. I am getting an =
error in the log 'Lock Table Overflow.', Eventhough, i have 5 logs it =
bombs at the exact time that the current log gets to 100% used. Why =
does it not use the other logs that are empty and why when I do an =
ontape -a it only free up the current log. If i repeat the command then =it backs up the other logs one at a time.
marie=20
------=_NextPart_000_0084_01BE5CC0.3EFB85E0
Content-Type: text/html;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
<!DOCTYPE HTML PUBLIC "-//W3C//DTD W3 HTML//EN">
<HTML>
<HEAD>
<META content=3Dtext/html;charset=3Diso-8859-1 =
http-equiv=3DContent-Type>
<META content=3D'"MSHTML 4.72.3110.7"' name=3DGENERATOR>
</HEAD>
<BODY bgColor=3D#ffffff>
<DIV><FONT color=3D#000000 size=3D2>Dear User,</FONT></DIV>
<DIV><FONT color=3D#000000 size=3D2></FONT> </DIV>
<DIV><FONT color=3D#000000 size=3D2>I have been trying to get a large =
file loaded on=20
a database with transaction logging and the loading keep bombing=20
out. I am getting an error in the log 'Lock Table =
Overflow.', =20
Eventhough, i have 5 logs it bombs at the exact time that the current =
log gets=20
to 100% used. Why does it not use the other logs that are empty =
and why=20
when I do an ontape -a it only free up the current log. If i =
repeat the=20
command then it backs up the other logs one at a time.</FONT></DIV>
<DIV><FONT color=3D#000000 size=3D2></FONT> </DIV>
<DIV><FONT color=3D#000000 =
size=3D2>marie </FONT></DIV></BODY></HTML>
------=_NextPart_000_0084_01BE5CC0.3EFB85E0--
You need to increase the number of LOCKS, not LOGS. Madison Pruet
In article <7amqjf$agf$1@news.xmission.com>,
<musher@btl.net> wrote:
>
> This is a multi-part message in MIME format.
>
> ------=_NextPart_000_0084_01BE5CC0.3EFB85E0
> Content-Type: text/plain;
> charset="iso-8859-1"
> Content-Transfer-Encoding: quoted-printable
>
> Dear User,
>
> I have been trying to get a large file loaded on a database with =
> transaction logging and the loading keep bombing out. I am getting an =
> error in the log 'Lock Table Overflow.', Eventhough, i have 5 logs it =
> bombs at the exact time that the current log gets to 100% used. Why =
> does it not use the other logs that are empty and why when I do an =
> ontape -a it only free up the current log. If i repeat the command then => it backs up the other logs one at a time.
>
> marie=20
>
> ------=_NextPart_000_0084_01BE5CC0.3EFB85E0
> Content-Type: text/html;
> charset="iso-8859-1"
> Content-Transfer-Encoding: quoted-printable
>
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD W3 HTML//EN">
> <HTML>
> <HEAD>
>
> <META content=3Dtext/html;charset=3Diso-8859-1 =
> http-equiv=3DContent-Type>
> <META content=3D'"MSHTML 4.72.3110.7"' name=3DGENERATOR>
> </HEAD>
> <BODY bgColor=3D#ffffff>
> <DIV><FONT color=3D#000000 size=3D2>Dear User,</FONT></DIV>
> <DIV><FONT color=3D#000000 size=3D2></FONT> </DIV>
> <DIV><FONT color=3D#000000 size=3D2>I have been trying to get a large =
> file loaded on=20
> a database with transaction logging and the loading keep bombing=20
> out. I am getting an error in the log 'Lock Table =
> Overflow.', =20
> Eventhough, i have 5 logs it bombs at the exact time that the current =
> log gets=20
> to 100% used. Why does it not use the other logs that are empty =
> and why=20
> when I do an ontape -a it only free up the current log. If i =
> repeat the=20
> command then it backs up the other logs one at a time.</FONT></DIV>
> <DIV><FONT color=3D#000000 size=3D2></FONT> </DIV>
> <DIV><FONT color=3D#000000 =
> size=3D2>marie </FONT></DIV></BODY></HTML>
>
> ------=_NextPart_000_0084_01BE5CC0.3EFB85E0--
>
>
Hello, I think I can help you...
You need to increase the parameter LOCKS, in your configuration file
(onconfig, located on $INFORMIXDIR/etc) for the instance you are using. You
can monitor the use of locks during the load by using the comand 'onstat -k',
wich will show you how many locks are being used by Informix at the moment.
If you are loading data to a table wich you can lock in exclusive mode, put
the command 'lock table <table> in exclusive mode' before the load command.
This will make your load command to use just 1 lock, and you'll not have to
increase LOCKS. But manage the output of the command 'onstat -k' to determine
the correct number of locks that your database need, so that you won't waste
your memory with this resource.
Hope it helps !!!
Regards
Paulo Amorim
TS&O Consulting - Brazil
-----------== Posted via Deja News, The Discussion Network ==----------
http://www.dejanews.com/ Search, Read, Discuss, or Start Your Own
Related threads
- Conversion to differeent characters sets
- Problem in changing locale via dbexport/dbimport
- RE: openlink error "Unable to load locale categories"