Start with wrong version destroys instance
Posted in 2009
Topics: Storage & Space Management, Versions, Editions & End-of-Life
Sorry, sent this before with wrong topic. Hi we accidently tired to start an IDS 11.50.FC3 instance with IDS 9.40FC9W2 software and configuration. The instance won't start what's ok. Sadly after that the start with correct IDS 11.50.FC3 software and configuration failes, too. Obviously the attempt to start with the wrong version had destroid the rootdbs. Shouldn't there be a warning when trying to start an instance with the wrong version? Reinhard.
Call tech support. Starting an instance with an earlier version should not have caused any damage. The engine should have read the version information page (page 0) and quit immediately when it saw the version on that page was a later release. I would think that the 9.40 was started with -i but then the startup would not have failed. Art Art S. Kagel Oninit (www.oninit.com) IIUG Board of Directors (art@iiug.org) Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on my employer, Oninit, the IIUG, nor any other organization with which I am associated either explicitly or implicitly. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Thu, Jun 18, 2009 at 5:04 AM, Habichtsberg, Reinhard < RHabichtsberg@arz-emmendingen.de> wrote: > Sorry, sent this before with wrong topic. > > Hi > > we accidently tired to start an IDS 11.50.FC3 instance with IDS 9.40FC9W2 > software and configuration. > > The instance won't start what's ok. Sadly after that the start with correct > IDS 11.50.FC3 software and configuration failes, too. Obviously the attempt > to start with the wrong version had destroid the rootdbs. > > Shouldn't there be a warning when trying to start an instance with the > wrong > version? > > Reinhard. > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --00504502ba45c08f8a046c9cdce0
Hi Art,
to verify the buggy behaviour I tested again. I have a clean instance named
dbtest4_tli which was migrated in place from 9.40.FC9W2 to 11.50.FC3.
The instance is runnig without problems, the migration had run without
errors
I stop this instance with onmode -yuk.
Then I log into the system using the old 9.40 environment (PATH, INFORMIXDIR
etc.) and start the instance with this wrong version of IDS.
Start with IDS 9.40.FC9W2
dbtest-db4:/home/informix%oninit -v
Checking group membership to determine server run modesucceeded
Reading configuration file '/app/lib/db1/etc/onconfig.db4'...succeeded
Creating /INFORMIXTMP/.infxdirs ... succeeded
Creating infos file "/app/lib/db1/etc/.infos.dbtest4_tli" ...
"/app/lib/db1/etc/.conf.dbtest4_tli" ... succeeded
Writing to infos file ... succeeded
Checking config parameters...DS_TOTAL_MEMORY recalculated and changed from
100000Kb to 256000Kb
succeeded
Allocating and attaching to shared memory...succeeded
Creating resident pool 500536 kbytes...succeeded
Creating buffer pool 199998 kbytes...succeeded
Creating buffer pool 6 kbytes...succeeded
Initializing rhead structure...succeeded
Initializing ASF ...succeeded
Initializing Dictionary Cache and SPL Routine Cache...succeeded
Bringing up ADM VP...succeeded
Creating VP classes...succeeded
Onlining 1 additional cpu vps...succeeded
Onlining 1 IO vps...succeeded
Initialization of Encryption...succeeded
Forking main_loop thread...succeeded
Initializing DR structures...succeeded
Forking 1 'tlitcp' listener threads...succeeded
Forking 1 'tlitcp' listener threads...succeeded
Starting tracing...succeeded
Initializing 32 flushers...succeeded
Initializing log/checkpoint information...succeeded
Opening primary chunks...oninit: Cannot open chunk 'Ç7]'. errno = 2
Chunk Ç7] already exists.
Primary reserved page is corrupt.
FAILED
oninit: Fatal error in shared memory initialization
vi online4.log
10:12:59 IBM Informix Dynamic Server Started.
10:13:01 Requested shared memory segment size rounded from 100000KB to
100352KB
Fri Jun 19 10:13:03 2009
10:13:03 Buffer manager: env variable TRACEFUZZYCKPT or TRACECKPT is
defined. Checkpoints will be traced.
10:13:03 Event alarms enabled. ALARMPROG =
'/opt/informix/etc/alarmprogram.sh'
10:13:03 Booting Language <c> from module <>
10:13:03 Loading Module <CNULL>
10:13:03 Booting Language <builtin> from module <>
10:13:03 Loading Module <BUILTINNULL>
10:13:08 IBM Informix Dynamic Server Version 9.40.FC9W2 Software Serial
Number AAA#B000000
10:13:09 Cannot Open Primary Chunk '^X\\\\3077]', errno = 2
10:13:09 IBM Informix Dynamic Server Stopped.
10:13:09 mt_shm_remove: WARNING: may not have removed all/correct segments
---------------------------------
Next I try to start the instance with the appropriate IDS Version (PATH,
INFORMIXDIR etc. checked):
Start with IDS 11.50.FC3
dbtest-db4_11:/home/informix%oninit -v
Checking group membership to determine server run mode...succeeded
Reading configuration file
'/app/lib/ids11.50.FC3/etc/onconfig.dbtest4_11'...succeeded
Creating /INFORMIXTMP/.infxdirs...succeeded
Creating infos file
"/app/lib/ids11.50.FC3/etc/.infos.dbtest4_tli"...succeeded
Linking conf file "/app/lib/ids11.50.FC3/etc/.conf.dbtest4_tli"...succeeded
Checking config parameters...succeeded
Writing to infos file...succeeded
Allocating and attaching to shared memory...succeeded
Creating resident pool 539216 kbytes...succeeded
Allocating 200016 kbytes for buffer pool of 2K page size...succeeded
Initializing rhead structure...succeeded
Initialization of Encryption...succeeded
Initializing ASF...succeeded
Initializing Dictionary Cache and SPL Routine Cache...succeeded
Bringing up ADM VP...succeeded
Creating VP classes...succeeded
Onlining 1 additional cpu vps...succeeded
Onlining 2 IO vps...succeeded
Forking main_loop thread...succeeded
WARNING: server initialization failed, or possibly timed out (if -w was
used).
Check the message log, online.log, for errors.
vi online4_11.log:
10:17:34 IBM Informix Dynamic Server Started.
10:17:34 Requested shared memory segment size rounded from 748544KB to
753664KB
10:17:35 Segment locked: addr=10a000000, size=771751936
10:17:35 Requested shared memory segment size rounded from 100000KB to
131072KB
10:17:35 Segment locked: addr=138000000, size=134217728
Fri Jun 19 10:17:36 2009
10:17:36 Event alarms enabled. ALARMPROG =
'/app/lib/ids11.50.FC3/etc/log_full.sh'
10:17:36 Booting Language <c> from module <>
10:17:36 Loading Module <CNULL>
10:17:36 Booting Language <builtin> from module <>
10:17:36 Loading Module <BUILTINNULL>
10:17:36 SQLTRACE: SQL History Tracing set to 1000 SQL statements.
10:17:36 Warning: CONSOLE = /home/informix/console4_11 open failed.
Redirecting output to '/dev/null'.
10:17:41 DR: DRAUTO is 0 (Off)
10:17:41 DR: ENCRYPT_HDR is 0 (HDR encryption Disabled)
10:17:41 Fast poll /dev/poll enabled.
10:17:41 Requested shared memory segment size rounded from 1096KB to 2048KB
10:17:42 IBM Informix Dynamic Server Version 11.50.FC3 Software Serial
Number AAA#B000000
10:17:43 Performance Advisory: The physical log size is smaller than the
recommended size for a
server configured with RTO_SERVER_RESTART.
10:17:43 Results: Fast recovery performance might not be optimal.
10:17:43 Action: For best fast recovery performance when
RTO_SERVER_RESTART is enabled,increase the physical log size to at least 220000 KB. For servers
configured with a large buffer pool, this might not be necessary.
10:17:43 Assert Failed: Page Check Error in init_dbspace_pre_chunk
10:17:43 IBM Informix Dynamic Server Version 11.50.FC3
10:17:43 Who: Session(1, informix@dbtest, 0, 1384f3028)
Thread(7, main_loop(), 1384b0028, 3)
File: rsdebug.c Line: 1085
10:17:43 Results: Possible inconsistencies in '(null)'
10:17:43 stack trace for pid 4741 written to /nas99/informixdump/af.3ef49a6
10:17:43 See Also: /nas99/informixdump/af.3ef49a6, shmem.3ef49a6.0
10:17:57 Page Check Error in init_dbspace_pre_chunk
10:17:57 oninit: Fatal error in shared memory initialization
10:17:57 IBM Informix Dynamic Server Stopped.
After starting the instance once with the wrong version, the appropriate
version reports a "Page Check Error in init_dbspace_pre_chunk".
Regards,
Reinhard.
> -----Original Message-----
> From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org]On
> Behalf Of Art
> Kagel
> Sent: Thursday, June 18, 2009 12:28 PM
> To: ids@iiug.org
> Subject: Re: Start with wrong version destroys instance [16086]
>
>
> Call tech support. Starting an instance with an earlier
> version should not
> have caused any damage. The engine should have read the
> version information
> page (page 0) and quit immediately when it saw the version on
> that page was
> a later release. I would think that the 9.40 was started with
> -i but then
> the startup would not have failed.
>
> Art
>
> Art S. Kagel
> Oninit (www.oninit.com)
> IIUG Board of Directors (art@iiug.org)
>
> D
Reinhard,
you can not do in-place downgrade. You must use onmode command
to revert to older version.
HTH
Hrvoje
Habichtsberg, Reinhard wrote:
Hi Art,
to verify the buggy behaviour I tested again. I have a clean instance named
dbtest4_tli which was migrated in place from 9.40.FC9W2 to 11.50.FC3.
The instance is runnig without problems, the migration had run without
errors
I stop this instance with onmode -yuk.
Then I log into the system using the old 9.40 environment (PATH, INFORMIXDIR
etc.) and start the instance with this wrong version of IDS.
Start with IDS 9.40.FC9W2
dbtest-db4:/home/informix%oninit -v
Checking group membership to determine server run modesucceeded
Reading configuration file '/app/lib/db1/etc/onconfig.db4'...succeeded
Creating /INFORMIXTMP/.infxdirs ... succeeded
Creating infos file "/app/lib/db1/etc/.infos.dbtest4_tli" ...
"/app/lib/db1/etc/.conf.dbtest4_tli" ... succeeded
Writing to infos file ... succeeded
Checking config parameters...DS_TOTAL_MEMORY recalculated and changed from
100000Kb to 256000Kb
succeeded
Allocating and attaching to shared memory...succeeded
Creating resident pool 500536 kbytes...succeeded
Creating buffer pool 199998 kbytes...succeeded
Creating buffer pool 6 kbytes...succeeded
Initializing rhead structure...succeeded
Initializing ASF ...succeeded
Initializing Dictionary Cache and SPL Routine Cache...succeeded
Bringing up ADM VP...succeeded
Creating VP classes...succeeded
Onlining 1 additional cpu vps...succeeded
Onlining 1 IO vps...succeeded
Initialization of Encryption...succeeded
Forking main_loop thread...succeeded
Initializing DR structures...succeeded
Forking 1 'tlitcp' listener threads...succeeded
Forking 1 'tlitcp' listener threads...succeeded
Starting tracing...succeeded
Initializing 32 flushers...succeeded
Initializing log/checkpoint information...succeeded
Opening primary chunks...oninit: Cannot open chunk '�. errno = 2
Chunk �already exists.
Primary reserved page is corrupt.
FAILED
oninit: Fatal error in shared memory initialization
vi online4.log
10:12:59 IBM Informix Dynamic Server Started.
10:13:01 Requested shared memory segment size rounded from 100000KB to
100352KB
Fri Jun 19 10:13:03 2009
10:13:03 Buffer manager: env variable TRACEFUZZYCKPT or TRACECKPT is
defined. Checkpoints will be traced.
10:13:03 Event alarms enabled. ALARMPROG =
'/opt/informix/etc/alarmprogram.sh'
10:13:03 Booting Language <c> from module <>
10:13:03 Loading Module <CNULL>
10:13:03 Booting Language <builtin> from module <>
10:13:03 Loading Module <BUILTINNULL>
10:13:08 IBM Informix Dynamic Server Version 9.40.FC9W2 Software Serial
Number AAA#B000000
10:13:09 Cannot Open Primary Chunk '^X\\\\3077]', errno = 2
10:13:09 IBM Informix Dynamic Server Stopped.
10:13:09 mt_shm_remove: WARNING: may not have removed all/correct segments
---------------------------------
Next I try to start the instance with the appropriate IDS Version (PATH,
INFORMIXDIR etc. checked):
Start with IDS 11.50.FC3
dbtest-db4_11:/home/informix%oninit -v
Checking group membership to determine server run mode...succeeded
Reading configuration file
'/app/lib/ids11.50.FC3/etc/onconfig.dbtest4_11'...succeeded
Creating /INFORMIXTMP/.infxdirs...succeeded
Creating infos file
"/app/lib/ids11.50.FC3/etc/.infos.dbtest4_tli"...succeeded
Linking conf file "/app/lib/ids11.50.FC3/etc/.conf.dbtest4_tli"...succeeded
Checking config parameters...succeeded
Writing to infos file...succeeded
Allocating and attaching to shared memory...succeeded
Creating resident pool 539216 kbytes...succeeded
Allocating 200016 kbytes for buffer pool of 2K page size...succeeded
Initializing rhead structure...succeeded
Initialization of Encryption...succeeded
Initializing ASF...succeeded
Initializing Dictionary Cache and SPL Routine Cache...succeeded
Bringing up ADM VP...succeeded
Creating VP classes...succeeded
Onlining 1 additional cpu vps...succeeded
Onlining 2 IO vps...succeeded
Forking main_loop thread...succeeded
WARNING: server initialization failed, or possibly timed out (if -w was
used).
Check the message log, online.log, for errors.
vi online4_11.log:
10:17:34 IBM Informix Dynamic Server Started.
10:17:34 Requested shared memory segment size rounded from 748544KB to
753664KB
10:17:35 Segment locked: addr=10a000000, size=771751936
10:17:35 Requested shared memory segment size rounded from 100000KB to
131072KB
10:17:35 Segment locked: addr=138000000, size=134217728
Fri Jun 19 10:17:36 2009
10:17:36 Event alarms enabled. ALARMPROG =
'/app/lib/ids11.50.FC3/etc/log_full.sh'
10:17:36 Booting Language <c> from module <>
10:17:36 Loading Module <CNULL>
10:17:36 Booting Language <builtin> from module <>
10:17:36 Loading Module <BUILTINNULL>
10:17:36 SQLTRACE: SQL History Tracing set to 1000 SQL statements.
10:17:36 Warning: CONSOLE = /home/informix/console4_11 open failed.
Redirecting output to '/dev/null'.
10:17:41 DR: DRAUTO is 0 (Off)
10:17:41 DR: ENCRYPT_HDR is 0 (HDR encryption Disabled)
10:17:41 Fast poll /dev/poll enabled.
10:17:41 Requested shared memory segment size rounded from 1096KB to 2048KB
10:17:42 IBM Informix Dynamic Server Version 11.50.FC3 Software Serial
Number AAA#B000000
10:17:43 Performance Advisory: The physical log size is smaller than the
recommended size for a
server configured with RTO_SERVER_RESTART.
10:17:43 Results: Fast recovery performance might not be optimal.
10:17:43 Action: For best fast recovery performance when
RTO_SERVER_RESTART is enabled,
increase the physical log size to at least 220000 KB. For servers
configured with a large buffer pool, this might not be necessary.
10:17:43 Assert Failed: Page Check Error in init_dbspace_pre_chunk
10:17:43 IBM Informix Dynamic Server Version 11.50.FC3
10:17:43 Who: Session(1, informix@dbtest, 0, 1384f3028)
Thread(7, main_loop(), 1384b0028, 3)
File: rsdebug.c Line: 1085
10:17:43 Results: Possible inconsistencies in '(null)'
10:17:43 stack trace for pid 4741 written to /nas99/informixdump/af.3ef49a6
10:17:43 See Also: /nas99/informixdump/af.3ef49a6, shmem.3ef49a6.0
10:17:57 Page Check Error in init_dbspace_pre_chunk
10:17:57 oninit: Fatal error in shared memory initialization
10:17:57 IBM Informix Dynamic Server Stopped.
After starting the instance once with the wrong version, the appropriate
version reports a "Page Check Error in init_dbspace_p
I didn't want to downgrade, I wanted to demonstrate how to destroy an
instance by starting it with the wrong IDS version accidently.
FYI,
Reinhard.
> -----Original Message-----
> From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org]On Behalf Of
> Hrvoje Zokovic
> Sent: Friday, June 19, 2009 11:35 PM
> To: ids@iiug.org
> Subject: Re: Start with wrong version destroys instance [16112]
>
>
> Reinhard,
>
> you can not do in-place downgrade. You must use onmode command
>
> to revert to older version.
>
> HTH
>
> Hrvoje
>
> Habichtsberg, Reinhard wrote:
>
> Hi Art,
>
> to verify the buggy behaviour I tested again. I have a clean
> instance named
>
> dbtest4_tli which was migrated in place from 9.40.FC9W2 to 11.50.FC3.
>
> The instance is runnig without problems, the migration had
> run without
>
> errors
>
> I stop this instance with onmode -yuk.
>
> Then I log into the system using the old 9.40 environment
> (PATH, INFORMIXDIR
>
> etc.) and start the instance with this wrong version of IDS.
>
> Start with IDS 9.40.FC9W2
>
> dbtest-db4:/home/informix%oninit -v
>
> Checking group membership to determine server run modesucceeded
>
> Reading configuration file
> '/app/lib/db1/etc/onconfig.db4'...succeeded
>
> Creating /INFORMIXTMP/.infxdirs ... succeeded
>
> Creating infos file "/app/lib/db1/etc/.infos.dbtest4_tli" ...
>
> "/app/lib/db1/etc/.conf.dbtest4_tli" ... succeeded
>
> Writing to infos file ... succeeded
>
> Checking config parameters...DS_TOTAL_MEMORY recalculated and
> changed from
>
> 100000Kb to 256000Kb
>
> succeeded
>
> Allocating and attaching to shared memory...succeeded
>
> Creating resident pool 500536 kbytes...succeeded
>
> Creating buffer pool 199998 kbytes...succeeded
>
> Creating buffer pool 6 kbytes...succeeded
>
> Initializing rhead structure...succeeded
>
> Initializing ASF ...succeeded
>
> Initializing Dictionary Cache and SPL Routine Cache...succeeded
>
> Bringing up ADM VP...succeeded
>
> Creating VP classes...succeeded
>
> Onlining 1 additional cpu vps...succeeded
>
> Onlining 1 IO vps...succeeded
>
> Initialization of Encryption...succeeded
>
> Forking main_loop thread...succeeded
>
> Initializing DR structures...succeeded
>
> Forking 1 'tlitcp' listener threads...succeeded
>
> Forking 1 'tlitcp' listener threads...succeeded
>
> Starting tracing...succeeded
>
> Initializing 32 flushers...succeeded
>
> Initializing log/checkpoint information...succeeded
>
> Opening primary chunks...oninit: Cannot open chunk '�.
> errno = 2
>
> Chunk �already exists.
>
> Primary reserved page is corrupt.
>
> FAILED
>
> oninit: Fatal error in shared memory initialization
>
> vi online4.log
>
> 10:12:59 IBM Informix Dynamic Server Started.
>
> 10:13:01 Requested shared memory segment size rounded from
> 100000KB to
>
> 100352KB
>
> Fri Jun 19 10:13:03 2009
>
> 10:13:03 Buffer manager: env variable TRACEFUZZYCKPT or TRACECKPT is
>
> defined. Checkpoints will be traced.
>
> 10:13:03 Event alarms enabled. ALARMPROG =
>
> '/opt/informix/etc/alarmprogram.sh'
>
> 10:13:03 Booting Language <c> from module <>
>
> 10:13:03 Loading Module <CNULL>
>
> 10:13:03 Booting Language <builtin> from module <>
>
> 10:13:03 Loading Module <BUILTINNULL>
>
> 10:13:08 IBM Informix Dynamic Server Version 9.40.FC9W2
> Software Serial
>
> Number AAA#B000000
>
> 10:13:09 Cannot Open Primary Chunk '^X\\\\3077]', errno = 2
>
> 10:13:09 IBM Informix Dynamic Server Stopped.
>
> 10:13:09 mt_shm_remove: WARNING: may not have removed
> all/correct segments
>
> ---------------------------------
>
> Next I try to start the instance with the appropriate IDS
> Version (PATH,
>
> INFORMIXDIR etc. checked):
>
> Start with IDS 11.50.FC3
>
> dbtest-db4_11:/home/informix%oninit -v
>
> Checking group membership to determine server run mode...succeeded
>
> Reading configuration file
>
> '/app/lib/ids11.50.FC3/etc/onconfig.dbtest4_11'...succeeded
>
> Creating /INFORMIXTMP/.infxdirs...succeeded
>
> Creating infos file
>
> "/app/lib/ids11.50.FC3/etc/.infos.dbtest4_tli"...succeeded
>
> Linking conf file
> "/app/lib/ids11.50.FC3/etc/.conf.dbtest4_tli"...succeeded
>
> Checking config parameters...succeeded
>
> Writing to infos file...succeeded
>
> Allocating and attaching to shared memory...succeeded
>
> Creating resident pool 539216 kbytes...succeeded
>
> Allocating 200016 kbytes for buffer pool of 2K page size...succeeded
>
> Initializing rhead structure...succeeded
>
> Initialization of Encryption...succeeded
>
> Initializing ASF...succeeded
>
> Initializing Dictionary Cache and SPL Routine Cache...succeeded
>
> Bringing up ADM VP...succeeded
>
> Creating VP classes...succeeded
>
> Onlining 1 additional cpu vps...succeeded
>
> Onlining 2 IO vps...succeeded
>
> Forking main_loop thread...succeeded
>
> WARNING: server initialization failed, or possibly timed out
> (if -w was
>
> used).
>
> Check the message log, online.log, for errors.
>
> vi online4_11.log:
>
> 10:17:34 IBM Informix Dynamic Server Started.
>
> 10:17:34 Requested shared memory segment size rounded from
> 748544KB to
>
> 753664KB
>
> 10:17:35 Segment locked: addr=10a000000, size=771751936
>
> 10:17:35 Requested shared memory segment size rounded from
> 100000KB to
>
> 131072KB
>
> 10:17:35 Segment locked: addr=138000000, size=134217728
>
> Fri Jun 19 10:17:36 2009
>
> 10:17:36 Event alarms enabled. ALARMPROG =
>
> '/app/lib/ids11.50.FC3/etc/log_full.sh'
>
> 10:17:36 Booting Language <c> from module <>
>
> 10:17:36 Loading Module <CNULL>
>
> 10:17:36 Booting Language <builtin> from module <>
>
> 10:17:36 Loading Module <BUILTINNULL>
>
> 10:17:36 SQLTRACE: SQL History Tracing set to 1000 SQL statements.
>
> 10:17:36 Warning: CONSOLE = /home/informix/console4_11 open failed.
>
> Redirecting output to '/dev/null'.
>
> 10:17:41 DR: DRAUTO is 0 (Off)
>
> 10:17:41 DR: ENCRYPT_HDR is 0 (HDR encryption Disabled)
>
> 10:17:41 Fast poll /dev/poll enabled.
>
> 10:17:41 Requested shared memory segment size rounded from
> 1096KB to 2048KB
>
> 10:17:42 IBM Informix Dynamic Server Version 11.50.FC3
> Software Serial
>
> Number AAA#B000000
>
> 10:17:43 Performance Advisory: The physical log size is
> smaller than the
>
> recommended size for a
>
> server configured with RTO_SERVER_RESTART.
>
> 10:17:43 Results: Fast recovery performance might not be optimal.
>
> 10:17:43 Action: For best fast recovery performance when
>
> RTO_SERVER_RESTART is enabled,>
> increase the physical log size to at least 220000 KB