HELP ontape -r : Physical restore failed
Posted in 2000
Topics: Backup & Restore, Storage & Space Management, Error Codes & Troubleshooting, Platform-Specific Issues
Hi all,
I wanted to restore from ontape and this error is showed !! (user:
root)
# ontape -r
... correcte ? etc ...
Physical restore failed - Cannot warm restore ROOT DBspace
I was then able to restore the dat dbspace by using ontape -r -D
dbsdat, but when I tried to open the database this error appears:
311: Cannot open system catalog (systables).
155: ISAM error: Primary and Mirror chunks are bad
on SuSE Linux 6.4, On7.30, tape device /dev/rmt0
Can anyone help me, please ? !!
Manel
according to my knowledge you cannot do a warm restore on a rootdbs.
you have to shut down the whole engine for a cold phycical restore.
shut down forced with onmode -ky
then
ontape -r
good luck
Manel Falc' <manel@semic.es> wrote in message
news:3939f61c.15637372@news.bcn.ttd.net...
> Hi all,
> I wanted to restore from ontape and this error is showed !! (user:
> root)
>
> # ontape -r
> ... correcte ? etc ...>
> Physical restore failed - Cannot warm restore ROOT DBspace
>
> I was then able to restore the dat dbspace by using ontape -r -D
> dbsdat, but when I tried to open the database this error appears:
>
> 311: Cannot open system catalog (systables).
> 155: ISAM error: Primary and Mirror chunks are bad>
> on SuSE Linux 6.4, On7.30, tape device /dev/rmt0
>
> Can anyone help me, please ? !!
>
> Manel
>
me stupid. Thanks Manel
"Manel Falcó" wrote:
>
> Hi all,
> I wanted to restore from ontape and this error is showed !! (user:
> root)
>
> # ontape -r
> ... correcte ? etc ...>
> Physical restore failed - Cannot warm restore ROOT DBspace
>
> I was then able to restore the dat dbspace by using ontape -r -D
> dbsdat, but when I tried to open the database this error appears:
>
> 311: Cannot open system catalog (systables).
> 155: ISAM error: Primary and Mirror chunks are bad>
> on SuSE Linux 6.4, On7.30, tape device /dev/rmt0
>
> Can anyone help me, please ? !!
If you restored dbsdat but said NO to the question about restoring logical
logs that dbspace and all of its chunks will be marked status 'I' for
Inconsistent. Informix restore is designed to recover a dbspace from tape
to it's latest condition using logical logs if it was damaged due to a
hardware failure. You cannot use it to back out changes as you seem to be
trying to do. You have two recourses. 1) restore again and restore all of
the requested logical logs. 2) call tech support and beg them to force the
chunks and dbspace to be marked to status Online. If you take the second
option note that you should unload the data, drop the tables, recreate and
reload. Even then any referential integrity of the tables that dbspace
contains and related tables in or out of that dbspace has been compromised.
Art S. Kagel