Level 0 Resotre problems
Posted in 2000
Topics: Backup & Restore, Storage & Space Management
I have created the same configuration with same sizes of dbspaces in a
new m/c as our production m/c. I am then restoring level-0 of the
production system in the new one. When I am doing ontape -r, It restored
the rootdbs fine. 2nd dbspace was also restored without any problem.
When the third dbspace was getting restored, it was hanging for some
time ( There was no activity in the hard disks and onstat -D was not
showing any increase in number of writes) and exited with the following
message.
'Physical restore failed. Function read archive backup failed.
code - 1 errno - 5'.
What is the reason for the failure?
When it is doing restore, I am seeing the following message with
onstat - command.
'Infx server 7.3 Fast Recovery (CKPT REQ) - Up 00.25:00 ,
Blocked CKPT'. Is it ok or anything to be done on this?
Thinking that the problem was with the tape, I tried another tape. Still
the same problem is occuring.
This is urgent, please.
Thanks
Sampath
In article <8hapcb$qc7$1@news.xmission.com>,
SAMPATH <sampath@gulfins.com.kw> wrote:
>
> I have created the same configuration with same sizes of dbspaces in a
> new m/c as our production m/c.
You do not have to create dbspaces in the new m/c (although there's
nothing wrong with that). The key is ensuring that the chunks are
identical (filenames, paths & sizes). Every single chunk!
Additionally, use identical ONCONFIG settings (with a few exceptions).
What about your OSes & Ifx versions? Are they identical? Minor
differences in the OS may be tolerated (although not recommended), but
your Informix versions must be identical.
> I am then restoring level-0 of the
> production system in the new one. When I am doing ontape -r, It
restored
> the rootdbs fine. 2nd dbspace was also restored without any problem.
> When the third dbspace was getting restored, it was hanging for some
> time ( There was no activity in the hard disks and onstat -D was not
> showing any increase in number of writes) and exited with the
following
> message.
>
> 'Physical restore failed. Function read archive backup failed.
> code - 1 errno - 5'.
>
> What is the reason for the failure?
>
> When it is doing restore, I am seeing the following message with
> onstat - command.
>
> 'Infx server 7.3 Fast Recovery (CKPT REQ) - Up 00.25:00 ,
> Blocked CKPT'. Is it ok or anything to be done on this?
This is normal.
>
> Thinking that the problem was with the tape, I tried another tape.
Still
> the same problem is occuring.
>
All the best.
Rudy
Sent via Deja.com http://www.deja.com/
Before you buy.
Related threads
- IDS 10 table-level restore
- Informix Development Webinar December 11, 2007
- ontape -p/r with changed ROOTPATH
- Migrate from HP PA-RISC to HP ITANIUM by ontape