Re: Problems installing Informix DS on ScoOpen 5
Posted in 1997
I had the same problem when installing Informix. This one took a long
weekend and many calls to Informix "tech" support!
We are running SCO OpenServer 5.0.4, so I do not know if all these
parameters are in the same place, but here is part of the EMail I sent to
Informix support...hoping that they would help future customers...
Problem
----------
oninit: Fatal error in initializing ASF with 'ASF_INIT_DATA' flags;
asfcode='-25580'.
Cannot start engine. This happens during install. Get the same error when
trying to start the engine at any time. The problem seems to be a tune
thing?
From the Informix installation notes and your EMail of past problems, I was
able to get the engine to "run" after manual changing of serveral files!
Solution
----------
NOTICE: It seems that you must edit the mtune, stune and config.h manually
to get SCO to use these values! I even had to add one of the parameters to
the stune file?
stune file (partial)
SEMMNI 2048
SEMMNS 2048
SEMMAP 2048
SEMMNU 100
SEMMSL 60
SHMMAX 671088640
mtune file (partial)
SEMMAP 10 10 8192
SEMMNI 10 10 8192
SEMMNS 60 60 2048
SEMMNU 30 10 100
SEMMSL 25 25 60
XSEMMAX 60 20 90
NOTICE: You must change the maximum values in mtune or stune will NOT
override!
config.h file (partial)
#define SEMMAP 2048
#define SEMMNI 2048
#define SEMMNS 2048
#define SEMMNU 100
#define SEMMSL 60
#define XSEMMAX 60
Steve
--
Ignorance can be cured!
scooper@thecompounders.com
xx <xx@xx.xx> wrote in article <01bcc929$a70b29a0$5a0a648b@ek.unique.no>...
> I'm running a ScoOpen 3.2v5.0.2 and I have installed an Informix Online
DS
> 7.22.UC3.
> The installation went ok, but when I run the command :
> oninit -iy> I receive the error message :
> oninit: Fatal error in initializing ASF with 'ASF_INIT_DATA' flags;
asfcode
> = '-
> 25580'.
>
> $
>
> The log (online.log) tells me :
> 22:27:25 Event alarms enabled. ALARMPROG = '/usr/informix/log_full.sh'
>
> 22:27:30 DR: DRAUTO is 0 (Off)
>
> 22:27:30 (2) failure, system out of semaphores
>
> $
>
>
> It looks like there is too little semaphore space available. I changed
the
> kernel parms to :
> SEMMAP: 8192
> SEMNI:8192
> SEMNU:100
> which are the recommended values given from Informix. I also changed
> SHMMAX to 409600000
> and then relinked the kernel.
>
> I still get these error messages and I'm running out of ideas.
>
> Any help will be highly appreciated!
>