>The error message returned from either prepared select statements or
>normally coded select statements are as follows :
>
>SQL statement error number -211
>Cannot read system catalog (systables).
>System error number -101.
>ISAM error: file is not open.>
>Any ideas/help would be much appreciated - this problem does not seem
>to occur when people are running 4.0 Online engine, but we are trying
>to encourage upgrading to 4.1 Online, so it is important that we
>track this one down.
>
I have had similar problem with a 4.1 engine, except in my case,
I was just trying to drop the old table. I'd suggest you unload
the table before playing this mukking about game. In fact, if unloading
is successful and/or reasonable, the cleanest method is to unload,
drop the old table, and load the rows into a new squeaky clean table.
To fix my problem, I created a new table with the same schema as the
one having the problems. I then switched the partnum column in systables,
and deleted the systables, syscolumns, and sysindexes for the tabid of
the new table, and then I was able to drop the old table.
Your mileage may vary.
Naomi
--
Naomi Walker (aka N7FSA) naomi%anasaz.UUCP@asuvax.eas.asu.edu
Enthusiasm is caught, In tennis,
not taught. love means nothing.