Failing to configure cdr replicas between 10.00FC9W2 and 11.50FC6
Posted in 2010
Topics: High Availability & Replication, Installation, Setup & Upgrades, Migration, Import/Export & Data Conversion
Hi,
first of all, have to say I'm pretty new to Informix...was coming from
Oracle world, at my new position we only have Informix so I'm having a
little bit of funny time getting use to it. But overall, I'm pretty
amazed with Informix.
Now, to my problem. We're in the process to migrate our current 10.00
installation with some replicas to 11.50. As first step we're trying
to upgrade the non-root nodes to 11.50 but we're facing some problems.
Let's name the nodes to try to keep things clear enough, please excuse
my terminology I'm sure I'm telling names that you might find wrong or
having nothing to do with Informix.
- Main node (leaf node??) -> suxdb and g_dbmain
- non root node -> sux11 (g_sux11)
I have set up a server cloned from a production one to do the tests
(sux11), have dropped syscdr database and defined it on the main
server (suxdb) as a new node, included it on the replicasets and
everything worked as expected on 10.00FC9W2. Once everything was set
up, took down the instance, upgraded to 11.50FC6 and now I can't get
cdr to re-connect the server, the migration process didn't report any
error.
Once the instance was in quiescent mode, I shut it down and got it up
with 'oninit -D', once started properly I tried issuing a 'cdr start'
on the sux11 and it produced the following messages on the main
server's online.log:
18:12:47 CDR: Re-connected to server, id 2000, name <g_sux11>
18:12:48 CDR connection to server lost, id 2000, name <g_sux11>Reason: disconnect server
Trying to connect from main server to the node using 'cdr connect
server -c g_sux11 g_sux11' gives me a message...my boss wouldn't like
to see... ;)
connect to g_sux11 failed
This feature of Enterprise Replication is not yet supported. (101)
command failed -- unable to connect to server specified (5)
This is the same message I got when tried to delete the server
definition and re-define it as non-root node. Getting these messages,
I got the feeling that what I'm trying to achieve is not really
supported....hope to be wrong.
Thanks in advance, I'm also trying to get in touch with IBM support to
see if they could throw some light on this set up....
Sergio.
On May 4, 11:38 am, TripleDES <triple...@gmail.com> wrote:
> Hi,
>
> first of all, have to say I'm pretty new to Informix...was coming from
> Oracle world, at my new position we only have Informix so I'm having a
> little bit of funny time getting use to it. But overall, I'm pretty
> amazed with Informix.
>
> Now, to my problem. We're in the process to migrate our current 10.00
> installation with some replicas to 11.50. As first step we're trying
> to upgrade the non-root nodes to 11.50 but we're facing some problems.
> Let's name the nodes to try to keep things clear enough, please excuse
> my terminology I'm sure I'm telling names that you might find wrong or
> having nothing to do with Informix.
>
> - Main node (leaf node??) -> suxdb and g_dbmain
> - non root node -> sux11 (g_sux11)
>
> I have set up a server cloned from a production one to do the tests
> (sux11), have dropped syscdr database and defined it on the main
> server (suxdb) as a new node, included it on the replicasets and
> everything worked as expected on 10.00FC9W2. Once everything was set
> up, took down the instance, upgraded to 11.50FC6 and now I can't get
> cdr to re-connect the server, the migration process didn't report any
> error.
>
> Once the instance was in quiescent mode, I shut it down and got it up
> with 'oninit -D', once started properly I tried issuing a 'cdr start'
> on the sux11 and it produced the following messages on the main
> server's online.log:
>
> 18:12:47 CDR: Re-connected to server, id 2000, name <g_sux11>
> 18:12:48 CDR connection to server lost, id 2000, name <g_sux11>> Reason: disconnect server
>
> Trying to connect from main server to the node using 'cdr connect
> server -c g_sux11 g_sux11' gives me a message...my boss wouldn't like
> to see... ;)
>
> connect to g_sux11 failed
> This feature of Enterprise Replication is not yet supported. (101)
> command failed -- unable to connect to server specified (5)
>
> This is the same message I got when tried to delete the server
> definition and re-define it as non-root node. Getting these messages,
> I got the feeling that what I'm trying to achieve is not really
> supported....hope to be wrong.
>
> Thanks in advance, I'm also trying to get in touch with IBM support to
> see if they could throw some light on this set up....
>
> Sergio.
If I understand what you are saying, I think you've possibly missed
some steps. So you set up a new server and got ER working with it
under version 10.x...you then brought it off-line, got all instance
set up pointing at a new 11.50 install place and then brought it up
with oninit -D. I believe at this point you need to do a conversion
on your syscdr database. Check out
http://publib.boulder.ibm.com/infocenter/idshelp/v115/index.jsp?topic=/com.ibm.mig.doc/ids_mig_056.htm
for more info. Sorry if you have already done this after before/after
bringing the instance up with the new 11.50 product.
Jacques Renaut
IBM Informix Advanced Support
APD Team
On May 4, 8:47 pm, jrenaut <jpren...@yahoo.com> wrote:
> On May 4, 11:38 am, TripleDES <triple...@gmail.com> wrote:
>
>
>
> > Hi,
>
> > first of all, have to say I'm pretty new to Informix...was coming from
> > Oracle world, at my new position we only have Informix so I'm having a
> > little bit of funny time getting use to it. But overall, I'm pretty
> > amazed with Informix.
>
> > Now, to my problem. We're in the process to migrate our current 10.00
> > installation with some replicas to 11.50. As first step we're trying
> > to upgrade the non-root nodes to 11.50 but we're facing some problems.
> > Let's name the nodes to try to keep things clear enough, please excuse
> > my terminology I'm sure I'm telling names that you might find wrong or
> > having nothing to do with Informix.
>
> > - Main node (leaf node??) -> suxdb and g_dbmain
> > - non root node -> sux11 (g_sux11)
>
> > I have set up a server cloned from a production one to do the tests
> > (sux11), have dropped syscdr database and defined it on the main
> > server (suxdb) as a new node, included it on the replicasets and
> > everything worked as expected on 10.00FC9W2. Once everything was set
> > up, took down the instance, upgraded to 11.50FC6 and now I can't get
> > cdr to re-connect the server, the migration process didn't report any
> > error.
>
> > Once the instance was in quiescent mode, I shut it down and got it up
> > with 'oninit -D', once started properly I tried issuing a 'cdr start'
> > on the sux11 and it produced the following messages on the main
> > server's online.log:
>
> > 18:12:47 CDR: Re-connected to server, id 2000, name <g_sux11>
> > 18:12:48 CDR connection to server lost, id 2000, name <g_sux11>> > Reason: disconnect server
>
> > Trying to connect from main server to the node using 'cdr connect
> > server -c g_sux11 g_sux11' gives me a message...my boss wouldn't like
> > to see... ;)
>
> > connect to g_sux11 failed
> > This feature of Enterprise Replication is not yet supported. (101)
> > command failed -- unable to connect to server specified (5)
>
> > This is the same message I got when tried to delete the server
> > definition and re-define it as non-root node. Getting these messages,
> > I got the feeling that what I'm trying to achieve is not really
> > supported....hope to be wrong.
>
> > Thanks in advance, I'm also trying to get in touch with IBM support to
> > see if they could throw some light on this set up....
>
> > Sergio.
>
> If I understand what you are saying, I think you've possibly missed
> some steps. So you set up a new server and got ER working with it
> under version 10.x...you then brought it off-line, got all instance
> set up pointing at a new 11.50 install place and then brought it up
> with oninit -D. I believe at this point you need to do a conversion
> on your syscdr database. Check outhttp://publib.boulder.ibm.com/infocenter/idshelp/v115/index.jsp?topic...
> for more info. Sorry if you have already done this after before/after
> bringing the instance up with the new 11.50 product.
>
> Jacques Renaut
> IBM Informix Advanced Support
> APD Team
Thank you so much Jacques!
That seemed to do the trick!
I've been trying to open a ticket request on IBM support but was
having trouble to access to the site, my firefox says something about
an infinite redirection and doesn't load the site....but we're good to
go now! we'll do further testing.
Again, thank you.
Sergio.