In-house app causing segmentation violation
Posted in 1999
Topics: Installation, Setup & Upgrades, Error Codes & Troubleshooting, Connectivity: ESQL/C, 4GL & Embedded SQL, Versions, Editions & End-of-Life
This message is in MIME format. Since your mail reader does not understand
this format, some or all of this message may not be legible.
------_=_NextPart_000_01BE63DA.ADD1CFB0
Content-Type: text/plain;
charset="iso-8859-1"
Hi!
An in-house application we have is causing our database instance to crash
with the following being added to the /tmp/af80f9f583 file:
22:03:47
22:03:47 Assert Failed: Internal Error - Segmentation Violation
22:03:47 Who: Session(8248, tracpmgr@hydrogen.ppsl.com, 11257, 141101656)
Thread(33017, sqlexec, 20866dee8, 1)
22:03:47 Results: OnLine must abort
22:03:47 Action: Reinitialize shared memory
22:03:47 See Also: /tmp/af.80f9f583, shmem.80f9f583.0
22:03:47 Stack for thread: 33017 sqlexec
base: 0x000000020b138028
len: 66560
pc: 0x000000012042e798
tos: 0x000000020b147410
[1] 0x000000002042ddb0 mt_affail()
[2] 0x0000000020273828 rsam_affail()
[3] 0x00000000200c112c hang_thread()
[4] 0x00000000200c0e84 afsig_segv()
[5] 0x00000000800d5db4 ***unknown***()
[6] 0x000000002017bb20 mknulldata()
[7] 0x000000002017bb20 mknulldata()
[8] 0x000000002017bf50 initrow()
[9] 0x000000002017bfc0 inittuple()
[10] 0x00000000201349e4 doinsert()
[11] 0x00000000200c82b8 aud_doinsert()
[12] 0x000000002012ef7c excommand()
[13] 0x00000000201e6c34 sq_execute()
[14] 0x00000000201a83d8 sqmain()
[15] 0x00000000204459e0 startup()
22:04:21
------------------ End of assertion failure 0 -----------------
Can anyone tell me where I can look to find help on interpreting the assert
fail output above, or provide some initial guidance as to what I should look
for in my program? Basically, this program ran fine in our old Informix
environment, which is Tools (4GL, SQL) 4.13.UD1 and OnLine 5.05.UC1. We
upgraded in December 1998 to Tools 6.05.UD1 and IDS 7.23.FC4, and the
program recompiled without any changes. The program is run on the last day
of every month. When we manually run it, it crashed the instances on our
test and production servers, but not all the time. When it ran as a cronjob
for the first time on Dec. 31 1998, it crashed the server; but when we
re-ran it as a cronjob in the first week in January, it completed
successfully. Last night, it crashed the instance again when it ran as a
cronjob.
Any help will be greatly appreciated.
Best regards,
Edmund Nigel Gall
Information Systems Specialist
Process Plant Services Limited
Atlantic Avenue, Point Lisas Industrial Estate
Point Lisas, Couva, Trinidad & Tobago, W.I.
Tel: (868) 636 3153 Fax: (868) 679 3770
------_=_NextPart_000_01BE63DA.ADD1CFB0
Content-Type: application/ms-tnef
Content-Transfer-Encoding: base64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Nigel Gall wrote:
>
> This message is in MIME format. Since your mail reader does not understand
> this format, some or all of this message may not be legible.
>
> ------_=_NextPart_000_01BE63DA.ADD1CFB0
> Content-Type: text/plain;
> charset="iso-8859-1"
>
> Hi!
>
> An in-house application we have is causing our database instance to crash
> with the following being added to the /tmp/af80f9f583 file:
>
> 22:03:47
> 22:03:47 Assert Failed: Internal Error - Segmentation Violation
> 22:03:47 Who: Session(8248, tracpmgr@hydrogen.ppsl.com, 11257, 141101656)
> Thread(33017, sqlexec, 20866dee8, 1)
> 22:03:47 Results: OnLine must abort
> 22:03:47 Action: Reinitialize shared memory
> 22:03:47 See Also: /tmp/af.80f9f583, shmem.80f9f583.0
> 22:03:47 Stack for thread: 33017 sqlexec>
> base: 0x000000020b138028
> len: 66560
> pc: 0x000000012042e798
> tos: 0x000000020b147410
>
> [1] 0x000000002042ddb0 mt_affail()
> [2] 0x0000000020273828 rsam_affail()
> [3] 0x00000000200c112c hang_thread()
> [4] 0x00000000200c0e84 afsig_segv()
> [5] 0x00000000800d5db4 ***unknown***()
> [6] 0x000000002017bb20 mknulldata()
> [7] 0x000000002017bb20 mknulldata()
> [8] 0x000000002017bf50 initrow()
> [9] 0x000000002017bfc0 inittuple()
> [10] 0x00000000201349e4 doinsert()
> [11] 0x00000000200c82b8 aud_doinsert()
> [12] 0x000000002012ef7c excommand()
> [13] 0x00000000201e6c34 sq_execute()
> [14] 0x00000000201a83d8 sqmain()
> [15] 0x00000000204459e0 startup()
>
> 22:04:21
> ------------------ End of assertion failure 0 -----------------
>
> Can anyone tell me where I can look to find help on interpreting the assert
> fail output above, or provide some initial guidance as to what I should look
> for in my program? Basically, this program ran fine in our old Informix
> environment, which is Tools (4GL, SQL) 4.13.UD1 and OnLine 5.05.UC1. We
> upgraded in December 1998 to Tools 6.05.UD1 and IDS 7.23.FC4, and the
> program recompiled without any changes. The program is run on the last day
> of every month. When we manually run it, it crashed the instances on our
> test and production servers, but not all the time. When it ran as a cronjob
> for the first time on Dec. 31 1998, it crashed the server; but when we
> re-ran it as a cronjob in the first week in January, it completed
> successfully. Last night, it crashed the instance again when it ran as a
> cronjob.
Sounds like array boundary or other memory corruption problems. It
does not always crash because the nature and extent of the memory
corruption it causes is data dependent.
For now try compiling with debugging and change the connection the
application uses from shared memory to a network connection (4GL 6.xx
cannot use stream pipe connections) which will prevent it from directly
corrupting the server's memory and should cause the application to
core dump instead. Then you can debug the post mortum.
Art S. Kagel
Related threads
- Conversion to differeent characters sets
- Problem in changing locale via dbexport/dbimport
- RE: openlink error "Unable to load locale categories"