logging change error
Posted in 2000
Topics: Backup & Restore, Server Administration, Migration, Import/Export & Data Conversion
Hi
I am a new Informix DBA - and have never use Informix before :) (I have an
Oracle background)
Yesterday I dbimported a database (ausatst -thank god it is a test database,
but still v. important at this stage of the project). I had not set logging
on (didn't know I had to) and had to go to a meeting. The PeopleSoft
administrator (my backup) attempted to set logging on with "ontape -s -U
ausatst" and encountered some sort of error. I think he may have done a
level 2 ontape.
Anyway the present situation is that onmonitor reports a logging status of
N. Any attempt to alter the logging status results in the following error
informix:ps7testshm@zircon>ontape -s -U aufstst
Error changing logging status - 'aufstst'. iserrno 107.
I have attempted to do "ontape -s -N ausatst" with the same result.
ontape -s -B ausatst gives the result "invalid logging change" or some verysimilar error. I have dropped and reimported the database. I have stopped
and resarted the instance. The docos refer to an onarchive command that
stops a partly completed logging change but we don't use onarchive and it
doesn't run - I tried it.
Any help greatfull appreciated. As I do not have newsgroup access at work
please reply to k.hewlett@auckland.ac.nz Thank you.
Karl Hewlett
PeopleSoft DBA
University of Auckland
New Zealand
A session has a lock on the database.
You need to remove the lock.
Stop PeopleSoft, bring Informix to "Quiescent Mode" onmode -sy,
run ondblog unbuf aufstst,
onbar -b -F,
onmode -m,start PeopleSoft.
"Karl Hewlett" <kzhw@xtra.co.nz> wrote in message
news:bfIh5.520$SSb8.1311082@news.xtra.co.nz...
> Hi
>
> I am a new Informix DBA - and have never use Informix before :) (I have an
> Oracle background)
>
> Yesterday I dbimported a database (ausatst -thank god it is a test
database,
> but still v. important at this stage of the project). I had not set
logging
> on (didn't know I had to) and had to go to a meeting. The PeopleSoft
> administrator (my backup) attempted to set logging on with "ontape -s -U
> ausatst" and encountered some sort of error. I think he may have done a
> level 2 ontape.
>
> Anyway the present situation is that onmonitor reports a logging status of
> N. Any attempt to alter the logging status results in the following error
>
> informix:ps7testshm@zircon>ontape -s -U aufstst
> Error changing logging status - 'aufstst'. iserrno 107.
>
>
> I have attempted to do "ontape -s -N ausatst" with the same result.
> ontape -s -B ausatst gives the result "invalid logging change" or somevery
> similar error. I have dropped and reimported the database. I have
stopped
> and resarted the instance. The docos refer to an onarchive command that
> stops a partly completed logging change but we don't use onarchive and it
> doesn't run - I tried it.
>
> Any help greatfull appreciated. As I do not have newsgroup access at work
> please reply to k.hewlett@auckland.ac.nz Thank you.
>
> Karl Hewlett
> PeopleSoft DBA
> University of Auckland
> New Zealand
>
>
Hi
Thanks for your help people.
The problem turned out to be that there was a service starting
automatically - I had a user logged on as far as Informix knew. I did an
onmode -s ...
All happy now :)
Karl
Karl Hewlett <kzhw@xtra.co.nz> wrote in message
news:bfIh5.520$SSb8.1311082@news.xtra.co.nz...
> Hi
>
> I am a new Informix DBA - and have never use Informix before :) (I have an
> Oracle background)
>
> Yesterday I dbimported a database (ausatst -thank god it is a test
database,
> but still v. important at this stage of the project). I had not set
logging
> on (didn't know I had to) and had to go to a meeting. The PeopleSoft
> administrator (my backup) attempted to set logging on with "ontape -s -U
> ausatst" and encountered some sort of error. I think he may have done a
> level 2 ontape.
>
> Anyway the present situation is that onmonitor reports a logging status of
> N. Any attempt to alter the logging status results in the following error
>
> informix:ps7testshm@zircon>ontape -s -U aufstst
> Error changing logging status - 'aufstst'. iserrno 107.
>
>
> I have attempted to do "ontape -s -N ausatst" with the same result.
> ontape -s -B ausatst gives the result "invalid logging change" or somevery
> similar error. I have dropped and reimported the database. I have
stopped
> and resarted the instance. The docos refer to an onarchive command that
> stops a partly completed logging change but we don't use onarchive and it
> doesn't run - I tried it.
>
> Any help greatfull appreciated. As I do not have newsgroup access at work
> please reply to k.hewlett@auckland.ac.nz Thank you.
>
> Karl Hewlett
> PeopleSoft DBA
> University of Auckland
> New Zealand
>
>