Re: Online 4.0 tbcheck error
Posted in 1994
In article <NICLAS.94Dec7151556@liza.appli.se> niclas@liza.appli.se (Niclas Bj|rkdahl) writes: >We are using Informix Online 4.0 on a HP 9000/822 with HP-UX A.B7.08 C. >When running tbcheck -cc befreg we get the following error: > >Validating database befreg > > Validating systables for database befreg >ERROR: informix.befolkningsreg nextsize 8 != partition.nxtsize 16 Well, I hope you haven't already re-built your table, because this is really a very minor error. This is probably caused by the automatic extent doubling that OnLine does when your table reaches a certain number of extents (which I can never remember, and also depends on the version of OnLine). When OnLine doubled your extent size, it forgot to put the new extent size in your systables entry, and only changed it in your partition. It only uses the value in your partition, so the fact that it's wrong in systables is totally irrelevant, except to you and tbcheck. If you REALLY want to, I suppose you can update systables as user informix and set it to 16, but personally, I would just ignore it. This is a bug (can't remember the number), and has been fixed in later versions of OnLine, but again, it really doesn't matter. June ---- June Tong Informix Software ---- ---- junet@informix.com On-Site Regency Support at SAP ---- ---- Informix: (415)926-6140 SAP: (415)286-6808 ----