Re: unloading a HUGE 32Go table
Posted in 2000
Topics: Storage & Space Management, Stored Procedures & SPL, Server Administration, Migration, Import/Export & Data Conversion, Platform-Specific Issues
dbaccess - output to pipe - split (1)
brett
In article <39A16D63.34D7C8F2@none.net>, Sebastien.THOMAS@none.net
says...
> Hi,
>
> I need to unload a 32Go table (16.000.000 rows). I'm having a sort of 2go
> limitation problem.
> In fact I'm on solaris 2.6, with Largefile enabled.
>
> This is what I noticed :
>
> -ipload can't load a such table by itself. he can't automaticaly fragment the
> output to multiple files. Informix SHOULD have include this feature !
> -ipload is not Largefile compliant
> -The french hotline (support) don't know what to do with a such table.
>
> As the table dbschema is quite complex, I can't find anything but "rowid" row
> for splitting my select.
> The problem is that the rowid number go from 256 to 2.451.000.000 for
> 16.000.000 rows.
> I tried to unload the rowid row this way :
> select rowid from vbap
> and choosing output to text file in dbaccess.>
> I finaly have a file of 16.000.000 lines (good) but half of the rowis numbers
> are minus numbers : "-17.001.458.255"
>
> What am I supposed to do with this kind of output ??
>
> Is there a simple good way for unloading this rows in different files ????
>
>
> Prasad Mahale wrote:
>
> > David,
> > Run ls -l and check the size of file you are trying to unload. It should be
> > around 2GB. This means that your operating system does not support a single
> > file size more than 2GB. Try splitting your unload statement by putting some
> > where condition on date or column so that the single file will not exceed
> > 2GB limit.
> >
> > >From: David Kulkarni <dnk61@yahoo.com>
> > >To: informix-list@iiug.org
> > >Subject: unloading a table
> > >Date: Mon, 14 Aug 2000 14:33:26 -0700 (PDT)
> > >
> > >On Informix ver. 5.10UC5 (OS HP-UX 10.20)
> > >
> > >I am trying to unload a table that has 24570444 rows but it keeps failing
> > >giving me the following
> > >error message:
> > >
> > >Write failed. 16794517 rows unloaded (check ulimit or disk space).
On Tue, 22 Aug 2000 08:13:41 +0200, bofh@mailbox.co.za (bob) wrote:
>dbaccess - output to pipe - split (1)
>
Or pipe into compress or gzip or bzip2.
HTH, Paul
Paul Sherwin Consulting 22 Monmouth Road, Oxford OX1 4TD, UK
Phone +44 (0)1865 721438 http://www.psherwin.strayduck.com
Mobile +44 (0)7931 578334 mailto:psherwin@strayduck.com
Pager +44 (0)7666 797228