Fatal Error
Posted in 2000
Topics: Installation, Setup & Upgrades
after installing Informix-Online 7.24 on a sparc2 I am unable to initialize the database. When trying to initialize I get the following error in onmonitor: Unable to attach to shared memory unknown error message -156 after looking in the online.log file I see that shared memory already exists and that it cannot create a resident segment. What does this mean and how can I resolve this? thanks in advance for any help Mike Sent via Deja.com http://www.deja.com/ Before you buy.
It is possible that there is already an Informix engine with the same
SERVERNUM in its onconfig/tbconfig file running on that machine. If so (try
ps -ef| egrep 'tbinit|oninit' to see) change your SERVERNUM for this new
server so this engine will get a different shared memory key value and not
clash with the existing engine. If there is not other Informix running then
it may be that you have tried oninit -i previously and it failed for some
other reason but did not remove its shared memory on the way down. This
often happens during failed initializations because the oninit has not yet
set up its own data structures used to know what to shut down. Try:
ipcs |fgrep informix
and see if there is indeed shared memory or semaphores allocated by a
previous startup attempt. If so you can try running onmode -ky which should
remove these segments. If they are still there they can be removed manually
using ipcrm -m <id> or ipcrm -M <key> for each segment. If there are not
any segments make sure that you have built a kernel with the recommended
values in the release notes to permit enough shared memory to be allocated.
See the files in $INFORMIXDIR/release/*/* for details.
Art S. Kagel
eeb4u@my-deja.com wrote:
>
> after installing Informix-Online 7.24 on a sparc2 I am unable to
> initialize the database. When trying to initialize I get the following
> error in onmonitor:
>
> Unable to attach to shared memory
> unknown error message -156
>
> after looking in the online.log file I see that shared memory already
> exists and that it cannot create a resident segment. What does this
> mean and how can I resolve this?
>
> thanks in advance for any help
>
> Mike
>
> Sent via Deja.com http://www.deja.com/
> Before you buy.
I did find an informix entry when using ipcs command (I'm learning new
commands everyday :->). I since removed this to find that the
initialization still fails. The online.log now states that I am out of
shared memory segments and to check SHMSEG. I looked in the onconfig
file but cannot find SHMSEG. I am unsure about what size SHMADD and
SHMVIRTSIZE should be. I only want to run the demo dbase that comes
with Informix to learn SQL.
Thanks for your prompt response. Any help apprecated.
Mike
In article <39367546.D709FCAD@bloomberg.net>,
kagel@bloomberg.net wrote:
> It is possible that there is already an Informix engine with the same
> SERVERNUM in its onconfig/tbconfig file running on that machine. If
so (try
> ps -ef| egrep 'tbinit|oninit' to see) change your SERVERNUM for this
new
> server so this engine will get a different shared memory key value
and not
> clash with the existing engine. If there is not other Informix
running then
> it may be that you have tried oninit -i previously and it failed for
some
> other reason but did not remove its shared memory on the way down.
This
> often happens during failed initializations because the oninit has
not yet
> set up its own data structures used to know what to shut down. Try:
> ipcs |fgrep informix
> and see if there is indeed shared memory or semaphores allocated by a
> previous startup attempt. If so you can try running onmode -ky which
should
> remove these segments. If they are still there they can be removed
manually
> using ipcrm -m <id> or ipcrm -M <key> for each segment. If there are
not
> any segments make sure that you have built a kernel with the
recommended
> values in the release notes to permit enough shared memory to be
allocated.
> See the files in $INFORMIXDIR/release/*/* for details.
>
> Art S. Kagel
>
> eeb4u@my-deja.com wrote:
> >
> > after installing Informix-Online 7.24 on a sparc2 I am unable to
> > initialize the database. When trying to initialize I get the
following
> > error in onmonitor:
> >
> > Unable to attach to shared memory
> > unknown error message -156
> >
> > after looking in the online.log file I see that shared memory
already
> > exists and that it cannot create a resident segment. What does this
> > mean and how can I resolve this?
> >
> > thanks in advance for any help
> >
> > Mike
> >
> > Sent via Deja.com http://www.deja.com/
> > Before you buy.
>
Sent via Deja.com http://www.deja.com/
Before you buy.
eeb4u@my-deja.com wrote:
> I did find an informix entry when using ipcs command (I'm learning new
> commands everyday :->). I since removed this to find that the
> initialization still fails. The online.log now states that I am out of
> shared memory segments and to check SHMSEG. I looked in the onconfig
> file but cannot find SHMSEG. I am unsure about what size SHMADD and
> SHMVIRTSIZE should be. I only want to run the demo dbase that comes
> with Informix to learn SQL.
>
SHMSEG is a UNIX kernel configuration parameter. As I suspected, and noted
in
my last post, you have not properly configured a kernel to run Informix.
Your
current kernel does not permit large enough shared memory segments to be
created
to support the engine's needs. There are a bunch of release notes files in
$INFORMIXDIR/release/*/* (subdir names are environment dependent) that
contain notes about running IDS on your platform. Look in the file
SERVERS_7.2
and ONLINE_7.2 for recommended kernel settings. Take these values as
MINIMUMS, they are not magic but just the values that the Informix testers
were
able to use successfully, larger values where practical are usually fine.
Once you
have reconfigured, built a new kernel, and rebooted with the new kernel you
should
be able to start the engine.
Art S. Kagel
>
>
> In article <39367546.D709FCAD@bloomberg.net>,
> kagel@bloomberg.net wrote:
> > It is possible that there is already an Informix engine with the same
> > SERVERNUM in its onconfig/tbconfig file running on that machine. If
> so (try
> > ps -ef| egrep 'tbinit|oninit' to see) change your SERVERNUM for this
> new
> > server so this engine will get a different shared memory key value
> and not
> > clash with the existing engine. If there is not other Informix
> running then
> > it may be that you have tried oninit -i previously and it failed for
> some
> > other reason but did not remove its shared memory on the way down.
> This
> > often happens during failed initializations because the oninit has
> not yet
> > set up its own data structures used to know what to shut down. Try:
> > ipcs |fgrep informix
> > and see if there is indeed shared memory or semaphores allocated by a
> > previous startup attempt. If so you can try running onmode -ky which
> should
> > remove these segments. If they are still there they can be removed
> manually
> > using ipcrm -m <id> or ipcrm -M <key> for each segment. If there are
> not
> > any segments make sure that you have built a kernel with the
> recommended
> > values in the release notes to permit enough shared memory to be
> allocated.
> > See the files in $INFORMIXDIR/release/*/* for details.
> >
> > Art S. Kagel
> >
> > eeb4u@my-deja.com wrote:
> > >
> > > after installing Informix-Online 7.24 on a sparc2 I am unable to
> > > initialize the database. When trying to initialize I get the
> following
> > > error in onmonitor:
> > >
> > > Unable to attach to shared memory
> > > unknown error message -156
> > >
> > > after looking in the online.log file I see that shared memory
> already
> > > exists and that it cannot create a resident segment. What does this
> > > mean and how can I resolve this?
> > >
> > > thanks in advance for any help
> > >
> > > Mike
> > >
> > > Sent via Deja.com http://www.deja.com/
> > > Before you buy.
> >
>
> Sent via Deja.com http://www.deja.com/
> Before you buy.
eeb4u@my-deja.com wrote:
> I did find an informix entry when using ipcs command (I'm learning new
> commands everyday :->). I since removed this to find that the
> initialization still fails. The online.log now states that I am out of
> shared memory segments and to check SHMSEG. I looked in the onconfig
> file but cannot find SHMSEG. I am unsure about what size SHMADD and
> SHMVIRTSIZE should be. I only want to run the demo dbase that comes
> with Informix to learn SQL.
SHMSEG is a UNIX kernel configuration parameter. As I suspected, and noted
in
my last post, you have not properly configured a kernel to run Informix.
Your
current kernel does not permit large enough shared memory segments to be
created
to support the engine's needs. There are a bunch of release notes files in
$INFORMIXDIR/release/*/* (subdir names are environment dependent) that
contain notes about running IDS on your platform. Look in the file
SERVERS_7.2
and ONLINE_7.2 for recommended kernel settings. Take these values as
MINIMUMS, they are not magic but just the values that the Informix testers
were
able to use successfully, larger values where practical are usually fine.
Once you
have reconfigured, built a new kernel, and rebooted with the new kernel you
should
be able to start the engine.
Art S. Kagel
>
>
> In article <39367546.D709FCAD@bloomberg.net>,
> kagel@bloomberg.net wrote:
> > It is possible that there is already an Informix engine with the same
> > SERVERNUM in its onconfig/tbconfig file running on that machine. If
> so (try
> > ps -ef| egrep 'tbinit|oninit' to see) change your SERVERNUM for this
> new
> > server so this engine will get a different shared memory key value
> and not
> > clash with the existing engine. If there is not other Informix
> running then
> > it may be that you have tried oninit -i previously and it failed for
> some
> > other reason but did not remove its shared memory on the way down.
> This
> > often happens during failed initializations because the oninit has
> not yet
> > set up its own data structures used to know what to shut down. Try:
> > ipcs |fgrep informix
> > and see if there is indeed shared memory or semaphores allocated by a
> > previous startup attempt. If so you can try running onmode -ky which
> should
> > remove these segments. If they are still there they can be removed
> manually
> > using ipcrm -m <id> or ipcrm -M <key> for each segment. If there are
> not
> > any segments make sure that you have built a kernel with the
> recommended
> > values in the release notes to permit enough shared memory to be
> allocated.
> > See the files in $INFORMIXDIR/release/*/* for details.
> >
> > Art S. Kagel
> >
> > eeb4u@my-deja.com wrote:
> > >
> > > after installing Informix-Online 7.24 on a sparc2 I am unable to
> > > initialize the database. When trying to initialize I get the
> following
> > > error in onmonitor:
> > >
> > > Unable to attach to shared memory
> > > unknown error message -156
> > >
> > > after looking in the online.log file I see that shared memory
> already
> > > exists and that it cannot create a resident segment. What does this
> > > mean and how can I resolve this?
> > >
> > > thanks in advance for any help
> > >
> > > Mike
> > >
> > > Sent via Deja.com http://www.deja.com/
> > > Before you buy.
> >
>
> Sent via Deja.com http://www.deja.com/
> Before you buy.
Related threads
- Re: Newbie : Main differences between informix and others SGDB
- Restore certain Logical Logs
- instalacion de informix